Upstream information

CVE-2018-5345 at MITRE

Description

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious attackers to cause a crash or, potentially, execute arbitrary code via a crafted .cab file.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1075745

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15
  • gcab >= 1.1-1.15
  • gcab-devel >= 1.1-1.15
  • gcab-lang >= 1.1-1.15
  • libgcab-1_0-0 >= 1.1-1.15
  • typelib-1_0-GCab-1_0 >= 1.1-1.15
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA gcab
openSUSE Leap 15.0
  • gcab >= 1.1-lp150.1.2
  • gcab-lang >= 1.1-lp150.1.2
  • libgcab-1_0-0 >= 1.1-lp150.1.2
Patchnames:
openSUSE Leap 15.0 GA gcab