Upstream information

CVE-2018-5208 at MITRE

Description

In Irssi before 1.0.6, a calculation error in the completion code could cause a heap buffer overflow when completing certain strings.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1074958 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.2
  • irssi >= 1.0.6-14.18.1
  • irssi-debuginfo >= 1.0.6-14.18.1
  • irssi-debugsource >= 1.0.6-14.18.1
  • irssi-devel >= 1.0.6-14.18.1
Patchnames:
openSUSE-2018-18
openSUSE Leap 42.3
  • irssi >= 1.0.6-21.1
  • irssi-debuginfo >= 1.0.6-21.1
  • irssi-debugsource >= 1.0.6-21.1
  • irssi-devel >= 1.0.6-21.1
Patchnames:
openSUSE-2018-18