Upstream information

CVE-2018-4700 at MITRE

Description

** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2018-4300. Reason: This candidate is a duplicate of CVE-2018-4300. Notes: All CVE users should reference CVE-2018-4300 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7.5
Vector AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1115750 [RESOLVED / FIXED], 1131480 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12 SP3
  • cups >= 1.7.5-20.20.1
  • cups-ddk >= 1.7.5-20.20.1
Patchnames:
SUSE-SLE-BSK-12-SP3-2018-2917
SUSE Linux Enterprise Build System Kit 12 SP4
  • cups >= 1.7.5-20.20.1
  • cups-ddk >= 1.7.5-20.20.1
Patchnames:
SUSE-SLE-BSK-12-SP4-2018-2917
SUSE Linux Enterprise Desktop 12 SP3
  • cups >= 1.7.5-20.20.1
  • cups-client >= 1.7.5-20.20.1
  • cups-libs >= 1.7.5-20.20.1
  • cups-libs-32bit >= 1.7.5-20.20.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2917
SUSE Linux Enterprise Desktop 12 SP4
  • cups >= 1.7.5-20.20.1
  • cups-client >= 1.7.5-20.20.1
  • cups-libs >= 1.7.5-20.20.1
  • cups-libs-32bit >= 1.7.5-20.20.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2018-2917
SUSE Linux Enterprise Module for Basesystem 15
  • cups >= 2.2.7-3.6.1
  • cups-client >= 2.2.7-3.6.1
  • cups-config >= 2.2.7-3.6.1
  • cups-devel >= 2.2.7-3.6.1
  • libcups2 >= 2.2.7-3.6.1
  • libcupscgi1 >= 2.2.7-3.6.1
  • libcupsimage2 >= 2.2.7-3.6.1
  • libcupsmime1 >= 2.2.7-3.6.1
  • libcupsppdc1 >= 2.2.7-3.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2882
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • cups >= 2.2.7-3.11.7
  • cups-client >= 2.2.7-3.11.7
  • cups-config >= 2.2.7-3.11.7
  • cups-devel >= 2.2.7-3.11.7
  • libcups2 >= 2.2.7-3.11.7
  • libcups2-32bit >= 2.2.7-3.11.7
  • libcupscgi1 >= 2.2.7-3.11.7
  • libcupsimage2 >= 2.2.7-3.11.7
  • libcupsmime1 >= 2.2.7-3.11.7
  • libcupsppdc1 >= 2.2.7-3.11.7
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA cups
SUSE Linux Enterprise Module for Desktop Applications 15
  • cups >= 2.2.7-3.6.1
  • libcups2-32bit >= 2.2.7-3.6.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-2882
SUSE Linux Enterprise Module for Development Tools 15
  • cups >= 2.2.7-3.6.1
  • cups-ddk >= 2.2.7-3.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2018-2882
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • cups-ddk >= 2.2.7-3.11.7
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP1 GA cups-ddk
SUSE Linux Enterprise Server 12 SP3
  • cups >= 1.7.5-20.20.1
  • cups-client >= 1.7.5-20.20.1
  • cups-libs >= 1.7.5-20.20.1
  • cups-libs-32bit >= 1.7.5-20.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2917
SUSE Linux Enterprise Server 12 SP4
  • cups >= 1.7.5-20.20.1
  • cups-client >= 1.7.5-20.20.1
  • cups-libs >= 1.7.5-20.20.1
  • cups-libs-32bit >= 1.7.5-20.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2917
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • cups >= 1.7.5-20.20.1
  • cups-client >= 1.7.5-20.20.1
  • cups-libs >= 1.7.5-20.20.1
  • cups-libs-32bit >= 1.7.5-20.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2917
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • cups >= 1.7.5-20.20.1
  • cups-client >= 1.7.5-20.20.1
  • cups-libs >= 1.7.5-20.20.1
  • cups-libs-32bit >= 1.7.5-20.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2917
SUSE Linux Enterprise Software Development Kit 12 SP3
  • cups >= 1.7.5-20.20.1
  • cups-ddk >= 1.7.5-20.20.1
  • cups-devel >= 1.7.5-20.20.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2917
SUSE Linux Enterprise Software Development Kit 12 SP4
  • cups >= 1.7.5-20.20.1
  • cups-ddk >= 1.7.5-20.20.1
  • cups-devel >= 1.7.5-20.20.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2018-2917
openSUSE Leap 15.0
  • cups >= 2.2.7-lp150.2.6.1
  • cups-client >= 2.2.7-lp150.2.6.1
  • cups-client-debuginfo >= 2.2.7-lp150.2.6.1
  • cups-config >= 2.2.7-lp150.2.6.1
  • cups-ddk >= 2.2.7-lp150.2.6.1
  • cups-ddk-debuginfo >= 2.2.7-lp150.2.6.1
  • cups-debuginfo >= 2.2.7-lp150.2.6.1
  • cups-debugsource >= 2.2.7-lp150.2.6.1
  • cups-devel >= 2.2.7-lp150.2.6.1
  • cups-devel-32bit >= 2.2.7-lp150.2.6.1
  • libcups2 >= 2.2.7-lp150.2.6.1
  • libcups2-32bit >= 2.2.7-lp150.2.6.1
  • libcups2-32bit-debuginfo >= 2.2.7-lp150.2.6.1
  • libcups2-debuginfo >= 2.2.7-lp150.2.6.1
  • libcupscgi1 >= 2.2.7-lp150.2.6.1
  • libcupscgi1-32bit >= 2.2.7-lp150.2.6.1
  • libcupscgi1-32bit-debuginfo >= 2.2.7-lp150.2.6.1
  • libcupscgi1-debuginfo >= 2.2.7-lp150.2.6.1
  • libcupsimage2 >= 2.2.7-lp150.2.6.1
  • libcupsimage2-32bit >= 2.2.7-lp150.2.6.1
  • libcupsimage2-32bit-debuginfo >= 2.2.7-lp150.2.6.1
  • libcupsimage2-debuginfo >= 2.2.7-lp150.2.6.1
  • libcupsmime1 >= 2.2.7-lp150.2.6.1
  • libcupsmime1-32bit >= 2.2.7-lp150.2.6.1
  • libcupsmime1-32bit-debuginfo >= 2.2.7-lp150.2.6.1
  • libcupsmime1-debuginfo >= 2.2.7-lp150.2.6.1
  • libcupsppdc1 >= 2.2.7-lp150.2.6.1
  • libcupsppdc1-32bit >= 2.2.7-lp150.2.6.1
  • libcupsppdc1-32bit-debuginfo >= 2.2.7-lp150.2.6.1
  • libcupsppdc1-debuginfo >= 2.2.7-lp150.2.6.1
Patchnames:
openSUSE-2019-991
openSUSE Leap 42.3
  • cups >= 1.7.5-12.9.1
  • cups-client >= 1.7.5-12.9.1
  • cups-client-debuginfo >= 1.7.5-12.9.1
  • cups-ddk >= 1.7.5-12.9.1
  • cups-ddk-debuginfo >= 1.7.5-12.9.1
  • cups-debuginfo >= 1.7.5-12.9.1
  • cups-debugsource >= 1.7.5-12.9.1
  • cups-devel >= 1.7.5-12.9.1
  • cups-libs >= 1.7.5-12.9.1
  • cups-libs-32bit >= 1.7.5-12.9.1
  • cups-libs-debuginfo >= 1.7.5-12.9.1
  • cups-libs-debuginfo-32bit >= 1.7.5-12.9.1
Patchnames:
openSUSE-2018-1555


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise BSK 12 SP3 cups Released
SUSE Linux Enterprise BSK 12 SP4 cups Released
SUSE Linux Enterprise Desktop 12 SP3 cups Released
SUSE Linux Enterprise Desktop 12 SP4 cups Released
SUSE Linux Enterprise High Performance Computing 12 cups Released
SUSE Linux Enterprise Module for Basesystem 15 GA cups Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA cups Released
SUSE Linux Enterprise Module for Development Tools 15 GA cups Released
SUSE Linux Enterprise SDK 11 SP4 cups Not affected
SUSE Linux Enterprise SDK 12 SP3 cups Released
SUSE Linux Enterprise SDK 12 SP4 cups Released
SUSE Linux Enterprise Server 11 SP3 LTSS cups Not affected
SUSE Linux Enterprise Server 11 SP4 cups Not affected
SUSE Linux Enterprise Server 12 GA LTSS cups Affected
SUSE Linux Enterprise Server 12 SP1 LTSS cups Affected
SUSE Linux Enterprise Server 12 SP2 LTSS cups Affected
SUSE Linux Enterprise Server 12 SP3 cups Released
SUSE Linux Enterprise Server 12 SP4 cups Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 cups Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA cups Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 cups Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 cups Released