Upstream information

CVE-2018-4088 at MITRE

Description

An issue was discovered in certain Apple products. iOS before 11.2.5 is affected. macOS before 10.13.3 is affected. Safari before 11.0.3 is affected. iCloud before 7.3 on Windows is affected. iTunes before 12.7.3 on Windows is affected. tvOS before 11.2.5 is affected. watchOS before 4.2.2 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 6.3
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
SUSE Bugzilla entries: 1075775 [RESOLVED / DUPLICATE], 1077535 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libjavascriptcoregtk-4_0-18 >= 2.20.2-1.14
  • libwebkit2gtk-4_0-37 >= 2.20.2-1.14
  • libwebkit2gtk3-lang >= 2.20.2-1.14
  • webkit2gtk-4_0-injected-bundles >= 2.20.2-1.14
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Module for Desktop Applications 15
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.2-1.14
  • typelib-1_0-WebKit2-4_0 >= 2.20.2-1.14
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.20.2-1.14
  • webkit2gtk3-devel >= 2.20.2-1.14
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA typelib-1_0-JavaScriptCore-4_0
openSUSE Leap 15.0
  • libjavascriptcoregtk-4_0-18 >= 2.20.2-lp150.1.1
  • libwebkit2gtk-4_0-37 >= 2.20.2-lp150.1.1
  • libwebkit2gtk3-lang >= 2.20.2-lp150.1.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.2-lp150.1.1
  • typelib-1_0-WebKit2-4_0 >= 2.20.2-lp150.1.1
  • webkit2gtk-4_0-injected-bundles >= 2.20.2-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libjavascriptcoregtk-4_0-18


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 webkit2gtk3 Unsupported
SUSE Linux Enterprise Desktop 12 SP2 webkitgtk Unsupported
SUSE Linux Enterprise Desktop 12 SP2 webkitgtk3 Unsupported
SUSE Linux Enterprise Desktop 12 SP3 webkit2gtk3 Affected
SUSE Linux Enterprise Desktop 12 SP3 webkitgtk Ignore
SUSE Linux Enterprise Desktop 12 SP3 webkitgtk3 Ignore
SUSE Linux Enterprise SDK 12 SP2 webkit2gtk3 Unsupported
SUSE Linux Enterprise SDK 12 SP2 webkitgtk Unsupported
SUSE Linux Enterprise SDK 12 SP2 webkitgtk3 Unsupported
SUSE Linux Enterprise SDK 12 SP3 webkit2gtk3 Affected
SUSE Linux Enterprise SDK 12 SP3 webkitgtk Ignore
SUSE Linux Enterprise SDK 12 SP3 webkitgtk3 Ignore
SUSE Linux Enterprise Server 12 GA LTSS webkitgtk3 Ignore
SUSE Linux Enterprise Server 12 SP1 LTSS webkitgtk3 Ignore
SUSE Linux Enterprise Server 12 SP2 webkit2gtk3 Unsupported
SUSE Linux Enterprise Server 12 SP2 webkitgtk3 Unsupported
SUSE Linux Enterprise Server 12 SP3 webkit2gtk3 Affected
SUSE Linux Enterprise Server 12 SP3 webkitgtk3 Ignore
SUSE Linux Enterprise Workstation Extension 12 SP2 webkit2gtk3 Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP2 webkitgtk Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP2 webkitgtk3 Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP3 webkit2gtk3 Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 webkitgtk Ignore
SUSE Linux Enterprise Workstation Extension 12 SP3 webkitgtk3 Ignore