Upstream information

CVE-2018-20546 at MITRE

Description

There is an illegal READ memory access at caca/dither.c (function get_rgba_default) in libcaca 0.99.beta19 for the default bpp case.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 4
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entries: 1120503 [RESOLVED / DUPLICATE], 1120504 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP4
  • libcaca >= 0.99.beta18-14.3.27
  • libcaca0 >= 0.99.beta18-14.3.27
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2745
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libcaca-devel >= 0.99.beta19.git20171003-3.3.7
  • libcaca0 >= 0.99.beta19.git20171003-3.3.7
  • libcaca0-plugins >= 0.99.beta19.git20171003-3.3.7
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libcaca-devel
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • caca-utils >= 0.99.beta19.git20171003-3.3.7
  • libcaca >= 0.99.beta19.git20171003-3.3.7
  • libcaca-ruby >= 0.99.beta19.git20171003-3.3.7
  • python3-caca >= 0.99.beta19.git20171003-3.3.7
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-770
SUSE Linux Enterprise Module for Server Applications 15
  • libcaca >= 0.99.beta19.git20171003-3.3.7
  • libcaca-devel >= 0.99.beta19.git20171003-3.3.7
  • libcaca0 >= 0.99.beta19.git20171003-3.3.7
  • libcaca0-plugins >= 0.99.beta19.git20171003-3.3.7
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-770
SUSE Linux Enterprise Server 12 SP4
  • libcaca >= 0.99.beta18-14.3.27
  • libcaca0 >= 0.99.beta18-14.3.27
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2745
SUSE Linux Enterprise Server 12 SP5
  • libcaca >= 0.99.beta18-14.3.27
  • libcaca0 >= 0.99.beta18-14.3.27
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-2745
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libcaca >= 0.99.beta18-14.3.27
  • libcaca0 >= 0.99.beta18-14.3.27
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2745
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libcaca >= 0.99.beta18-14.3.27
  • libcaca0 >= 0.99.beta18-14.3.27
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-2745
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libcaca >= 0.99.beta18-14.3.27
  • libcaca-devel >= 0.99.beta18-14.3.27
  • libcaca0-plugins >= 0.99.beta18-14.3.27
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2745
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libcaca >= 0.99.beta18-14.3.27
  • libcaca-devel >= 0.99.beta18-14.3.27
  • libcaca0-plugins >= 0.99.beta18-14.3.27
Patchnames:
SUSE-SLE-SDK-12-SP5-2019-2745
openSUSE Leap 15.0
  • caca-utils >= 0.99.beta19.git20171003-lp150.2.3.1
  • caca-utils-debuginfo >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca-debugsource >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca-devel >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca-ruby >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca-ruby-debuginfo >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca0 >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca0-32bit >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca0-32bit-debuginfo >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca0-debuginfo >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca0-plugins >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca0-plugins-32bit >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca0-plugins-32bit-debuginfo >= 0.99.beta19.git20171003-lp150.2.3.1
  • libcaca0-plugins-debuginfo >= 0.99.beta19.git20171003-lp150.2.3.1
  • python3-caca >= 0.99.beta19.git20171003-lp150.2.3.1
Patchnames:
openSUSE-2019-1144


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 libcaca In progress
SUSE Linux Enterprise Desktop 12 SP4 libcaca Released
SUSE Linux Enterprise High Performance Computing 12 libcaca Released
SUSE Linux Enterprise Module for Server Applications 15 GA libcaca Released
SUSE Linux Enterprise SDK 11 SP4 libcaca Affected
SUSE Linux Enterprise SDK 12 SP3 libcaca In progress
SUSE Linux Enterprise SDK 12 SP4 libcaca Released
SUSE Linux Enterprise Server 11 SP3 LTSS libcaca Affected
SUSE Linux Enterprise Server 11 SP4 libcaca Affected
SUSE Linux Enterprise Server 12 GA LTSS libcaca Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libcaca Affected
SUSE Linux Enterprise Server 12 SP2 LTSS libcaca Affected
SUSE Linux Enterprise Server 12 SP3 libcaca In progress
SUSE Linux Enterprise Server 12 SP4 libcaca Released
SUSE Linux Enterprise Server 12 SP5 libcaca Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 libcaca Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA libcaca Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libcaca Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libcaca Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libcaca Released