Upstream information

CVE-2018-20467 at MITRE

Description

In coders/bmp.c in ImageMagick before 7.0.8-16, an input file can result in an infinite loop and hang, with high CPU and memory consumption. Remote attackers could leverage this vulnerability to cause a denial of service via a crafted file.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 3.3
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
SUSE Bugzilla entry: 1120381 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.3
  • GraphicsMagick >= 1.3.25-123.1
  • GraphicsMagick-debuginfo >= 1.3.25-123.1
  • GraphicsMagick-debugsource >= 1.3.25-123.1
  • GraphicsMagick-devel >= 1.3.25-123.1
  • libGraphicsMagick++-Q16-12 >= 1.3.25-123.1
  • libGraphicsMagick++-Q16-12-debuginfo >= 1.3.25-123.1
  • libGraphicsMagick++-devel >= 1.3.25-123.1
  • libGraphicsMagick-Q16-3 >= 1.3.25-123.1
  • libGraphicsMagick-Q16-3-debuginfo >= 1.3.25-123.1
  • libGraphicsMagick3-config >= 1.3.25-123.1
  • libGraphicsMagickWand-Q16-2 >= 1.3.25-123.1
  • libGraphicsMagickWand-Q16-2-debuginfo >= 1.3.25-123.1
  • perl-GraphicsMagick >= 1.3.25-123.1
  • perl-GraphicsMagick-debuginfo >= 1.3.25-123.1
Patchnames:
openSUSE-2019-16


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 ImageMagick In progress
SUSE Linux Enterprise Desktop 12 SP4 ImageMagick In progress
SUSE Linux Enterprise High Performance Computing 12 ImageMagick In progress
SUSE Linux Enterprise Module for Desktop Applications 15 GA ImageMagick In progress
SUSE Linux Enterprise Module for Development Tools 15 GA ImageMagick In progress
SUSE Linux Enterprise SDK 11 SP4 GraphicsMagick In progress
SUSE Linux Enterprise SDK 11 SP4 ImageMagick In progress
SUSE Linux Enterprise SDK 12 SP3 ImageMagick In progress
SUSE Linux Enterprise SDK 12 SP4 ImageMagick In progress
SUSE Linux Enterprise Server 11 SP3 LTSS ImageMagick Affected
SUSE Linux Enterprise Server 11 SP4 ImageMagick In progress
SUSE Linux Enterprise Server 12 GA LTSS ImageMagick Affected
SUSE Linux Enterprise Server 12 SP1 LTSS ImageMagick Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ImageMagick Affected
SUSE Linux Enterprise Server 12 SP3 ImageMagick In progress
SUSE Linux Enterprise Server 12 SP4 ImageMagick In progress
SUSE Linux Enterprise Server for SAP Applications 11 SP3 ImageMagick Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA ImageMagick Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ImageMagick Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ImageMagick In progress
SUSE Linux Enterprise Workstation Extension 12 SP3 ImageMagick In progress
SUSE Linux Enterprise Workstation Extension 12 SP4 ImageMagick In progress
SUSE Studio Onsite 1.3 GraphicsMagick In progress