Upstream information

CVE-2018-20346 at MITRE

Description

SQLite before 3.25.3, when the FTS3 extension is enabled, encounters an integer overflow (and resultant buffer overflow) for FTS3 queries that occur after crafted changes to FTS3 shadow tables, allowing remote attackers to execute arbitrary code by leveraging the ability to run arbitrary SQL statements (such as in certain WebSQL use cases), aka Magellan.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 7
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Local
Access Complexity High High
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entries: 1119687 [RESOLVED / FIXED], 1120335 [RESOLVED / DUPLICATE], 1131576 [NEW], 1131918 [RESOLVED / DUPLICATE], 1131919 [RESOLVED / FIXED], 1148893 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2019-913
SUSE CaaS Platform 3.0
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-CAASP-3.0-2019-913
SUSE CaaS Platform ALL
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-CAASP-ALL-2019-913
SUSE Enterprise Storage 4
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-Storage-4-2019-913
SUSE Linux Enterprise Desktop 12 SP3
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-913
SUSE Linux Enterprise Desktop 12 SP4
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-913
SUSE Linux Enterprise Module for Basesystem 15
  • libsqlite3-0 >= 3.27.2-3.3.2
  • libsqlite3-0-32bit >= 3.27.2-3.3.2
  • sqlite3 >= 3.27.2-3.3.2
  • sqlite3-devel >= 3.27.2-3.3.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-788
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libsqlite3-0 >= 3.28.0-3.6.1
  • libsqlite3-0-32bit >= 3.28.0-3.6.1
  • sqlite3 >= 3.28.0-3.6.1
  • sqlite3-devel >= 3.28.0-3.6.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libsqlite3-0
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • sqlite3 >= 3.27.2-3.3.2
  • sqlite3-doc >= 3.27.2-3.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-788
SUSE Linux Enterprise Point of Sale 11 SP3
  • libsqlite3-0 >= 3.7.6.3-1.4.7.3.1
  • sqlite3 >= 3.7.6.3-1.4.7.3.1
Patchnames:
sleposp3-sqlite3-14003
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-913
SUSE Linux Enterprise Server 11 SP4
  • libsqlite3-0 >= 3.7.6.3-1.4.7.3.1
  • libsqlite3-0-32bit >= 3.7.6.3-1.4.7.3.1
  • libsqlite3-0-x86 >= 3.7.6.3-1.4.7.3.1
  • sqlite3 >= 3.7.6.3-1.4.7.3.1
Patchnames:
slessp4-sqlite3-14003
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-913
SUSE Linux Enterprise Server 12 SP2-BCL
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-913
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-913
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-913
SUSE Linux Enterprise Server 12 SP3
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-913
SUSE Linux Enterprise Server 12 SP4
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-913
SUSE Linux Enterprise Server 12-LTSS
  • libsqlite3-0 >= 3.8.3.1-2.7.1
  • libsqlite3-0-32bit >= 3.8.3.1-2.7.1
  • sqlite3 >= 3.8.3.1-2.7.1
Patchnames:
SUSE-SLE-SERVER-12-2019-973
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libsqlite3-0 >= 3.7.6.3-1.4.7.3.1
  • libsqlite3-0-32bit >= 3.7.6.3-1.4.7.3.1
  • libsqlite3-0-x86 >= 3.7.6.3-1.4.7.3.1
  • sqlite3 >= 3.7.6.3-1.4.7.3.1
Patchnames:
slessp4-sqlite3-14003
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-913
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-913
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-913
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-913
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-913
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-913
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-913
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-913
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • libsqlite3-0 >= 3.8.3.1-2.7.1
  • libsqlite3-0-32bit >= 3.8.3.1-2.7.1
  • sqlite3 >= 3.8.3.1-2.7.1
Patchnames:
SUSE-SLE-SERVER-12-2019-973
SUSE Linux Enterprise Software Development Kit 11 SP4
  • sqlite3 >= 3.7.6.3-1.4.7.3.1
  • sqlite3-devel >= 3.7.6.3-1.4.7.3.1
Patchnames:
sdksp4-sqlite3-14003
SUSE Linux Enterprise Software Development Kit 12 SP3
  • sqlite3 >= 3.8.10.2-9.3.1
  • sqlite3-devel >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-913
SUSE Linux Enterprise Software Development Kit 12 SP4
  • sqlite3 >= 3.8.10.2-9.3.1
  • sqlite3-devel >= 3.8.10.2-9.3.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-913
SUSE OpenStack Cloud 7
  • libsqlite3-0 >= 3.8.10.2-9.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.3.1
  • sqlite3 >= 3.8.10.2-9.3.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-913
SUSE Studio Onsite 1.3
  • sqlite3 >= 3.7.6.3-1.4.7.3.1
  • sqlite3-devel >= 3.7.6.3-1.4.7.3.1
Patchnames:
slestso13-sqlite3-14003
openSUSE Leap 15.0
  • libsqlite3-0 >= 3.27.2-lp150.2.3.1
  • libsqlite3-0-32bit >= 3.27.2-lp150.2.3.1
  • libsqlite3-0-32bit-debuginfo >= 3.27.2-lp150.2.3.1
  • libsqlite3-0-debuginfo >= 3.27.2-lp150.2.3.1
  • sqlite3 >= 3.27.2-lp150.2.3.1
  • sqlite3-debuginfo >= 3.27.2-lp150.2.3.1
  • sqlite3-debugsource >= 3.27.2-lp150.2.3.1
  • sqlite3-devel >= 3.27.2-lp150.2.3.1
  • sqlite3-doc >= 3.27.2-lp150.2.3.1
Patchnames:
openSUSE-2019-1159
openSUSE Leap 42.3
  • libsqlite3-0 >= 3.8.10.2-11.3.1
  • libsqlite3-0-32bit >= 3.8.10.2-11.3.1
  • libsqlite3-0-debuginfo >= 3.8.10.2-11.3.1
  • libsqlite3-0-debuginfo-32bit >= 3.8.10.2-11.3.1
  • sqlite3 >= 3.8.10.2-11.3.1
  • sqlite3-debuginfo >= 3.8.10.2-11.3.1
  • sqlite3-debugsource >= 3.8.10.2-11.3.1
  • sqlite3-devel >= 3.8.10.2-11.3.1
  • sqlite3-doc >= 3.8.10.2-11.3.1
Patchnames:
openSUSE-2019-1222


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 sqlite3 Released
CaaS Platform 3.0 sqlite3 Released
OpenStack Cloud Magnum Orchestration 7.0 sqlite3 Released
SUSE Linux Enterprise Desktop 12 SP3 sqlite3 Released
SUSE Linux Enterprise Desktop 12 SP4 sqlite3 Released
SUSE Linux Enterprise High Availability 12 GA sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 11 SP4 sqlite2 Not affected
SUSE Linux Enterprise High Performance Computing 12 sqlite3 Released
SUSE Linux Enterprise Module for Basesystem 15 GA sqlite3 Released
SUSE Linux Enterprise SDK 11 SP4 sqlite2 Not affected
SUSE Linux Enterprise SDK 11 SP4 sqlite3 Released
SUSE Linux Enterprise SDK 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise SDK 12 SP3 sqlite3 Released
SUSE Linux Enterprise SDK 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise SDK 12 SP4 sqlite3 Released
SUSE Linux Enterprise Server 11 SP3 LTSS sqlite3 Affected
SUSE Linux Enterprise Server 11 SP4 sqlite3 Released
SUSE Linux Enterprise Server 12 GA LTSS sqlite3 Released
SUSE Linux Enterprise Server 12 SP1 LTSS sqlite3 Released
SUSE Linux Enterprise Server 12 SP2 LTSS sqlite3 Released
SUSE Linux Enterprise Server 12 SP3 sqlite3 Released
SUSE Linux Enterprise Server 12 SP4 sqlite3 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sqlite3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 sqlite3 Released
SUSE Studio Onsite 1.3 sqlite3 Released