Upstream information

CVE-2018-19788 at MITRE

Description

A flaw was found in PolicyKit (aka polkit) 0.115 that allows a user with a uid greater than INT_MAX to successfully execute any systemctl command.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9
Vector AV:N/AC:L/Au:S/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 5.6
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:H
Access Vector Network Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High None
Availability Impact High High
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entries: 1118274 [RESOLVED / DUPLICATE], 1118277 [RESOLVED / FIXED], 1119056 [RESOLVED / DUPLICATE], 1126909 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-Storage-4-2019-19
SUSE Linux Enterprise Desktop 12 SP3
  • libpolkit0 >= 0.113-5.15.1
  • libpolkit0-32bit >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-19
SUSE Linux Enterprise Desktop 12 SP4
  • libpolkit0 >= 0.113-5.15.1
  • libpolkit0-32bit >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-19
SUSE Linux Enterprise Module for Basesystem 15
  • libpolkit0 >= 0.114-3.6.1
  • polkit >= 0.114-3.6.1
  • polkit-devel >= 0.114-3.6.1
  • typelib-1_0-Polkit-1_0 >= 0.114-3.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libpolkit0 >= 0.114-3.6.1
  • polkit >= 0.114-3.6.1
  • polkit-devel >= 0.114-3.6.1
  • typelib-1_0-Polkit-1_0 >= 0.114-3.6.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libpolkit0
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • polkit >= 0.114-3.6.1
  • polkit-doc >= 0.114-3.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-15
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-19
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-19
SUSE Linux Enterprise Server 12 SP2-BCL
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-19
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-19
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-19
SUSE Linux Enterprise Server 12 SP3
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-19
SUSE Linux Enterprise Server 12 SP4
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-19
SUSE Linux Enterprise Server 12-LTSS
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-2019-19
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-19
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-19
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-19
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-19
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-19
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-19
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-19
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-19
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SERVER-12-2019-19
SUSE Linux Enterprise Software Development Kit 12 SP3
  • polkit >= 0.113-5.15.1
  • polkit-devel >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-19
SUSE Linux Enterprise Software Development Kit 12 SP4
  • polkit >= 0.113-5.15.1
  • polkit-devel >= 0.113-5.15.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-19
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libpolkit0-32bit >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
Patchnames:
SUSE-SLE-WE-12-SP3-2019-19
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libpolkit0-32bit >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
Patchnames:
SUSE-SLE-WE-12-SP4-2019-19
SUSE OpenStack Cloud 7
  • libpolkit0 >= 0.113-5.15.1
  • polkit >= 0.113-5.15.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.15.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-19
openSUSE Leap 15.0
  • libpolkit0 >= 0.114-lp150.2.6.1
  • libpolkit0-32bit >= 0.114-lp150.2.6.1
  • libpolkit0-32bit-debuginfo >= 0.114-lp150.2.6.1
  • libpolkit0-debuginfo >= 0.114-lp150.2.6.1
  • polkit >= 0.114-lp150.2.6.1
  • polkit-debuginfo >= 0.114-lp150.2.6.1
  • polkit-debugsource >= 0.114-lp150.2.6.1
  • polkit-devel >= 0.114-lp150.2.6.1
  • polkit-devel-debuginfo >= 0.114-lp150.2.6.1
  • polkit-doc >= 0.114-lp150.2.6.1
  • typelib-1_0-Polkit-1_0 >= 0.114-lp150.2.6.1
Patchnames:
openSUSE-2019-10
openSUSE Leap 42.3
  • libpolkit0 >= 0.113-14.6.1
  • libpolkit0-32bit >= 0.113-14.6.1
  • libpolkit0-debuginfo >= 0.113-14.6.1
  • libpolkit0-debuginfo-32bit >= 0.113-14.6.1
  • polkit >= 0.113-14.6.1
  • polkit-debuginfo >= 0.113-14.6.1
  • polkit-debugsource >= 0.113-14.6.1
  • polkit-devel >= 0.113-14.6.1
  • polkit-devel-debuginfo >= 0.113-14.6.1
  • polkit-doc >= 0.113-14.6.1
  • typelib-1_0-Polkit-1_0 >= 0.113-14.6.1
Patchnames:
openSUSE-2018-1617


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 polkit Released
SUSE Linux Enterprise Desktop 12 SP4 polkit Released
SUSE Linux Enterprise High Performance Computing 12 polkit Released
SUSE Linux Enterprise Module for Basesystem 15 GA polkit Released
SUSE Linux Enterprise SDK 11 SP4 PolicyKit Not affected
SUSE Linux Enterprise SDK 12 SP3 polkit Released
SUSE Linux Enterprise SDK 12 SP4 polkit Released
SUSE Linux Enterprise Server 11 SP3 LTSS PolicyKit Not affected
SUSE Linux Enterprise Server 11 SP4 PolicyKit Not affected
SUSE Linux Enterprise Server 12 GA LTSS polkit Released
SUSE Linux Enterprise Server 12 SP1 LTSS polkit Released
SUSE Linux Enterprise Server 12 SP2 LTSS polkit Released
SUSE Linux Enterprise Server 12 SP3 polkit Released
SUSE Linux Enterprise Server 12 SP4 polkit Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 PolicyKit Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA polkit Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 polkit Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 polkit Released
SUSE Linux Enterprise Workstation Extension 12 SP3 polkit Released
SUSE Linux Enterprise Workstation Extension 12 SP4 polkit Released