Upstream information

CVE-2018-19409 at MITRE

Description

An issue was discovered in Artifex Ghostscript before 9.26. LockSafetyParams is not checked correctly if another device is used.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 7.1
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entries: 1108027 [NEW], 1109105 [NEW], 1111479 [NEW], 1111480 [NEW], 1112229 [NEW], 1117022 [NEW], 1117331 [IN_PROGRESS], 1118455 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-Storage-4-2018-2916
SUSE Linux Enterprise Build System Kit 12 SP3
  • ghostscript-mini >= 9.26-23.16.1
  • ghostscript-mini-devel >= 9.26-23.16.1
Patchnames:
SUSE-SLE-BSK-12-SP3-2018-2916
SUSE Linux Enterprise Build System Kit 12 SP4
  • ghostscript-mini >= 9.26-23.16.1
  • ghostscript-mini-devel >= 9.26-23.16.1
Patchnames:
SUSE-SLE-BSK-12-SP4-2018-2916
SUSE Linux Enterprise Desktop 12 SP3
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2916
SUSE Linux Enterprise Desktop 12 SP4
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2018-2916
SUSE Linux Enterprise Module for Basesystem 15
  • ghostscript >= 9.26-3.9.4
  • ghostscript-devel >= 9.26-3.9.4
  • ghostscript-x11 >= 9.26-3.9.4
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2914
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • ghostscript >= 9.26a-3.15.1
  • ghostscript-devel >= 9.26a-3.15.1
  • ghostscript-x11 >= 9.26a-3.15.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA ghostscript
SUSE Linux Enterprise Module for Desktop Applications 15
  • libspectre >= 0.2.8-3.4.3
  • libspectre-devel >= 0.2.8-3.4.3
  • libspectre1 >= 0.2.8-3.4.3
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-2914
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • ghostscript-mini >= 9.26-3.9.3
  • ghostscript-mini-devel >= 9.26-3.9.3
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2018-2914
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-2916
SUSE Linux Enterprise Server 12 SP1-LTSS
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2916
SUSE Linux Enterprise Server 12 SP2-BCL
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-2916
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-2916
SUSE Linux Enterprise Server 12 SP2-LTSS
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-2916
SUSE Linux Enterprise Server 12 SP3
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2916
SUSE Linux Enterprise Server 12 SP4
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2916
SUSE Linux Enterprise Server 12-LTSS
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2916
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-1076
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2916
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-2916
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-2916
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-2916
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-2916
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2916
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2916
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2916
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ghostscript >= 9.26-23.16.1
  • ghostscript-devel >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre-devel >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2916
SUSE Linux Enterprise Software Development Kit 12 SP4
  • ghostscript >= 9.26-23.16.1
  • ghostscript-devel >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre-devel >= 0.2.7-12.4.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2018-2916
SUSE OpenStack Cloud 7
  • ghostscript >= 9.26-23.16.1
  • ghostscript-x11 >= 9.26-23.16.1
  • libspectre >= 0.2.7-12.4.1
  • libspectre1 >= 0.2.7-12.4.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-2916
openSUSE Leap 15.0
  • ghostscript >= 9.26-lp150.2.9.1
  • ghostscript-debuginfo >= 9.26-lp150.2.9.1
  • ghostscript-debugsource >= 9.26-lp150.2.9.1
  • ghostscript-devel >= 9.26-lp150.2.9.1
  • ghostscript-mini >= 9.26-lp150.2.9.1
  • ghostscript-mini-debuginfo >= 9.26-lp150.2.9.1
  • ghostscript-mini-debugsource >= 9.26-lp150.2.9.1
  • ghostscript-mini-devel >= 9.26-lp150.2.9.1
  • ghostscript-x11 >= 9.26-lp150.2.9.1
  • ghostscript-x11-debuginfo >= 9.26-lp150.2.9.1
  • libspectre-debugsource >= 0.2.8-lp150.2.6.2
  • libspectre-devel >= 0.2.8-lp150.2.6.2
  • libspectre1 >= 0.2.8-lp150.2.6.2
  • libspectre1-debuginfo >= 0.2.8-lp150.2.6.2
Patchnames:
openSUSE-2019-1007
openSUSE Leap 42.3
  • ghostscript >= 9.26-14.12.1
  • ghostscript-debuginfo >= 9.26-14.12.1
  • ghostscript-debugsource >= 9.26-14.12.1
  • ghostscript-devel >= 9.26-14.12.1
  • ghostscript-mini >= 9.26-14.12.1
  • ghostscript-mini-debuginfo >= 9.26-14.12.1
  • ghostscript-mini-debugsource >= 9.26-14.12.1
  • ghostscript-mini-devel >= 9.26-14.12.1
  • ghostscript-x11 >= 9.26-14.12.1
  • ghostscript-x11-debuginfo >= 9.26-14.12.1
  • libspectre >= 0.2.7-17.4.2
  • libspectre-debugsource >= 0.2.7-17.4.2
  • libspectre-devel >= 0.2.7-17.4.2
  • libspectre1 >= 0.2.7-17.4.2
  • libspectre1-debuginfo >= 0.2.7-17.4.2
Patchnames:
openSUSE-2018-1556


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 ghostscript Released
SUSE Linux Enterprise Desktop 12 SP4 ghostscript Released
SUSE Linux Enterprise High Performance Computing 12 ghostscript Released
SUSE Linux Enterprise Module for Basesystem 15 GA ghostscript Released
SUSE Linux Enterprise SDK 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise SDK 12 SP3 ghostscript Released
SUSE Linux Enterprise SDK 12 SP4 ghostscript Released
SUSE Linux Enterprise Server 11 SP3 LTSS ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise Server 12 GA LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP1 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP2 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP3 ghostscript Released
SUSE Linux Enterprise Server 12 SP4 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 ghostscript-library Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA ghostscript Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ghostscript Released