Upstream information

CVE-2018-19295 at MITRE

Description

Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1111411 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 12 SP3
  • libsingularity1 >= 2.6.1-14.1
  • singularity >= 2.6.1-14.1
  • singularity-devel >= 2.6.1-14.1
Patchnames:
openSUSE-2019-95
SUSE Package Hub for SUSE Linux Enterprise 15
  • libsingularity1 >= 2.6.1-bp150.3.6.1
  • libsingularity1-debuginfo >= 2.6.1-lp150.2.6.1
  • singularity >= 2.6.1-bp150.3.6.1
  • singularity-debuginfo >= 2.6.1-lp150.2.6.1
  • singularity-debugsource >= 2.6.1-lp150.2.6.1
  • singularity-devel >= 2.6.1-bp150.3.6.1
Patchnames:
openSUSE-2019-9
openSUSE Leap 15.0
  • libsingularity1 >= 2.6.1-lp150.2.6.1
  • libsingularity1-debuginfo >= 2.6.1-lp150.2.6.1
  • singularity >= 2.6.1-lp150.2.6.1
  • singularity-debuginfo >= 2.6.1-lp150.2.6.1
  • singularity-debugsource >= 2.6.1-lp150.2.6.1
  • singularity-devel >= 2.6.1-lp150.2.6.1
Patchnames:
openSUSE-2019-9