Upstream information

CVE-2018-18065 at MITRE

Description

_set_key in agent/helpers/table_container.c in Net-SNMP before 5.8 has a NULL Pointer Exception bug that can be used by an authenticated attacker to remotely cause the instance to crash via a crafted UDP packet, resulting in Denial of Service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 7.5
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entries: 1111122 [RESOLVED / FIXED], 1126909 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 3.0
  • libsnmp30 >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-CAASP-3.0-2018-2461
SUSE Enterprise Storage 4
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-Storage-4-2018-2461
SUSE Linux Enterprise Desktop 12 SP3
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2461
SUSE Linux Enterprise Desktop 12 SP4
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libsnmp30-32bit
SUSE Linux Enterprise Module for Basesystem 15
  • libsnmp30 >= 5.7.3-7.3.1
  • net-snmp >= 5.7.3-7.3.1
  • net-snmp-devel >= 5.7.3-7.3.1
  • perl-SNMP >= 5.7.3-7.3.1
  • snmp-mibs >= 5.7.3-7.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2396
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-2461
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2461
SUSE Linux Enterprise Server 12 SP2-BCL
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-2461
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-2461
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-2461
SUSE Linux Enterprise Server 12 SP3
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2461
SUSE Linux Enterprise Server 12 SP4
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libsnmp30-32bit
SUSE Linux Enterprise Server 12-LTSS
  • libsnmp30 >= 5.7.2.1-4.9.1
  • libsnmp30-32bit >= 5.7.2.1-4.9.1
  • net-snmp >= 5.7.2.1-4.9.1
  • perl-SNMP >= 5.7.2.1-4.9.1
  • snmp-mibs >= 5.7.2.1-4.9.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2390
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-1064
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2461
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-2461
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-2461
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-2461
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-2461
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2461
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • libsnmp30 >= 5.7.2.1-4.9.1
  • libsnmp30-32bit >= 5.7.2.1-4.9.1
  • net-snmp >= 5.7.2.1-4.9.1
  • perl-SNMP >= 5.7.2.1-4.9.1
  • snmp-mibs >= 5.7.2.1-4.9.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2390
SUSE Linux Enterprise Software Development Kit 12 SP3
  • net-snmp >= 5.7.3-6.3.1
  • net-snmp-devel >= 5.7.3-6.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2461
SUSE Linux Enterprise Software Development Kit 12 SP4
  • net-snmp-devel >= 5.7.3-6.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA net-snmp-devel
SUSE OpenStack Cloud 7
  • libsnmp30 >= 5.7.3-6.3.1
  • libsnmp30-32bit >= 5.7.3-6.3.1
  • net-snmp >= 5.7.3-6.3.1
  • perl-SNMP >= 5.7.3-6.3.1
  • snmp-mibs >= 5.7.3-6.3.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-2461
openSUSE Leap 15.0
  • libsnmp30 >= 5.7.3-lp150.6.3.1
  • libsnmp30-32bit >= 5.7.3-lp150.6.3.1
  • libsnmp30-32bit-debuginfo >= 5.7.3-lp150.6.3.1
  • libsnmp30-debuginfo >= 5.7.3-lp150.6.3.1
  • net-snmp >= 5.7.3-lp150.6.3.1
  • net-snmp-debuginfo >= 5.7.3-lp150.6.3.1
  • net-snmp-debugsource >= 5.7.3-lp150.6.3.1
  • net-snmp-devel >= 5.7.3-lp150.6.3.1
  • net-snmp-devel-32bit >= 5.7.3-lp150.6.3.1
  • perl-SNMP >= 5.7.3-lp150.6.3.1
  • perl-SNMP-debuginfo >= 5.7.3-lp150.6.3.1
  • python2-net-snmp >= 5.7.3-lp150.6.3.1
  • python2-net-snmp-debuginfo >= 5.7.3-lp150.6.3.1
  • python3-net-snmp >= 5.7.3-lp150.6.3.1
  • python3-net-snmp-debuginfo >= 5.7.3-lp150.6.3.1
  • snmp-mibs >= 5.7.3-lp150.6.3.1
Patchnames:
openSUSE-2019-846
openSUSE Leap 42.3
  • libsnmp30 >= 5.7.3-7.3.1
  • libsnmp30-32bit >= 5.7.3-7.3.1
  • libsnmp30-debuginfo >= 5.7.3-7.3.1
  • libsnmp30-debuginfo-32bit >= 5.7.3-7.3.1
  • net-snmp >= 5.7.3-7.3.1
  • net-snmp-debuginfo >= 5.7.3-7.3.1
  • net-snmp-debugsource >= 5.7.3-7.3.1
  • net-snmp-devel >= 5.7.3-7.3.1
  • net-snmp-devel-32bit >= 5.7.3-7.3.1
  • net-snmp-python >= 5.7.3-7.3.1
  • net-snmp-python-debuginfo >= 5.7.3-7.3.1
  • perl-SNMP >= 5.7.3-7.3.1
  • perl-SNMP-debuginfo >= 5.7.3-7.3.1
  • snmp-mibs >= 5.7.3-7.3.1
Patchnames:
openSUSE-2018-1313


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 3.0 net-snmp Released
SUSE Linux Enterprise Desktop 12 SP3 net-snmp Released
SUSE Linux Enterprise Module for Basesystem 15 GA net-snmp Released
SUSE Linux Enterprise SDK 11 SP4 net-snmp Not affected
SUSE Linux Enterprise SDK 12 SP3 net-snmp Released
SUSE Linux Enterprise Server 11 SP3 LTSS net-snmp Not affected
SUSE Linux Enterprise Server 11 SP4 net-snmp Not affected
SUSE Linux Enterprise Server 12 GA LTSS net-snmp Released
SUSE Linux Enterprise Server 12 SP1 LTSS net-snmp Released
SUSE Linux Enterprise Server 12 SP2 LTSS net-snmp Released
SUSE Linux Enterprise Server 12 SP3 net-snmp Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 net-snmp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA net-snmp Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 net-snmp Released