Upstream information

CVE-2018-17953 at MITRE

Description

A incorrect variable in a SUSE specific patch for pam_access rule matching in PAM 1.3.0 in openSUSE Leap 15.0 and SUSE Linux Enterprise 15 could lead to pam_access rules not being applied (fail open).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 7.5
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Access Vector Network Network
Access Complexity High Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High High
Availability Impact High None
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entry: 1115640 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • pam >= 1.3.0-6.6.1
  • pam-32bit >= 1.3.0-6.6.1
  • pam-devel >= 1.3.0-6.6.1
  • pam-doc >= 1.3.0-6.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2825
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • pam >= 1.3.0-6.6.1
  • pam-32bit >= 1.3.0-6.6.1
  • pam-devel >= 1.3.0-6.6.1
  • pam-doc >= 1.3.0-6.6.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA pam
SUSE Linux Enterprise Module for Development Tools 15
  • pam >= 1.3.0-6.6.1
  • pam-devel-32bit >= 1.3.0-6.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2018-2825
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • pam-devel-32bit >= 1.3.0-6.6.1
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP1 GA pam-devel-32bit
openSUSE Leap 15.0
  • pam >= 1.3.0-lp150.5.6.1
  • pam-32bit >= 1.3.0-lp150.5.6.1
  • pam-32bit-debuginfo >= 1.3.0-lp150.5.6.1
  • pam-debuginfo >= 1.3.0-lp150.5.6.1
  • pam-debugsource >= 1.3.0-lp150.5.6.1
  • pam-devel >= 1.3.0-lp150.5.6.1
  • pam-devel-32bit >= 1.3.0-lp150.5.6.1
  • pam-doc >= 1.3.0-lp150.5.6.1
Patchnames:
openSUSE-2019-971


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 pam Not affected
CaaS Platform 2.0 pam Not affected
CaaS Platform 3.0 pam Not affected
OpenStack Cloud Magnum Orchestration 7.0 pam Not affected
SUSE Linux Enterprise Desktop 12 SP3 pam Not affected
SUSE Linux Enterprise Desktop 12 SP4 pam Not affected
SUSE Linux Enterprise High Performance Computing 12 pam Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA pam Released
SUSE Linux Enterprise Module for Development Tools 15 GA pam Released
SUSE Linux Enterprise SDK 11 SP4 pam Not affected
SUSE Linux Enterprise SDK 12 SP3 pam Not affected
SUSE Linux Enterprise SDK 12 SP4 pam Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS pam Not affected
SUSE Linux Enterprise Server 11 SP4 pam Not affected
SUSE Linux Enterprise Server 12 GA LTSS pam Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS pam Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS pam Not affected
SUSE Linux Enterprise Server 12 SP3 pam Not affected
SUSE Linux Enterprise Server 12 SP4 pam Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 pam Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA pam Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 pam Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 pam Not affected