Upstream information

CVE-2018-16869 at MITRE

Description

A Bleichenbacher type side-channel based padding oracle attack was found in the way nettle handles endian conversion of RSA decrypted PKCS#1 v1.5 data. An attacker who is able to run a process on the same physical core as the victim process, could use this flaw extract plaintext or in some cases downgrade any TLS connections to a vulnerable server.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.3
Vector AV:L/AC:M/Au:N/C:P/I:P/A:N
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.7 5.3
Vector AV:P/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:N AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:N/A:N
Access Vector Physical Local
Access Complexity High High
Privileges Required None High
User Interaction None None
Scope Changed Changed
Confidentiality Impact High High
Integrity Impact Low None
Availability Impact None None
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entries: 1117951 [IN_PROGRESS], 1118086 [CONFIRMED], 1118087 [CONFIRMED], 1134856 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libhogweed4 >= 3.4-4.3.1
  • libnettle >= 3.4-4.3.1
  • libnettle-devel >= 3.4-4.3.1
  • libnettle6 >= 3.4-4.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2986
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libhogweed4 >= 3.4.1-4.9.1
  • libhogweed4-32bit >= 3.4.1-4.9.1
  • libnettle-devel >= 3.4.1-4.9.1
  • libnettle6 >= 3.4.1-4.9.1
  • libnettle6-32bit >= 3.4.1-4.9.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libhogweed4
SUSE Linux Enterprise Module for Desktop Applications 15
  • libhogweed4-32bit >= 3.4-4.3.1
  • libnettle >= 3.4-4.3.1
  • libnettle6-32bit >= 3.4-4.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-2986
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libnettle >= 3.4-4.3.1
  • nettle >= 3.4-4.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2018-2986
openSUSE Leap 15.0
  • libhogweed4 >= 3.4-lp150.3.3.1
  • libhogweed4-32bit >= 3.4-lp150.3.3.1
  • libhogweed4-32bit-debuginfo >= 3.4-lp150.3.3.1
  • libhogweed4-debuginfo >= 3.4-lp150.3.3.1
  • libnettle >= 3.4-lp150.3.3.1
  • libnettle-debugsource >= 3.4-lp150.3.3.1
  • libnettle-devel >= 3.4-lp150.3.3.1
  • libnettle-devel-32bit >= 3.4-lp150.3.3.1
  • libnettle6 >= 3.4-lp150.3.3.1
  • libnettle6-32bit >= 3.4-lp150.3.3.1
  • libnettle6-32bit-debuginfo >= 3.4-lp150.3.3.1
  • libnettle6-debuginfo >= 3.4-lp150.3.3.1
  • nettle >= 3.4-lp150.3.3.1
  • nettle-debuginfo >= 3.4-lp150.3.3.1
Patchnames:
openSUSE-2019-1031


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 libnettle Affected
SUSE Linux Enterprise Desktop 12 SP4 libnettle Affected
SUSE Linux Enterprise High Performance Computing 12 libnettle Affected
SUSE Linux Enterprise Module for Basesystem 15 GA libnettle Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA libnettle Released
SUSE Linux Enterprise SDK 12 SP3 libnettle Affected
SUSE Linux Enterprise SDK 12 SP4 libnettle Affected
SUSE Linux Enterprise Server 12 GA LTSS libnettle Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libnettle Affected
SUSE Linux Enterprise Server 12 SP2 LTSS libnettle Affected
SUSE Linux Enterprise Server 12 SP3 libnettle Affected
SUSE Linux Enterprise Server 12 SP4 libnettle Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA libnettle Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libnettle Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libnettle Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libnettle Affected