Upstream information

CVE-2018-16866 at MITRE

Description

An out of bounds read was discovered in systemd-journald in the way it parses log messages that terminate with a colon ':'. A local attacker can use this flaw to disclose process memory data. Versions from v221 to v239 are vulnerable.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 3.3 3.3
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entries: 1108912 [RESOLVED / FIXED], 1120323 [RESOLVED / FIXED], 1122265 [RESOLVED / INVALID], 1126183 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libsystemd0 >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2019-135
SUSE CaaS Platform 3.0
  • libsystemd0 >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-CAASP-3.0-2019-135
SUSE CaaS Platform ALL
  • libsystemd0 >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-CAASP-ALL-2019-135
SUSE Enterprise Storage 4
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-Storage-4-2019-135
SUSE Linux Enterprise Build System Kit 12 SP3
  • libudev-mini-devel >= 228-150.58.1
  • libudev-mini1 >= 228-150.58.1
  • systemd-mini >= 228-150.58.1
  • systemd-mini-devel >= 228-150.58.1
  • udev-mini >= 228-150.58.1
Patchnames:
SUSE-SLE-BSK-12-SP3-2019-135
SUSE Linux Enterprise Build System Kit 12 SP4
  • libudev-mini-devel >= 228-150.58.1
  • libudev-mini1 >= 228-150.58.1
  • systemd-mini >= 228-150.58.1
  • systemd-mini-devel >= 228-150.58.1
  • udev-mini >= 228-150.58.1
Patchnames:
SUSE-SLE-BSK-12-SP4-2019-135
SUSE Linux Enterprise Desktop 12 SP3
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-135
SUSE Linux Enterprise Desktop 12 SP4
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-135
SUSE Linux Enterprise Module for Basesystem 15
  • libsystemd0 >= 234-24.20.1
  • libsystemd0-32bit >= 234-24.20.1
  • libudev-devel >= 234-24.20.1
  • libudev1 >= 234-24.20.1
  • libudev1-32bit >= 234-24.20.1
  • systemd >= 234-24.20.1
  • systemd-32bit >= 234-24.20.1
  • systemd-bash-completion >= 234-24.20.1
  • systemd-container >= 234-24.20.1
  • systemd-coredump >= 234-24.20.1
  • systemd-devel >= 234-24.20.1
  • systemd-sysvinit >= 234-24.20.1
  • udev >= 234-24.20.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-137
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libsystemd0-mini >= 234-24.20.1
  • libudev-mini-devel >= 234-24.20.1
  • libudev-mini1 >= 234-24.20.1
  • nss-myhostname >= 234-24.20.1
  • nss-mymachines >= 234-24.20.1
  • nss-systemd >= 234-24.20.1
  • systemd >= 234-24.20.1
  • systemd-logger >= 234-24.20.1
  • systemd-mini >= 234-24.20.1
  • systemd-mini-bash-completion >= 234-24.20.1
  • systemd-mini-container-mini >= 234-24.20.1
  • systemd-mini-coredump-mini >= 234-24.20.1
  • systemd-mini-devel >= 234-24.20.1
  • systemd-mini-sysvinit >= 234-24.20.1
  • udev-mini >= 234-24.20.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-137
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-135
SUSE Linux Enterprise Server 12 SP2-BCL
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-135
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-135
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-135
SUSE Linux Enterprise Server 12 SP3
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-135
SUSE Linux Enterprise Server 12 SP4
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-135
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-135
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-135
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-135
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-135
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-135
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-135
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libudev-devel >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-devel >= 228-150.58.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-135
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libudev-devel >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-devel >= 228-150.58.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-135
SUSE OpenStack Cloud 7
  • libsystemd0 >= 228-150.58.1
  • libsystemd0-32bit >= 228-150.58.1
  • libudev1 >= 228-150.58.1
  • libudev1-32bit >= 228-150.58.1
  • systemd >= 228-150.58.1
  • systemd-32bit >= 228-150.58.1
  • systemd-bash-completion >= 228-150.58.1
  • systemd-sysvinit >= 228-150.58.1
  • udev >= 228-150.58.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-135
openSUSE Leap 15.0
  • libsystemd0 >= 234-lp150.20.12.1
  • libsystemd0-32bit >= 234-lp150.20.12.1
  • libsystemd0-32bit-debuginfo >= 234-lp150.20.12.1
  • libsystemd0-debuginfo >= 234-lp150.20.12.1
  • libsystemd0-mini >= 234-lp150.20.12.1
  • libsystemd0-mini-debuginfo >= 234-lp150.20.12.1
  • libudev-devel >= 234-lp150.20.12.1
  • libudev-devel-32bit >= 234-lp150.20.12.1
  • libudev-mini-devel >= 234-lp150.20.12.1
  • libudev-mini1 >= 234-lp150.20.12.1
  • libudev-mini1-debuginfo >= 234-lp150.20.12.1
  • libudev1 >= 234-lp150.20.12.1
  • libudev1-32bit >= 234-lp150.20.12.1
  • libudev1-32bit-debuginfo >= 234-lp150.20.12.1
  • libudev1-debuginfo >= 234-lp150.20.12.1
  • nss-myhostname >= 234-lp150.20.12.1
  • nss-myhostname-32bit >= 234-lp150.20.12.1
  • nss-myhostname-32bit-debuginfo >= 234-lp150.20.12.1
  • nss-myhostname-debuginfo >= 234-lp150.20.12.1
  • nss-mymachines >= 234-lp150.20.12.1
  • nss-mymachines-32bit >= 234-lp150.20.12.1
  • nss-mymachines-32bit-debuginfo >= 234-lp150.20.12.1
  • nss-mymachines-debuginfo >= 234-lp150.20.12.1
  • nss-systemd >= 234-lp150.20.12.1
  • nss-systemd-debuginfo >= 234-lp150.20.12.1
  • systemd >= 234-lp150.20.12.1
  • systemd-32bit >= 234-lp150.20.12.1
  • systemd-32bit-debuginfo >= 234-lp150.20.12.1
  • systemd-bash-completion >= 234-lp150.20.12.1
  • systemd-container >= 234-lp150.20.12.1
  • systemd-container-debuginfo >= 234-lp150.20.12.1
  • systemd-coredump >= 234-lp150.20.12.1
  • systemd-coredump-debuginfo >= 234-lp150.20.12.1
  • systemd-debuginfo >= 234-lp150.20.12.1
  • systemd-debugsource >= 234-lp150.20.12.1
  • systemd-devel >= 234-lp150.20.12.1
  • systemd-logger >= 234-lp150.20.12.1
  • systemd-mini >= 234-lp150.20.12.1
  • systemd-mini-bash-completion >= 234-lp150.20.12.1
  • systemd-mini-container-mini >= 234-lp150.20.12.1
  • systemd-mini-container-mini-debuginfo >= 234-lp150.20.12.1
  • systemd-mini-coredump-mini >= 234-lp150.20.12.1
  • systemd-mini-coredump-mini-debuginfo >= 234-lp150.20.12.1
  • systemd-mini-debuginfo >= 234-lp150.20.12.1
  • systemd-mini-debugsource >= 234-lp150.20.12.1
  • systemd-mini-devel >= 234-lp150.20.12.1
  • systemd-mini-sysvinit >= 234-lp150.20.12.1
  • systemd-sysvinit >= 234-lp150.20.12.1
  • udev >= 234-lp150.20.12.1
  • udev-debuginfo >= 234-lp150.20.12.1
  • udev-mini >= 234-lp150.20.12.1
  • udev-mini-debuginfo >= 234-lp150.20.12.1
Patchnames:
openSUSE-2019-98
openSUSE Leap 42.3
  • libsystemd0 >= 228-65.1
  • libsystemd0-32bit >= 228-65.1
  • libsystemd0-debuginfo >= 228-65.1
  • libsystemd0-debuginfo-32bit >= 228-65.1
  • libsystemd0-mini >= 228-65.1
  • libsystemd0-mini-debuginfo >= 228-65.1
  • libudev-devel >= 228-65.1
  • libudev-mini-devel >= 228-65.1
  • libudev-mini1 >= 228-65.1
  • libudev-mini1-debuginfo >= 228-65.1
  • libudev1 >= 228-65.1
  • libudev1-32bit >= 228-65.1
  • libudev1-debuginfo >= 228-65.1
  • libudev1-debuginfo-32bit >= 228-65.1
  • nss-myhostname >= 228-65.1
  • nss-myhostname-32bit >= 228-65.1
  • nss-myhostname-debuginfo >= 228-65.1
  • nss-myhostname-debuginfo-32bit >= 228-65.1
  • nss-mymachines >= 228-65.1
  • nss-mymachines-debuginfo >= 228-65.1
  • systemd >= 228-65.1
  • systemd-32bit >= 228-65.1
  • systemd-bash-completion >= 228-65.1
  • systemd-debuginfo >= 228-65.1
  • systemd-debuginfo-32bit >= 228-65.1
  • systemd-debugsource >= 228-65.1
  • systemd-devel >= 228-65.1
  • systemd-logger >= 228-65.1
  • systemd-mini >= 228-65.1
  • systemd-mini-bash-completion >= 228-65.1
  • systemd-mini-debuginfo >= 228-65.1
  • systemd-mini-debugsource >= 228-65.1
  • systemd-mini-devel >= 228-65.1
  • systemd-mini-sysvinit >= 228-65.1
  • systemd-sysvinit >= 228-65.1
  • udev >= 228-65.1
  • udev-debuginfo >= 228-65.1
  • udev-mini >= 228-65.1
  • udev-mini-debuginfo >= 228-65.1
Patchnames:
openSUSE-2019-97


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 systemd Already fixed
CaaS Platform 2.0 systemd Already fixed
CaaS Platform 3.0 systemd Already fixed
OpenStack Cloud Magnum Orchestration 7.0 systemd Already fixed
SUSE Linux Enterprise Desktop 12 SP3 systemd Already fixed
SUSE Linux Enterprise Desktop 12 SP4 systemd Already fixed
SUSE Linux Enterprise High Performance Computing 12 systemd Already fixed
SUSE Linux Enterprise Module for Basesystem 15 GA systemd Already fixed
SUSE Linux Enterprise SDK 12 SP3 systemd Already fixed
SUSE Linux Enterprise SDK 12 SP4 systemd Already fixed
SUSE Linux Enterprise Server 12 GA LTSS systemd Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS systemd Already fixed
SUSE Linux Enterprise Server 12 SP3 systemd Already fixed
SUSE Linux Enterprise Server 12 SP4 systemd Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 GA systemd Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 systemd Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 systemd Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 systemd Already fixed