Upstream information

CVE-2018-16850 at MITRE

Description

postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can cause arbitrary SQL statements to run, with superuser privileges.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.0
SUSE Bugzilla entry: 1114837 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libecpg6 >= 10.6-1.6.1
  • libpq5 >= 10.6-1.6.1
  • libpq5-32bit >= 10.6-1.6.1
  • postgresql10 >= 10.6-1.6.1
  • postgresql10-libs >= 10.6-1.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2662
SUSE Linux Enterprise Desktop 12 SP4
  • libecpg6 >= 10.6-1.6.1
  • libpq5 >= 10.6-1.6.1
  • libpq5-32bit >= 10.6-1.6.1
  • postgresql10 >= 10.6-1.6.1
  • postgresql10-libs >= 10.6-1.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2018-2662
SUSE Linux Enterprise Module for Basesystem 15
  • libpq5 >= 10.6-4.8.1
  • postgresql10 >= 10.6-4.8.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2813
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libpq5 >= 10.6-6.25
  • postgresql10 >= 10.6-6.26
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libpq5
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • postgresql10 >= 10.6-4.8.1
  • postgresql10-test >= 10.6-4.8.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2018-2813
SUSE Linux Enterprise Module for Server Applications 15
  • libecpg6 >= 10.6-4.8.1
  • postgresql10 >= 10.6-4.8.1
  • postgresql10-contrib >= 10.6-4.8.1
  • postgresql10-devel >= 10.6-4.8.1
  • postgresql10-docs >= 10.6-4.8.1
  • postgresql10-plperl >= 10.6-4.8.1
  • postgresql10-plpython >= 10.6-4.8.1
  • postgresql10-pltcl >= 10.6-4.8.1
  • postgresql10-server >= 10.6-4.8.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2018-2813
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • libecpg6 >= 10.6-6.25
  • postgresql10-contrib >= 10.6-6.26
  • postgresql10-devel >= 10.6-6.25
  • postgresql10-docs >= 10.6-6.26
  • postgresql10-plperl >= 10.6-6.26
  • postgresql10-plpython >= 10.6-6.26
  • postgresql10-pltcl >= 10.6-6.26
  • postgresql10-server >= 10.6-6.26
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA libecpg6
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • postgresql10 >= 10.6-4.8.1
  • postgresql10-test >= 10.6-4.8.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2018-2813
SUSE Linux Enterprise Server 12 SP3
  • libecpg6 >= 10.6-1.6.1
  • libpq5 >= 10.6-1.6.1
  • libpq5-32bit >= 10.6-1.6.1
  • postgresql10 >= 10.6-1.6.1
  • postgresql10-contrib >= 10.6-1.6.1
  • postgresql10-docs >= 10.6-1.6.1
  • postgresql10-libs >= 10.6-1.6.1
  • postgresql10-server >= 10.6-1.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2662
SUSE Linux Enterprise Server 12 SP4
  • libecpg6 >= 10.6-1.6.1
  • libpq5 >= 10.6-1.6.1
  • libpq5-32bit >= 10.6-1.6.1
  • postgresql10 >= 10.6-1.6.1
  • postgresql10-contrib >= 10.6-1.6.1
  • postgresql10-docs >= 10.6-1.6.1
  • postgresql10-libs >= 10.6-1.6.1
  • postgresql10-server >= 10.6-1.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2662
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libecpg6 >= 10.6-1.6.1
  • libpq5 >= 10.6-1.6.1
  • libpq5-32bit >= 10.6-1.6.1
  • postgresql10 >= 10.6-1.6.1
  • postgresql10-contrib >= 10.6-1.6.1
  • postgresql10-docs >= 10.6-1.6.1
  • postgresql10-libs >= 10.6-1.6.1
  • postgresql10-server >= 10.6-1.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2662
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libecpg6 >= 10.6-1.6.1
  • libpq5 >= 10.6-1.6.1
  • libpq5-32bit >= 10.6-1.6.1
  • postgresql10 >= 10.6-1.6.1
  • postgresql10-contrib >= 10.6-1.6.1
  • postgresql10-docs >= 10.6-1.6.1
  • postgresql10-libs >= 10.6-1.6.1
  • postgresql10-server >= 10.6-1.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2662
SUSE Linux Enterprise Software Development Kit 12 SP3
  • postgresql10-devel >= 10.6-1.6.1
  • postgresql10-libs >= 10.6-1.6.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2662
SUSE Linux Enterprise Software Development Kit 12 SP4
  • postgresql10-devel >= 10.6-1.6.1
  • postgresql10-libs >= 10.6-1.6.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2018-2662
openSUSE Leap 15.0
  • libecpg6 >= 10.6-lp150.3.6.1
  • libecpg6-32bit >= 10.6-lp150.3.6.1
  • libecpg6-32bit-debuginfo >= 10.6-lp150.3.6.1
  • libecpg6-debuginfo >= 10.6-lp150.3.6.1
  • libpq5 >= 10.6-lp150.3.6.1
  • libpq5-32bit >= 10.6-lp150.3.6.1
  • libpq5-32bit-debuginfo >= 10.6-lp150.3.6.1
  • libpq5-debuginfo >= 10.6-lp150.3.6.1
  • postgresql10 >= 10.6-lp150.3.6.1
  • postgresql10-contrib >= 10.6-lp150.3.6.1
  • postgresql10-contrib-debuginfo >= 10.6-lp150.3.6.1
  • postgresql10-debuginfo >= 10.6-lp150.3.6.1
  • postgresql10-debugsource >= 10.6-lp150.3.6.1
  • postgresql10-devel >= 10.6-lp150.3.6.1
  • postgresql10-devel-debuginfo >= 10.6-lp150.3.6.1
  • postgresql10-docs >= 10.6-lp150.3.6.1
  • postgresql10-plperl >= 10.6-lp150.3.6.1
  • postgresql10-plperl-debuginfo >= 10.6-lp150.3.6.1
  • postgresql10-plpython >= 10.6-lp150.3.6.1
  • postgresql10-plpython-debuginfo >= 10.6-lp150.3.6.1
  • postgresql10-pltcl >= 10.6-lp150.3.6.1
  • postgresql10-pltcl-debuginfo >= 10.6-lp150.3.6.1
  • postgresql10-server >= 10.6-lp150.3.6.1
  • postgresql10-server-debuginfo >= 10.6-lp150.3.6.1
  • postgresql10-test >= 10.6-lp150.3.6.1
Patchnames:
openSUSE-2019-967
openSUSE Leap 42.3
  • libecpg6 >= 10.6-5.1
  • libecpg6-32bit >= 10.6-5.1
  • libecpg6-debuginfo >= 10.6-5.1
  • libecpg6-debuginfo-32bit >= 10.6-5.1
  • libpq5 >= 10.6-5.1
  • libpq5-32bit >= 10.6-5.1
  • libpq5-debuginfo >= 10.6-5.1
  • libpq5-debuginfo-32bit >= 10.6-5.1
  • postgresql10 >= 10.6-5.1
  • postgresql10-contrib >= 10.6-5.1
  • postgresql10-contrib-debuginfo >= 10.6-5.1
  • postgresql10-debuginfo >= 10.6-5.1
  • postgresql10-debugsource >= 10.6-5.1
  • postgresql10-devel >= 10.6-5.1
  • postgresql10-devel-debuginfo >= 10.6-5.1
  • postgresql10-docs >= 10.6-5.1
  • postgresql10-libs >= 10.6-5.1
  • postgresql10-libs-debugsource >= 10.6-5.1
  • postgresql10-plperl >= 10.6-5.1
  • postgresql10-plperl-debuginfo >= 10.6-5.1
  • postgresql10-plpython >= 10.6-5.1
  • postgresql10-plpython-debuginfo >= 10.6-5.1
  • postgresql10-pltcl >= 10.6-5.1
  • postgresql10-pltcl-debuginfo >= 10.6-5.1
  • postgresql10-server >= 10.6-5.1
  • postgresql10-server-debuginfo >= 10.6-5.1
  • postgresql10-test >= 10.6-5.1
Patchnames:
openSUSE-2018-1460


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 postgresql10 Released
SUSE Linux Enterprise Desktop 12 SP4 postgresql10 Released
SUSE Linux Enterprise High Performance Computing 12 postgresql10 Released
SUSE Linux Enterprise Module for Basesystem 15 GA postgresql10 Released
SUSE Linux Enterprise Module for Server Applications 15 GA postgresql10 Released
SUSE Linux Enterprise Server 12 SP3 postgresql10 Released
SUSE Linux Enterprise Server 12 SP4 postgresql10 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 postgresql10 Released