Upstream information

CVE-2018-16847 at MITRE

Description

An OOB heap buffer r/w access issue was found in the NVM Express Controller emulation in QEMU. It could occur in nvme_cmb_ops routines in nvme device. A guest user/process could use this flaw to crash the QEMU process resulting in DoS or potentially run arbitrary code with privileges of the QEMU process.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7
Vector AV:L/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:H
Access Vector Local
Access Complexity High
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact High
SUSE Bugzilla entries: 1114529 [NEW], 1114540 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for Basesystem 15
  • qemu >= 2.11.2-9.12.2
  • qemu-debuginfo >= 2.11.2-9.12.2
  • qemu-debugsource >= 2.11.2-9.12.2
  • qemu-tools >= 2.11.2-9.12.2
  • qemu-tools-debuginfo >= 2.11.2-9.12.2
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • qemu >= 2.11.2-9.12.2
  • qemu-block-dmg >= 2.11.2-9.12.2
  • qemu-block-dmg-debuginfo >= 2.11.2-9.12.2
  • qemu-debuginfo >= 2.11.2-9.12.2
  • qemu-debugsource >= 2.11.2-9.12.2
  • qemu-extra >= 2.11.2-9.12.2
  • qemu-extra-debuginfo >= 2.11.2-9.12.2
  • qemu-linux-user >= 2.11.2-9.12.1
  • qemu-linux-user-debuginfo >= 2.11.2-9.12.1
  • qemu-linux-user-debugsource >= 2.11.2-9.12.1
SUSE Linux Enterprise Module for Server Applications 15
  • qemu >= 2.11.2-9.12.2
  • qemu-arm >= 2.11.2-9.12.2
  • qemu-arm-debuginfo >= 2.11.2-9.12.2
  • qemu-block-curl >= 2.11.2-9.12.2
  • qemu-block-curl-debuginfo >= 2.11.2-9.12.2
  • qemu-block-iscsi >= 2.11.2-9.12.2
  • qemu-block-iscsi-debuginfo >= 2.11.2-9.12.2
  • qemu-block-rbd >= 2.11.2-9.12.2
  • qemu-block-rbd-debuginfo >= 2.11.2-9.12.2
  • qemu-block-ssh >= 2.11.2-9.12.2
  • qemu-block-ssh-debuginfo >= 2.11.2-9.12.2
  • qemu-debuginfo >= 2.11.2-9.12.2
  • qemu-debugsource >= 2.11.2-9.12.2
  • qemu-guest-agent >= 2.11.2-9.12.2
  • qemu-guest-agent-debuginfo >= 2.11.2-9.12.2
  • qemu-ipxe >= 1.0.0+-9.12.2
  • qemu-kvm >= 2.11.2-9.12.2
  • qemu-lang >= 2.11.2-9.12.2
  • qemu-ppc >= 2.11.2-9.12.2
  • qemu-ppc-debuginfo >= 2.11.2-9.12.2
  • qemu-s390 >= 2.11.2-9.12.2
  • qemu-s390-debuginfo >= 2.11.2-9.12.2
  • qemu-seabios >= 1.11.0-9.12.2
  • qemu-sgabios >= 8-9.12.2
  • qemu-vgabios >= 1.11.0-9.12.2
  • qemu-x86 >= 2.11.2-9.12.2
  • qemu-x86-debuginfo >= 2.11.2-9.12.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 qemu Not affected
CaaS Platform 1.0 xen Not affected
CaaS Platform 2.0 qemu Not affected
CaaS Platform 2.0 xen Not affected
CaaS Platform 3.0 qemu Not affected
CaaS Platform 3.0 xen Not affected
SUSE Linux Enterprise Desktop 12 SP3 qemu Not affected
SUSE Linux Enterprise Desktop 12 SP3 xen Not affected
SUSE Linux Enterprise Desktop 12 SP4 qemu In progress
SUSE Linux Enterprise Desktop 12 SP4 xen Not affected
SUSE Linux Enterprise High Performance Computing 12 qemu In progress
SUSE Linux Enterprise High Performance Computing 12 xen Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA qemu In progress
SUSE Linux Enterprise Module for Basesystem 15 GA xen Not affected
SUSE Linux Enterprise Module for Server Applications 15 GA qemu In progress
SUSE Linux Enterprise Module for Server Applications 15 GA xen Not affected
SUSE Linux Enterprise Point of Sale 11 SP3 qemu Not affected
SUSE Linux Enterprise SDK 11 SP4 qemu Not affected
SUSE Linux Enterprise SDK 11 SP4 xen Not affected
SUSE Linux Enterprise SDK 12 SP3 xen Not affected
SUSE Linux Enterprise SDK 12 SP4 xen Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS kvm Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS xen Not affected
SUSE Linux Enterprise Server 11 SP4 kvm Not affected
SUSE Linux Enterprise Server 11 SP4 xen Not affected
SUSE Linux Enterprise Server 12 GA LTSS qemu Not affected
SUSE Linux Enterprise Server 12 GA LTSS xen Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS qemu Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS xen Not affected
SUSE Linux Enterprise Server 12 SP3 qemu Not affected
SUSE Linux Enterprise Server 12 SP3 xen Not affected
SUSE Linux Enterprise Server 12 SP4 qemu In progress
SUSE Linux Enterprise Server 12 SP4 xen Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 kvm Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 xen Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA xen Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 xen Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 qemu In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 xen Not affected
SUSE Studio Onsite 1.3 qemu Not affected