Upstream information

CVE-2018-16802 at MITRE

Description

An issue was discovered in Artifex Ghostscript before 9.25. Incorrect "restoration of privilege" checking when running out of stack during exception handling could be used by attackers able to supply crafted PostScript to execute code using the "pipe" instruction. This is due to an incomplete fix for CVE-2018-16509.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1107410 [NEW], 1108027 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-Storage-4-2018-2121
SUSE Linux Enterprise Build System Kit 12 SP3
  • ghostscript-mini >= 9.25-23.13.1
  • ghostscript-mini-devel >= 9.25-23.13.1
Patchnames:
SUSE-SLE-BSK-12-SP3-2018-2121
SUSE Linux Enterprise Desktop 12 SP3
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2121
SUSE Linux Enterprise Module for Basesystem 15
  • ghostscript >= 9.25-3.6.1
  • ghostscript-devel >= 9.25-3.6.1
  • ghostscript-x11 >= 9.25-3.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2119
SUSE Linux Enterprise Module for Desktop Applications 15
  • libspectre >= 0.2.8-3.2.1
  • libspectre-devel >= 0.2.8-3.2.1
  • libspectre1 >= 0.2.8-3.2.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-2119
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-2121
SUSE Linux Enterprise Server 12 SP1-LTSS
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2121
SUSE Linux Enterprise Server 12 SP2-BCL
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-2121
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-2121
SUSE Linux Enterprise Server 12 SP2-LTSS
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-2121
SUSE Linux Enterprise Server 12 SP3
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2121
SUSE Linux Enterprise Server 12-LTSS
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2121
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2121
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-2121
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-2121
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-2121
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-2121
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2121
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2121
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ghostscript >= 9.25-23.13.1
  • ghostscript-devel >= 9.25-23.13.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2121
SUSE OpenStack Cloud 7
  • ghostscript >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-2121
openSUSE Leap 15.0
  • ghostscript >= 9.25-lp150.2.6.1
  • ghostscript-debuginfo >= 9.25-lp150.2.6.1
  • ghostscript-debugsource >= 9.25-lp150.2.6.1
  • ghostscript-devel >= 9.25-lp150.2.6.1
  • ghostscript-mini >= 9.25-lp150.2.6.1
  • ghostscript-mini-debuginfo >= 9.25-lp150.2.6.1
  • ghostscript-mini-debugsource >= 9.25-lp150.2.6.1
  • ghostscript-mini-devel >= 9.25-lp150.2.6.1
  • ghostscript-x11 >= 9.25-lp150.2.6.1
  • ghostscript-x11-debuginfo >= 9.25-lp150.2.6.1
  • libspectre >= 0.2.8-lp150.2.3.1
  • libspectre-debugsource >= 0.2.8-lp150.2.3.1
  • libspectre-devel >= 0.2.8-lp150.2.3.1
  • libspectre1 >= 0.2.8-lp150.2.3.1
  • libspectre1-debuginfo >= 0.2.8-lp150.2.3.1
Patchnames:
openSUSE-2018-1123
openSUSE Leap 42.3
  • ghostscript >= 9.25-14.9.1
  • ghostscript-debuginfo >= 9.25-14.9.1
  • ghostscript-debugsource >= 9.25-14.9.1
  • ghostscript-devel >= 9.25-14.9.1
  • ghostscript-mini >= 9.25-14.9.1
  • ghostscript-mini-debuginfo >= 9.25-14.9.1
  • ghostscript-mini-debugsource >= 9.25-14.9.1
  • ghostscript-mini-devel >= 9.25-14.9.1
  • ghostscript-x11 >= 9.25-14.9.1
  • ghostscript-x11-debuginfo >= 9.25-14.9.1
Patchnames:
openSUSE-2018-1122


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 ghostscript Released
SUSE Linux Enterprise Module for Basesystem 15 GA ghostscript Released
SUSE Linux Enterprise SDK 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise SDK 12 SP3 ghostscript Released
SUSE Linux Enterprise Server 11 SP3 LTSS ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise Server 12 GA LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP1 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP2 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP3 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ghostscript Released