Upstream information

CVE-2018-16749 at MITRE

Description

In ImageMagick 7.0.7-29 and earlier, a missing NULL check in ReadOneJNGImage in coders/png.c allows an attacker to cause a denial of service (WriteBlob assertion failure and application exit) via a crafted file.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v3 Scores
  SUSE
Base Score 2.8
Vector AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
SUSE Bugzilla entry: 1108282 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • ImageMagick >= 6.8.8.1-71.79.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.79.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.79.1
  • libMagickCore-6_Q16-1-32bit >= 6.8.8.1-71.79.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.79.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2195
SUSE Linux Enterprise Server 12 SP3
  • ImageMagick >= 6.8.8.1-71.79.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.79.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.79.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2195
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ImageMagick >= 6.8.8.1-71.79.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.79.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.79.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2195
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ImageMagick >= 6.8.8.1-71.79.1
  • ImageMagick-devel >= 6.8.8.1-71.79.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.79.1
  • libMagick++-devel >= 6.8.8.1-71.79.1
  • perl-PerlMagick >= 6.8.8.1-71.79.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2195
SUSE Linux Enterprise Workstation Extension 12 SP3
  • ImageMagick >= 6.8.8.1-71.79.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.79.1
  • libMagickCore-6_Q16-1-32bit >= 6.8.8.1-71.79.1
Patchnames:
SUSE-SLE-WE-12-SP3-2018-2195
openSUSE Leap 42.3
  • GraphicsMagick >= 1.3.25-108.1
  • GraphicsMagick-debuginfo >= 1.3.25-108.1
  • GraphicsMagick-debugsource >= 1.3.25-108.1
  • GraphicsMagick-devel >= 1.3.25-108.1
  • ImageMagick >= 6.8.8.1-70.2
  • ImageMagick-debuginfo >= 6.8.8.1-70.2
  • ImageMagick-debugsource >= 6.8.8.1-70.2
  • ImageMagick-devel >= 6.8.8.1-70.2
  • ImageMagick-devel-32bit >= 6.8.8.1-70.2
  • ImageMagick-doc >= 6.8.8.1-70.2
  • ImageMagick-extra >= 6.8.8.1-70.2
  • ImageMagick-extra-debuginfo >= 6.8.8.1-70.2
  • libGraphicsMagick++-Q16-12 >= 1.3.25-108.1
  • libGraphicsMagick++-Q16-12-debuginfo >= 1.3.25-108.1
  • libGraphicsMagick++-devel >= 1.3.25-108.1
  • libGraphicsMagick-Q16-3 >= 1.3.25-108.1
  • libGraphicsMagick-Q16-3-debuginfo >= 1.3.25-108.1
  • libGraphicsMagick3-config >= 1.3.25-108.1
  • libGraphicsMagickWand-Q16-2 >= 1.3.25-108.1
  • libGraphicsMagickWand-Q16-2-debuginfo >= 1.3.25-108.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-70.2
  • libMagick++-6_Q16-3-32bit >= 6.8.8.1-70.2
  • libMagick++-6_Q16-3-debuginfo >= 6.8.8.1-70.2
  • libMagick++-6_Q16-3-debuginfo-32bit >= 6.8.8.1-70.2
  • libMagick++-devel >= 6.8.8.1-70.2
  • libMagick++-devel-32bit >= 6.8.8.1-70.2
  • libMagickCore-6_Q16-1 >= 6.8.8.1-70.2
  • libMagickCore-6_Q16-1-32bit >= 6.8.8.1-70.2
  • libMagickCore-6_Q16-1-debuginfo >= 6.8.8.1-70.2
  • libMagickCore-6_Q16-1-debuginfo-32bit >= 6.8.8.1-70.2
  • libMagickWand-6_Q16-1 >= 6.8.8.1-70.2
  • libMagickWand-6_Q16-1-32bit >= 6.8.8.1-70.2
  • libMagickWand-6_Q16-1-debuginfo >= 6.8.8.1-70.2
  • libMagickWand-6_Q16-1-debuginfo-32bit >= 6.8.8.1-70.2
  • perl-GraphicsMagick >= 1.3.25-108.1
  • perl-GraphicsMagick-debuginfo >= 1.3.25-108.1
  • perl-PerlMagick >= 6.8.8.1-70.2
  • perl-PerlMagick-debuginfo >= 6.8.8.1-70.2
Patchnames:
openSUSE-2018-1045
openSUSE-2018-1181

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Server 11 SP4
  • ImageMagick >= 6.4.3.6-78.74.1
  • libMagickCore1 >= 6.4.3.6-78.74.1
  • libMagickCore1-32bit >= 6.4.3.6-78.74.1
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • ImageMagick >= 6.4.3.6-78.74.1
  • libMagickCore1 >= 6.4.3.6-78.74.1
  • libMagickCore1-32bit >= 6.4.3.6-78.74.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • GraphicsMagick >= 1.2.5-78.72.1
  • ImageMagick >= 6.4.3.6-78.74.1
  • ImageMagick-devel >= 6.4.3.6-78.74.1
  • libGraphicsMagick2 >= 1.2.5-78.72.1
  • libMagick++-devel >= 6.4.3.6-78.74.1
  • libMagick++1 >= 6.4.3.6-78.74.1
  • libMagickWand1 >= 6.4.3.6-78.74.1
  • libMagickWand1-32bit >= 6.4.3.6-78.74.1
  • perl-GraphicsMagick >= 1.2.5-78.72.1
  • perl-PerlMagick >= 6.4.3.6-78.74.1
SUSE Studio Onsite 1.3
  • GraphicsMagick >= 1.2.5-78.72.1
  • libGraphicsMagick2 >= 1.2.5-78.72.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 ImageMagick Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA ImageMagick Already fixed
SUSE Linux Enterprise Module for Development Tools 15 GA ImageMagick Already fixed
SUSE Linux Enterprise SDK 11 SP4 GraphicsMagick In progress
SUSE Linux Enterprise SDK 11 SP4 ImageMagick In progress
SUSE Linux Enterprise SDK 12 SP3 ImageMagick Released
SUSE Linux Enterprise Server 11 SP3 LTSS ImageMagick Affected
SUSE Linux Enterprise Server 11 SP4 ImageMagick In progress
SUSE Linux Enterprise Server 12 GA LTSS ImageMagick Affected
SUSE Linux Enterprise Server 12 SP1 LTSS ImageMagick Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ImageMagick Affected
SUSE Linux Enterprise Server 12 SP3 ImageMagick Released
SUSE Linux Enterprise Workstation Extension 12 SP3 ImageMagick Released
SUSE Studio Onsite 1.3 GraphicsMagick In progress