Upstream information

CVE-2018-16476 at MITRE

Description

A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entry: 1117632 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • ruby2.1-rubygem-activejob-4_2 >= 4.2.9-3.6.1
  • rubygem-activejob-4_2 >= 4.2.9-3.6.1
Patchnames:
SUSE-Storage-4-2019-152
SUSE Linux Enterprise High Availability 15
  • ruby2.5-rubygem-activejob-5_1 >= 5.1.4-3.3.1
  • rubygem-activejob-5_1 >= 5.1.4-3.3.1
Patchnames:
SUSE-SLE-Product-HA-15-2018-2857
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • ruby2.5-rubygem-activejob-doc-5_1 >= 5.1.4-3.3.1
  • rubygem-activejob-5_1 >= 5.1.4-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2018-2857
SUSE OpenStack Cloud 7
  • ruby2.1-rubygem-activejob-4_2 >= 4.2.9-3.6.1
  • rubygem-activejob-4_2 >= 4.2.9-3.6.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-152
SUSE OpenStack Cloud Crowbar 8
  • ruby2.1-rubygem-activejob-4_2 >= 4.2.9-3.6.1
  • rubygem-activejob-4_2 >= 4.2.9-3.6.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-152
openSUSE Leap 15.0
  • ruby2.5-rubygem-activejob-5_1 >= 5.1.4-lp150.2.3.1
  • ruby2.5-rubygem-activejob-doc-5_1 >= 5.1.4-lp150.2.3.1
Patchnames:
openSUSE-2019-982


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability 15 GA rubygem-activejob-5_1 Released
SUSE Openstack Cloud 6 rubygem-activejob-4_2 Affected
SUSE Openstack Cloud 7 rubygem-activejob-4_2 Released
SUSE Openstack Cloud 8 rubygem-activejob-4_2 Released
SUSE Storage 4 rubygem-activejob-4_2 Released