Upstream information

CVE-2018-16057 at MITRE

Description

In Wireshark 2.6.0 to 2.6.2, 2.4.0 to 2.4.8, and 2.2.0 to 2.2.16, the Radiotap dissector could crash. This was addressed in epan/dissectors/packet-ieee80211-radiotap-iter.c by validating iterator operations.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7.1
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact Low
Availability Impact High
SUSE Bugzilla entry: 1106514 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-Storage-4-2018-2051
SUSE Linux Enterprise Desktop 12 SP3
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2051
SUSE Linux Enterprise Module for Basesystem 15
  • libwireshark9 >= 2.4.9-3.9.1
  • libwiretap7 >= 2.4.9-3.9.1
  • libwscodecs1 >= 2.4.9-3.9.1
  • libwsutil8 >= 2.4.9-3.9.1
  • wireshark >= 2.4.9-3.9.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2052
SUSE Linux Enterprise Module for Desktop Applications 15
  • wireshark >= 2.4.9-3.9.1
  • wireshark-devel >= 2.4.9-3.9.1
  • wireshark-ui-qt >= 2.4.9-3.9.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-2052
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-2051
SUSE Linux Enterprise Server 11 SP4
  • libwireshark8 >= 2.2.17-40.31.1
  • libwiretap6 >= 2.2.17-40.31.1
  • libwscodecs1 >= 2.2.17-40.31.1
  • libwsutil7 >= 2.2.17-40.31.1
  • wireshark >= 2.2.17-40.31.1
  • wireshark-gtk >= 2.2.17-40.31.1
Patchnames:
slessp4-wireshark-13792
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2051
SUSE Linux Enterprise Server 12 SP2-BCL
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-2051
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-2051
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-2051
SUSE Linux Enterprise Server 12 SP3
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2051
SUSE Linux Enterprise Server 12-LTSS
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2051
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libwireshark8 >= 2.2.17-40.31.1
  • libwiretap6 >= 2.2.17-40.31.1
  • libwscodecs1 >= 2.2.17-40.31.1
  • libwsutil7 >= 2.2.17-40.31.1
  • wireshark >= 2.2.17-40.31.1
  • wireshark-gtk >= 2.2.17-40.31.1
Patchnames:
slessp4-wireshark-13792
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-2051
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2051
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-2051
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-2051
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-2051
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-2051
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2051
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2051
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libwireshark8 >= 2.2.17-40.31.1
  • libwiretap6 >= 2.2.17-40.31.1
  • libwscodecs1 >= 2.2.17-40.31.1
  • libwsutil7 >= 2.2.17-40.31.1
  • wireshark >= 2.2.17-40.31.1
  • wireshark-devel >= 2.2.17-40.31.1
  • wireshark-gtk >= 2.2.17-40.31.1
Patchnames:
sdksp4-wireshark-13792
SUSE Linux Enterprise Software Development Kit 12 SP3
  • wireshark >= 2.4.9-48.29.1
  • wireshark-devel >= 2.4.9-48.29.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2051
SUSE OpenStack Cloud 7
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-2051
openSUSE Leap 15.0
  • libwireshark9 >= 2.4.9-lp150.2.10.1
  • libwireshark9-debuginfo >= 2.4.9-lp150.2.10.1
  • libwiretap7 >= 2.4.9-lp150.2.10.1
  • libwiretap7-debuginfo >= 2.4.9-lp150.2.10.1
  • libwscodecs1 >= 2.4.9-lp150.2.10.1
  • libwscodecs1-debuginfo >= 2.4.9-lp150.2.10.1
  • libwsutil8 >= 2.4.9-lp150.2.10.1
  • libwsutil8-debuginfo >= 2.4.9-lp150.2.10.1
  • wireshark >= 2.4.9-lp150.2.10.1
  • wireshark-debuginfo >= 2.4.9-lp150.2.10.1
  • wireshark-debugsource >= 2.4.9-lp150.2.10.1
  • wireshark-devel >= 2.4.9-lp150.2.10.1
  • wireshark-ui-qt >= 2.4.9-lp150.2.10.1
  • wireshark-ui-qt-debuginfo >= 2.4.9-lp150.2.10.1
Patchnames:
openSUSE-2018-972
openSUSE Leap 42.3
  • wireshark >= 2.2.17-47.1
  • wireshark-debuginfo >= 2.2.17-47.1
  • wireshark-debugsource >= 2.2.17-47.1
  • wireshark-devel >= 2.2.17-47.1
  • wireshark-ui-gtk >= 2.2.17-47.1
  • wireshark-ui-gtk-debuginfo >= 2.2.17-47.1
  • wireshark-ui-qt >= 2.2.17-47.1
  • wireshark-ui-qt-debuginfo >= 2.2.17-47.1
Patchnames:
openSUSE-2018-949


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 wireshark Released
SUSE Linux Enterprise Module for Basesystem 15 GA wireshark Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA wireshark Released
SUSE Linux Enterprise SDK 11 SP4 wireshark Released
SUSE Linux Enterprise SDK 12 SP3 wireshark Released
SUSE Linux Enterprise Server 11 SP3 LTSS wireshark Affected
SUSE Linux Enterprise Server 11 SP4 wireshark Released
SUSE Linux Enterprise Server 12 GA LTSS wireshark Released
SUSE Linux Enterprise Server 12 SP1 LTSS wireshark Released
SUSE Linux Enterprise Server 12 SP2 LTSS wireshark Released
SUSE Linux Enterprise Server 12 SP3 wireshark Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 wireshark Released