Upstream information

CVE-2018-15919 at MITRE

Description

Remotely observable behaviour in auth-gss2.c in OpenSSH through 7.8 could be used by remote attackers to detect existence of users on a target system when GSS2 is in use. NOTE: the discoverer states 'We understand that the OpenSSH developers do not want to treat such a username enumeration (or "oracle") as a vulnerability.'

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.3 5.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entries: 1105010 [RESOLVED / FIXED], 1106163 [IN_PROGRESS], 1114890 [RESOLVED / DUPLICATE], 1115654 [RESOLVED / FIXED], 1123133 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • openssh >= 7.6p1-9.3.1
  • openssh-helpers >= 7.6p1-9.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2619
SUSE Linux Enterprise Module for Desktop Applications 15
  • openssh-askpass-gnome >= 7.6p1-9.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-2619
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • openssh >= 7.6p1-9.3.1
  • openssh-cavs >= 7.6p1-9.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2018-2619
SUSE Linux Enterprise Module for Server Applications 15
  • openssh >= 7.6p1-9.3.1
  • openssh-fips >= 7.6p1-9.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2018-2619
SUSE Linux Enterprise Point of Sale 11 SP3
  • openssh >= 6.2p2-0.41.5.1
  • openssh-askpass >= 6.2p2-0.41.5.1
  • openssh-askpass-gnome >= 6.2p2-0.41.5.1
Patchnames:
sleposp3-openssh-13848
SUSE Linux Enterprise Server 11 SP3-LTSS
  • openssh >= 6.2p2-0.41.5.1
  • openssh-askpass >= 6.2p2-0.41.5.1
  • openssh-askpass-gnome >= 6.2p2-0.41.5.1
Patchnames:
slessp3-openssh-13848
SUSE Linux Enterprise Server 11 SP4
  • openssh >= 6.6p1-36.6.1
  • openssh-askpass-gnome >= 6.6p1-36.6.1
  • openssh-fips >= 6.6p1-36.6.1
  • openssh-helpers >= 6.6p1-36.6.1
Patchnames:
slessp4-openssh-13867
SUSE Linux Enterprise Server 11-SECURITY
  • openssh-openssl1 >= 6.6p1-19.6.1
  • openssh-openssl1-helpers >= 6.6p1-19.6.1
Patchnames:
secsp3-openssh-openssl1-13865
SUSE Linux Enterprise Server 12 SP1-LTSS
  • openssh >= 6.6p1-54.18.1
  • openssh-askpass-gnome >= 6.6p1-54.18.1
  • openssh-fips >= 6.6p1-54.18.1
  • openssh-helpers >= 6.6p1-54.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2698
SUSE Linux Enterprise Server 12-LTSS
  • openssh >= 6.6p1-54.18.1
  • openssh-askpass-gnome >= 6.6p1-54.18.1
  • openssh-fips >= 6.6p1-54.18.1
  • openssh-helpers >= 6.6p1-54.18.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2698
SUSE Linux Enterprise Server for SAP Applications 11 SP3-LTSS
  • openssh >= 6.2p2-0.41.5.1
  • openssh-askpass >= 6.2p2-0.41.5.1
  • openssh-askpass-gnome >= 6.2p2-0.41.5.1
Patchnames:
slessp3-openssh-13848
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • openssh >= 6.6p1-36.6.1
  • openssh-askpass-gnome >= 6.6p1-36.6.1
  • openssh-fips >= 6.6p1-36.6.1
  • openssh-helpers >= 6.6p1-36.6.1
Patchnames:
slessp4-openssh-13867
SUSE Linux Enterprise Server for SAP Applications 11-SECURITY
  • openssh-openssl1 >= 6.6p1-19.6.1
  • openssh-openssl1-helpers >= 6.6p1-19.6.1
Patchnames:
secsp3-openssh-openssl1-13865
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • openssh >= 6.6p1-54.18.1
  • openssh-askpass-gnome >= 6.6p1-54.18.1
  • openssh-fips >= 6.6p1-54.18.1
  • openssh-helpers >= 6.6p1-54.18.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-1081
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • openssh >= 6.6p1-54.18.1
  • openssh-askpass-gnome >= 6.6p1-54.18.1
  • openssh-fips >= 6.6p1-54.18.1
  • openssh-helpers >= 6.6p1-54.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2698
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • openssh >= 6.6p1-54.18.1
  • openssh-askpass-gnome >= 6.6p1-54.18.1
  • openssh-fips >= 6.6p1-54.18.1
  • openssh-helpers >= 6.6p1-54.18.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2698
openSUSE Leap 15.0
  • openssh >= 7.6p1-lp150.8.3.1
  • openssh-askpass-gnome >= 7.6p1-lp150.8.3.1
  • openssh-askpass-gnome-debuginfo >= 7.6p1-lp150.8.3.1
  • openssh-cavs >= 7.6p1-lp150.8.3.1
  • openssh-cavs-debuginfo >= 7.6p1-lp150.8.3.1
  • openssh-debuginfo >= 7.6p1-lp150.8.3.1
  • openssh-debugsource >= 7.6p1-lp150.8.3.1
  • openssh-fips >= 7.6p1-lp150.8.3.1
  • openssh-helpers >= 7.6p1-lp150.8.3.1
  • openssh-helpers-debuginfo >= 7.6p1-lp150.8.3.1
Patchnames:
openSUSE-2019-914


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 openssh Already fixed
CaaS Platform 2.0 openssh Already fixed
CaaS Platform 3.0 openssh Already fixed
OpenStack Cloud Magnum Orchestration 7.0 openssh Already fixed
SUSE Linux Enterprise Desktop 12 SP3 openssh Already fixed
SUSE Linux Enterprise Desktop 12 SP4 openssh Already fixed
SUSE Linux Enterprise High Performance Computing 12 openssh Already fixed
SUSE Linux Enterprise Module for Basesystem 15 GA openssh Already fixed
SUSE Linux Enterprise Module for Server Applications 15 GA openssh Already fixed
SUSE Linux Enterprise Server 11 SP3 LTSS openssh Already fixed
SUSE Linux Enterprise Server 12 GA LTSS openssh Already fixed
SUSE Linux Enterprise Server 12 SP1 LTSS openssh Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS openssh Already fixed
SUSE Linux Enterprise Server 12 SP3 openssh Already fixed
SUSE Linux Enterprise Server 12 SP4 openssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 11 SP3 openssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 GA openssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssh Already fixed