Upstream information

CVE-2018-14780 at MITRE

Description

An out-of-bounds read issue was discovered in the Yubico-Piv 1.5.0 smartcard driver. The file lib/ykpiv.c contains the following code in the function `_ykpiv_fetch_object()`: {% highlight c %} if(sw == SW_SUCCESS) { size_t outlen; int offs = _ykpiv_get_length(data + 1, &outlen); if(offs == 0) { return YKPIV_SIZE_ERROR; } memmove(data, data + 1 + offs, outlen); *len = outlen; return YKPIV_OK; } else { return YKPIV_GENERIC_ERROR; } {% endhighlight %} -- in the end, a `memmove()` occurs with a length retrieved from APDU data. This length is not checked for whether it is outside of the APDU data retrieved. Therefore the `memmove()` could copy bytes behind the allocated data buffer into this buffer.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 4.6 2.2
Vector AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N AV:P/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N
Access Vector Physical Physical
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entries: 1104809 [IN_PROGRESS], 1104811 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP4
  • libykcs11-1 >= 1.5.0-3.16
  • libykpiv1 >= 1.5.0-3.16
  • yubico-piv-tool >= 1.5.0-3.16
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libykcs11-1
SUSE Linux Enterprise Module for Basesystem 15
  • libykcs11-1 >= 1.5.0-3.3.33
  • libykcs11-devel >= 1.5.0-3.3.33
  • libykpiv-devel >= 1.5.0-3.3.33
  • libykpiv1 >= 1.5.0-3.3.33
  • yubico-piv-tool >= 1.5.0-3.3.33
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1123
SUSE Linux Enterprise Server 12 SP4
  • libykcs11-1 >= 1.5.0-3.16
  • libykpiv1 >= 1.5.0-3.16
  • yubico-piv-tool >= 1.5.0-3.16
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libykcs11-1
openSUSE Leap 15.0
  • libykcs11-1 >= 1.5.0-lp150.2.3.1
  • libykcs11-1-debuginfo >= 1.5.0-lp150.2.3.1
  • libykcs11-devel >= 1.5.0-lp150.2.3.1
  • libykpiv-devel >= 1.5.0-lp150.2.3.1
  • libykpiv1 >= 1.5.0-lp150.2.3.1
  • libykpiv1-debuginfo >= 1.5.0-lp150.2.3.1
  • yubico-piv-tool >= 1.5.0-lp150.2.3.1
  • yubico-piv-tool-debuginfo >= 1.5.0-lp150.2.3.1
  • yubico-piv-tool-debugsource >= 1.5.0-lp150.2.3.1
Patchnames:
openSUSE-2019-1341
openSUSE Leap 42.3
  • libykpiv-devel >= 0.1.6-7.3.1
  • libykpiv1 >= 0.1.6-7.3.1
  • libykpiv1-debuginfo >= 0.1.6-7.3.1
  • yubico-piv-tool >= 0.1.6-7.3.1
  • yubico-piv-tool-debuginfo >= 0.1.6-7.3.1
  • yubico-piv-tool-debugsource >= 0.1.6-7.3.1
Patchnames:
openSUSE-2018-969


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Basesystem 15 GA yubico-piv-tool Released