Upstream information

CVE-2018-14645 at MITRE

Description

A flaw was discovered in the HPACK decoder of HAProxy, before 1.8.14, that is used for HTTP/2. An out-of-bounds read access in hpack_valid_idx() resulted in a remote crash and denial of service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1108683 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 15
  • haproxy >= 1.8.14~git0.52e4d43b-3.3.2
Patchnames:
SUSE-SLE-Product-HA-15-2018-2332
openSUSE Leap 15.0
  • haproxy >= 1.8.14~git0.52e4d43b-lp150.2.3.1
  • haproxy-debuginfo >= 1.8.14~git0.52e4d43b-lp150.2.3.1
  • haproxy-debugsource >= 1.8.14~git0.52e4d43b-lp150.2.3.1
Patchnames:
openSUSE-2018-1229


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 haproxy Not affected
SUSE Linux Enterprise High Availability 12 SP2 haproxy Not affected
SUSE Linux Enterprise High Availability 12 SP3 haproxy Not affected
SUSE Linux Enterprise High Availability 15 GA haproxy Released
SUSE Openstack Cloud 7 haproxy Not affected
SUSE Openstack Cloud 8 haproxy Not affected