Upstream information

CVE-2018-12892 at MITRE

Description

An issue was discovered in Xen 4.7 through 4.10.x. libxl fails to pass the readonly flag to qemu when setting up a SCSI disk, due to what was probably an erroneous merge conflict resolution. Malicious guest administrators or (in some situations) users may be able to write to supposedly read-only disk images. Only emulated SCSI disks (specified as "sd" in the libxl disk configuration, or an equivalent) are affected. IDE disks ("hd") are not affected (because attempts to make them readonly are rejected). Additionally, CDROM devices (that is, devices specified to be presented to the guest as CDROMs, regardless of the nature of the backing storage on the host) are not affected; they are always read only. Only systems using qemu-xen (rather than qemu-xen-traditional) as the device model version are vulnerable. Only systems using libxl or libxl-based toolstacks are vulnerable. (This includes xl, and libvirt with the libxl driver.) The vulnerability is present in Xen versions 4.7 and later. (In earlier versions, provided that the patch for XSA-142 has been applied, attempts to create read only disks are rejected.) If the host and guest together usually support PVHVM, the issue is exploitable only if the malicious guest administrator has control of the guest kernel or guest kernel command line.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.5
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact None
SUSE Bugzilla entry: 1097523 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform ALL
  • xen >= 4.9.2_08-3.35.2
  • xen-libs >= 4.9.2_08-3.35.2
  • xen-tools-domU >= 4.9.2_08-3.35.2
Patchnames:
SUSE-CAASP-ALL-2018-1388
SUSE Enterprise Storage 4
  • xen >= 4.7.6_02-43.36.1
  • xen-doc-html >= 4.7.6_02-43.36.1
  • xen-libs >= 4.7.6_02-43.36.1
  • xen-libs-32bit >= 4.7.6_02-43.36.1
  • xen-tools >= 4.7.6_02-43.36.1
  • xen-tools-domU >= 4.7.6_02-43.36.1
Patchnames:
SUSE-Storage-4-2018-1414
SUSE Linux Enterprise Desktop 12 SP3
  • xen >= 4.9.2_08-3.35.2
  • xen-libs >= 4.9.2_08-3.35.2
  • xen-libs-32bit >= 4.9.2_08-3.35.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1388
SUSE Linux Enterprise Module for Basesystem 15
  • xen >= 4.10.1_06-3.3.1
  • xen-libs >= 4.10.1_06-3.3.1
  • xen-tools-domU >= 4.10.1_06-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1342
SUSE Linux Enterprise Module for Server Applications 15
  • xen >= 4.10.1_06-3.3.1
  • xen-devel >= 4.10.1_06-3.3.1
  • xen-tools >= 4.10.1_06-3.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2018-1342
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • xen >= 4.7.6_02-43.36.1
  • xen-doc-html >= 4.7.6_02-43.36.1
  • xen-libs >= 4.7.6_02-43.36.1
  • xen-libs-32bit >= 4.7.6_02-43.36.1
  • xen-tools >= 4.7.6_02-43.36.1
  • xen-tools-domU >= 4.7.6_02-43.36.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-1414
SUSE Linux Enterprise Server 12 SP2-BCL
  • xen >= 4.7.6_02-43.36.1
  • xen-doc-html >= 4.7.6_02-43.36.1
  • xen-libs >= 4.7.6_02-43.36.1
  • xen-libs-32bit >= 4.7.6_02-43.36.1
  • xen-tools >= 4.7.6_02-43.36.1
  • xen-tools-domU >= 4.7.6_02-43.36.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1414
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • xen >= 4.7.6_02-43.36.1
  • xen-doc-html >= 4.7.6_02-43.36.1
  • xen-libs >= 4.7.6_02-43.36.1
  • xen-libs-32bit >= 4.7.6_02-43.36.1
  • xen-tools >= 4.7.6_02-43.36.1
  • xen-tools-domU >= 4.7.6_02-43.36.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1414
SUSE Linux Enterprise Server 12 SP2-LTSS
  • xen >= 4.7.6_02-43.36.1
  • xen-doc-html >= 4.7.6_02-43.36.1
  • xen-libs >= 4.7.6_02-43.36.1
  • xen-libs-32bit >= 4.7.6_02-43.36.1
  • xen-tools >= 4.7.6_02-43.36.1
  • xen-tools-domU >= 4.7.6_02-43.36.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1414
SUSE Linux Enterprise Server 12 SP3
  • xen >= 4.9.2_08-3.35.2
  • xen-doc-html >= 4.9.2_08-3.35.2
  • xen-libs >= 4.9.2_08-3.35.2
  • xen-libs-32bit >= 4.9.2_08-3.35.2
  • xen-tools >= 4.9.2_08-3.35.2
  • xen-tools-domU >= 4.9.2_08-3.35.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1388
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • xen >= 4.7.6_02-43.36.1
  • xen-doc-html >= 4.7.6_02-43.36.1
  • xen-libs >= 4.7.6_02-43.36.1
  • xen-libs-32bit >= 4.7.6_02-43.36.1
  • xen-tools >= 4.7.6_02-43.36.1
  • xen-tools-domU >= 4.7.6_02-43.36.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-1414
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • xen >= 4.7.6_02-43.36.1
  • xen-doc-html >= 4.7.6_02-43.36.1
  • xen-libs >= 4.7.6_02-43.36.1
  • xen-libs-32bit >= 4.7.6_02-43.36.1
  • xen-tools >= 4.7.6_02-43.36.1
  • xen-tools-domU >= 4.7.6_02-43.36.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1414
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • xen >= 4.7.6_02-43.36.1
  • xen-doc-html >= 4.7.6_02-43.36.1
  • xen-libs >= 4.7.6_02-43.36.1
  • xen-libs-32bit >= 4.7.6_02-43.36.1
  • xen-tools >= 4.7.6_02-43.36.1
  • xen-tools-domU >= 4.7.6_02-43.36.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1414
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • xen >= 4.7.6_02-43.36.1
  • xen-doc-html >= 4.7.6_02-43.36.1
  • xen-libs >= 4.7.6_02-43.36.1
  • xen-libs-32bit >= 4.7.6_02-43.36.1
  • xen-tools >= 4.7.6_02-43.36.1
  • xen-tools-domU >= 4.7.6_02-43.36.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1414
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • xen >= 4.9.2_08-3.35.2
  • xen-doc-html >= 4.9.2_08-3.35.2
  • xen-libs >= 4.9.2_08-3.35.2
  • xen-libs-32bit >= 4.9.2_08-3.35.2
  • xen-tools >= 4.9.2_08-3.35.2
  • xen-tools-domU >= 4.9.2_08-3.35.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1388
SUSE Linux Enterprise Software Development Kit 12 SP3
  • xen >= 4.9.2_08-3.35.2
  • xen-devel >= 4.9.2_08-3.35.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1388
SUSE OpenStack Cloud 7
  • xen >= 4.7.6_02-43.36.1
  • xen-doc-html >= 4.7.6_02-43.36.1
  • xen-libs >= 4.7.6_02-43.36.1
  • xen-libs-32bit >= 4.7.6_02-43.36.1
  • xen-tools >= 4.7.6_02-43.36.1
  • xen-tools-domU >= 4.7.6_02-43.36.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1414
openSUSE Leap 15.0
  • xen >= 4.10.1_06-lp150.2.6.1
  • xen-debugsource >= 4.10.1_06-lp150.2.6.1
  • xen-devel >= 4.10.1_06-lp150.2.6.1
  • xen-doc-html >= 4.10.1_06-lp150.2.6.1
  • xen-libs >= 4.10.1_06-lp150.2.6.1
  • xen-libs-32bit >= 4.10.1_06-lp150.2.6.1
  • xen-libs-32bit-debuginfo >= 4.10.1_06-lp150.2.6.1
  • xen-libs-debuginfo >= 4.10.1_06-lp150.2.6.1
  • xen-tools >= 4.10.1_06-lp150.2.6.1
  • xen-tools-debuginfo >= 4.10.1_06-lp150.2.6.1
  • xen-tools-domU >= 4.10.1_06-lp150.2.6.1
  • xen-tools-domU-debuginfo >= 4.10.1_06-lp150.2.6.1
Patchnames:
openSUSE-2018-766
openSUSE Leap 42.3
  • xen >= 4.9.2_08-25.2
  • xen-debugsource >= 4.9.2_08-25.2
  • xen-devel >= 4.9.2_08-25.2
  • xen-doc-html >= 4.9.2_08-25.2
  • xen-libs >= 4.9.2_08-25.2
  • xen-libs-debuginfo >= 4.9.2_08-25.2
  • xen-tools >= 4.9.2_08-25.2
  • xen-tools-debuginfo >= 4.9.2_08-25.2
  • xen-tools-domU >= 4.9.2_08-25.2
  • xen-tools-domU-debuginfo >= 4.9.2_08-25.2
Patchnames:
openSUSE-2018-803


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 xen Released
SUSE Linux Enterprise Desktop 12 SP3 xen Released
SUSE Linux Enterprise Module for Basesystem 15 GA xen Released
SUSE Linux Enterprise Module for Server Applications 15 GA xen Released
SUSE Linux Enterprise SDK 11 SP4 xen Not affected
SUSE Linux Enterprise SDK 12 SP3 xen Released
SUSE Linux Enterprise Server 11 SP4 xen Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS xen Released
SUSE Linux Enterprise Server 12 SP3 xen Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 xen Released