Upstream information

CVE-2018-12434 at MITRE

Description

LibreSSL before 2.6.5 and 2.7.x before 2.7.4 allows a memory-cache side-channel attack on DSA and ECDSA signatures, aka the Return Of the Hidden Number Problem or ROHNP. To discover a key, the attacker needs access to either the local machine or a different virtual machine on the same physical host.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 1.9
Vector AV:L/AC:M/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 1097779 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • libcrypto43 >= 2.8.0-lp150.2.3.1
  • libcrypto43-32bit >= 2.8.0-lp150.2.3.1
  • libcrypto43-32bit-debuginfo >= 2.8.0-lp150.2.3.1
  • libcrypto43-debuginfo >= 2.8.0-lp150.2.3.1
  • libressl >= 2.8.0-lp150.2.3.1
  • libressl-debuginfo >= 2.8.0-lp150.2.3.1
  • libressl-debugsource >= 2.8.0-lp150.2.3.1
  • libressl-devel >= 2.8.0-lp150.2.3.1
  • libressl-devel-32bit >= 2.8.0-lp150.2.3.1
  • libressl-devel-doc >= 2.8.0-lp150.2.3.1
  • libssl45 >= 2.8.0-lp150.2.3.1
  • libssl45-32bit >= 2.8.0-lp150.2.3.1
  • libssl45-32bit-debuginfo >= 2.8.0-lp150.2.3.1
  • libssl45-debuginfo >= 2.8.0-lp150.2.3.1
  • libtls17 >= 2.8.0-lp150.2.3.1
  • libtls17-32bit >= 2.8.0-lp150.2.3.1
  • libtls17-32bit-debuginfo >= 2.8.0-lp150.2.3.1
  • libtls17-debuginfo >= 2.8.0-lp150.2.3.1
Patchnames:
openSUSE-2018-950
openSUSE Leap 42.3
  • libcrypto43 >= 2.8.0-11.1
  • libcrypto43-32bit >= 2.8.0-11.1
  • libcrypto43-debuginfo >= 2.8.0-11.1
  • libcrypto43-debuginfo-32bit >= 2.8.0-11.1
  • libressl >= 2.8.0-11.1
  • libressl-debuginfo >= 2.8.0-11.1
  • libressl-debugsource >= 2.8.0-11.1
  • libressl-devel >= 2.8.0-11.1
  • libressl-devel-32bit >= 2.8.0-11.1
  • libressl-devel-doc >= 2.8.0-11.1
  • libssl45 >= 2.8.0-11.1
  • libssl45-32bit >= 2.8.0-11.1
  • libssl45-debuginfo >= 2.8.0-11.1
  • libssl45-debuginfo-32bit >= 2.8.0-11.1
  • libtls17 >= 2.8.0-11.1
  • libtls17-32bit >= 2.8.0-11.1
  • libtls17-debuginfo >= 2.8.0-11.1
  • libtls17-debuginfo-32bit >= 2.8.0-11.1
Patchnames:
openSUSE-2018-953