Upstream information

CVE-2018-12120 at MITRE

Description

Node.js: All versions prior to Node.js 6.15.0: Debugger port 5858 listens on any interface by default: When the debugger is enabled with `node --debug` or `node debug`, it listens to port 5858 on all interfaces by default. This may allow remote computers to attach to the debug port and evaluate arbitrary JavaScript. The default interface is now localhost. It has always been possible to start the debugger on a specific interface, such as `node --debug=localhost`. The debugger was removed in Node.js 8 and replaced with the inspector, so no versions from 8 and later are vulnerable.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 9.8
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity High Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entry: 1117625 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • nodejs4 >= 4.9.1-15.17.1
  • nodejs6 >= 6.16.0-11.21.1
Patchnames:
SUSE-Storage-4-2019-117
SUSE-Storage-4-2019-395
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs4 >= 4.9.1-15.17.1
  • nodejs4-devel >= 4.9.1-15.17.1
  • nodejs4-docs >= 4.9.1-15.17.1
  • nodejs6 >= 6.16.0-11.21.1
  • nodejs6-devel >= 6.16.0-11.21.1
  • nodejs6-docs >= 6.16.0-11.21.1
  • npm4 >= 4.9.1-15.17.1
  • npm6 >= 6.16.0-11.21.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2019-117
SUSE-SLE-Module-Web-Scripting-12-2019-395
SUSE OpenStack Cloud 7
  • nodejs6 >= 6.16.0-11.21.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-395
SUSE OpenStack Cloud Crowbar 8
  • nodejs6 >= 6.16.0-11.21.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-395
openSUSE Leap 42.3
  • nodejs4 >= 4.9.1-20.1
  • nodejs4-debuginfo >= 4.9.1-20.1
  • nodejs4-debugsource >= 4.9.1-20.1
  • nodejs4-devel >= 4.9.1-20.1
  • nodejs4-docs >= 4.9.1-20.1
  • nodejs6 >= 6.16.0-18.1
  • nodejs6-debuginfo >= 6.16.0-18.1
  • nodejs6-debugsource >= 6.16.0-18.1
  • nodejs6-devel >= 6.16.0-18.1
  • nodejs6-docs >= 6.16.0-18.1
  • npm4 >= 4.9.1-20.1
  • npm6 >= 6.16.0-18.1
Patchnames:
openSUSE-2019-234
openSUSE-2019-88


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs4 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs6 Released
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs8 Not affected
SUSE Openstack Cloud 7 nodejs6 Released
SUSE Openstack Cloud 8 nodejs6 Released
SUSE Storage 4 nodejs4 Released
SUSE Storage 4 nodejs6 Released