Upstream information

CVE-2018-12115 at MITRE

Description

In all versions of Node.js prior to 6.14.4, 8.11.4 and 10.9.0 when used with UCS-2 encoding (recognized by Node.js under the names `'ucs2'`, `'ucs-2'`, `'utf16le'` and `'utf-16le'`), `Buffer#write()` can be abused to write outside of the bounds of a single `Buffer`. Writes that start from the second-to-last position of a buffer cause a miscalculation of the maximum length of the input bytes to be written.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7.8
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1105019 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • nodejs4 >= 4.9.1-15.14.1
  • nodejs6 >= 6.14.4-11.18.1
Patchnames:
SUSE-Storage-4-2018-1854
SUSE-Storage-4-2018-1968
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs4 >= 4.9.1-15.14.1
  • nodejs4-devel >= 4.9.1-15.14.1
  • nodejs4-docs >= 4.9.1-15.14.1
  • nodejs6 >= 6.14.4-11.18.1
  • nodejs6-devel >= 6.14.4-11.18.1
  • nodejs6-docs >= 6.14.4-11.18.1
  • npm4 >= 4.9.1-15.14.1
  • npm6 >= 6.14.4-11.18.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2018-1854
SUSE-SLE-Module-Web-Scripting-12-2018-1968
SUSE Linux Enterprise Module for Web Scripting 15
  • nodejs8 >= 8.11.4-3.8.2
  • nodejs8-devel >= 8.11.4-3.8.2
  • nodejs8-docs >= 8.11.4-3.8.2
  • npm8 >= 8.11.4-3.8.2
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-2018-1971
SUSE OpenStack Cloud 7
  • nodejs6 >= 6.14.4-11.18.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1968
SUSE OpenStack Cloud Crowbar 8
  • nodejs6 >= 6.14.4-11.18.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2018-1968
openSUSE Leap 15.0
  • nodejs8 >= 8.11.4-lp150.2.6.1
  • nodejs8-debuginfo >= 8.11.4-lp150.2.6.1
  • nodejs8-debugsource >= 8.11.4-lp150.2.6.1
  • nodejs8-devel >= 8.11.4-lp150.2.6.1
  • nodejs8-docs >= 8.11.4-lp150.2.6.1
  • npm8 >= 8.11.4-lp150.2.6.1
Patchnames:
openSUSE-2018-1047
openSUSE Leap 42.3
  • nodejs4 >= 4.9.1-17.1
  • nodejs4-debuginfo >= 4.9.1-17.1
  • nodejs4-debugsource >= 4.9.1-17.1
  • nodejs4-devel >= 4.9.1-17.1
  • nodejs4-docs >= 4.9.1-17.1
  • nodejs6 >= 6.14.4-15.1
  • nodejs6-debuginfo >= 6.14.4-15.1
  • nodejs6-debugsource >= 6.14.4-15.1
  • nodejs6-devel >= 6.14.4-15.1
  • nodejs6-docs >= 6.14.4-15.1
  • npm4 >= 4.9.1-17.1
  • npm6 >= 6.14.4-15.1
Patchnames:
openSUSE-2018-1041
openSUSE-2018-991


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs4 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs6 Released
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs8 Released
SUSE Openstack Cloud 7 nodejs6 Released
SUSE Openstack Cloud 8 nodejs6 Released
SUSE Storage 4 nodejs4 Released
SUSE Storage 4 nodejs6 Released