Upstream information

CVE-2018-11712 at MITRE

Description

WebCore/platform/network/soup/SocketStreamHandleImplSoup.cpp in the libsoup network backend of WebKit, as used in WebKitGTK+ versions 2.20.0 and 2.20.1, failed to perform TLS certificate verification for WebSocket connections.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entries: 1096061 [NEW], 1097693 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libjavascriptcoregtk-4_0-18 >= 2.20.3-2.23.8
  • libwebkit2gtk-4_0-37 >= 2.20.3-2.23.8
  • libwebkit2gtk3-lang >= 2.20.3-2.23.8
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.3-2.23.8
  • typelib-1_0-WebKit2-4_0 >= 2.20.3-2.23.8
  • webkit2gtk-4_0-injected-bundles >= 2.20.3-2.23.8
  • webkit2gtk3 >= 2.20.3-2.23.8
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2432
SUSE Linux Enterprise Desktop 12 SP4
  • libjavascriptcoregtk-4_0-18 >= 2.20.3-2.23.8
  • libwebkit2gtk-4_0-37 >= 2.20.3-2.23.8
  • libwebkit2gtk3-lang >= 2.20.3-2.23.8
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.3-2.23.8
  • typelib-1_0-WebKit2-4_0 >= 2.20.3-2.23.8
  • webkit2gtk-4_0-injected-bundles >= 2.20.3-2.23.8
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Server 12 SP3
  • libjavascriptcoregtk-4_0-18 >= 2.20.3-2.23.8
  • libwebkit2gtk-4_0-37 >= 2.20.3-2.23.8
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.3-2.23.8
  • typelib-1_0-WebKit2-4_0 >= 2.20.3-2.23.8
  • webkit2gtk-4_0-injected-bundles >= 2.20.3-2.23.8
  • webkit2gtk3 >= 2.20.3-2.23.8
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2432
SUSE Linux Enterprise Server 12 SP4
  • libjavascriptcoregtk-4_0-18 >= 2.20.3-2.23.8
  • libwebkit2gtk-4_0-37 >= 2.20.3-2.23.8
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.3-2.23.8
  • typelib-1_0-WebKit2-4_0 >= 2.20.3-2.23.8
  • webkit2gtk-4_0-injected-bundles >= 2.20.3-2.23.8
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libjavascriptcoregtk-4_0-18 >= 2.20.3-2.23.8
  • libwebkit2gtk-4_0-37 >= 2.20.3-2.23.8
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.3-2.23.8
  • typelib-1_0-WebKit2-4_0 >= 2.20.3-2.23.8
  • webkit2gtk-4_0-injected-bundles >= 2.20.3-2.23.8
  • webkit2gtk3 >= 2.20.3-2.23.8
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2432
SUSE Linux Enterprise Software Development Kit 12 SP3
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.20.3-2.23.8
  • webkit2gtk3 >= 2.20.3-2.23.8
  • webkit2gtk3-devel >= 2.20.3-2.23.8
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2432
SUSE Linux Enterprise Software Development Kit 12 SP4
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.20.3-2.23.8
  • webkit2gtk3-devel >= 2.20.3-2.23.8
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA typelib-1_0-WebKit2WebExtension-4_0
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libwebkit2gtk3-lang >= 2.20.3-2.23.8
  • webkit2gtk3 >= 2.20.3-2.23.8
Patchnames:
SUSE-SLE-WE-12-SP3-2018-2432
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libwebkit2gtk3-lang >= 2.20.3-2.23.8
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libwebkit2gtk3-lang
openSUSE Leap 42.3
  • libjavascriptcoregtk-4_0-18 >= 2.20.3-11.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.20.3-11.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.20.3-11.1
  • libjavascriptcoregtk-4_0-18-debuginfo-32bit >= 2.20.3-11.1
  • libwebkit2gtk-4_0-37 >= 2.20.3-11.1
  • libwebkit2gtk-4_0-37-32bit >= 2.20.3-11.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.20.3-11.1
  • libwebkit2gtk-4_0-37-debuginfo-32bit >= 2.20.3-11.1
  • libwebkit2gtk3-lang >= 2.20.3-11.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.3-11.1
  • typelib-1_0-WebKit2-4_0 >= 2.20.3-11.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.20.3-11.1
  • webkit-jsc-4 >= 2.20.3-11.1
  • webkit-jsc-4-debuginfo >= 2.20.3-11.1
  • webkit2gtk-4_0-injected-bundles >= 2.20.3-11.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.20.3-11.1
  • webkit2gtk3 >= 2.20.3-11.1
  • webkit2gtk3-debugsource >= 2.20.3-11.1
  • webkit2gtk3-devel >= 2.20.3-11.1
  • webkit2gtk3-plugin-process-gtk2 >= 2.20.3-11.1
  • webkit2gtk3-plugin-process-gtk2-debuginfo >= 2.20.3-11.1
Patchnames:
openSUSE-2018-1288


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 webkit2gtk3 Released
SUSE Linux Enterprise Module for Basesystem 15 GA webkit2gtk3 Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 GA webkit2gtk3 Already fixed
SUSE Linux Enterprise SDK 12 SP3 webkit2gtk3 Released
SUSE Linux Enterprise Server 12 SP2 LTSS webkit2gtk3 Affected
SUSE Linux Enterprise Server 12 SP3 webkit2gtk3 Released
SUSE Linux Enterprise Workstation Extension 12 SP3 webkit2gtk3 Released