Upstream information

CVE-2018-1115 at MITRE

Description

postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile. If the adminpack is added to a database, an attacker able to connect to it could exploit this to force log rotation.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:N/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.1
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1091610 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libecpg6 >= 9.6.9-3.19.1
  • libpq5 >= 9.6.9-3.19.1
  • libpq5-32bit >= 9.6.9-3.19.1
  • postgresql96 >= 9.6.9-3.19.1
  • postgresql96-libs >= 9.6.9-3.19.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1138
SUSE Linux Enterprise Server 12 SP3
  • libecpg6 >= 9.6.9-3.19.1
  • libpq5 >= 9.6.9-3.19.1
  • libpq5-32bit >= 9.6.9-3.19.1
  • postgresql96 >= 9.6.9-3.19.1
  • postgresql96-contrib >= 9.6.9-3.19.1
  • postgresql96-docs >= 9.6.9-3.19.1
  • postgresql96-libs >= 9.6.9-3.19.1
  • postgresql96-server >= 9.6.9-3.19.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1138
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libecpg6 >= 9.6.9-3.19.1
  • libpq5 >= 9.6.9-3.19.1
  • libpq5-32bit >= 9.6.9-3.19.1
  • postgresql96 >= 9.6.9-3.19.1
  • postgresql96-contrib >= 9.6.9-3.19.1
  • postgresql96-docs >= 9.6.9-3.19.1
  • postgresql96-libs >= 9.6.9-3.19.1
  • postgresql96-server >= 9.6.9-3.19.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1138
SUSE Linux Enterprise Software Development Kit 12 SP3
  • postgresql96-devel >= 9.6.9-3.19.1
  • postgresql96-libs >= 9.6.9-3.19.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1138
openSUSE Leap 42.3
  • libecpg6 >= 9.6.9-18.1
  • libecpg6-32bit >= 9.6.9-18.1
  • libecpg6-debuginfo >= 9.6.9-18.1
  • libecpg6-debuginfo-32bit >= 9.6.9-18.1
  • libpq5 >= 9.6.9-18.1
  • libpq5-32bit >= 9.6.9-18.1
  • libpq5-debuginfo >= 9.6.9-18.1
  • libpq5-debuginfo-32bit >= 9.6.9-18.1
  • postgresql95 >= 9.5.13-2.9.1
  • postgresql95-contrib >= 9.5.13-2.9.1
  • postgresql95-contrib-debuginfo >= 9.5.13-2.9.1
  • postgresql95-debuginfo >= 9.5.13-2.9.1
  • postgresql95-debugsource >= 9.5.13-2.9.1
  • postgresql95-devel >= 9.5.13-2.9.1
  • postgresql95-devel-debuginfo >= 9.5.13-2.9.1
  • postgresql95-docs >= 9.5.13-2.9.1
  • postgresql95-libs >= 9.5.13-2.9.1
  • postgresql95-libs-debugsource >= 9.5.13-2.9.1
  • postgresql95-plperl >= 9.5.13-2.9.1
  • postgresql95-plperl-debuginfo >= 9.5.13-2.9.1
  • postgresql95-plpython >= 9.5.13-2.9.1
  • postgresql95-plpython-debuginfo >= 9.5.13-2.9.1
  • postgresql95-pltcl >= 9.5.13-2.9.1
  • postgresql95-pltcl-debuginfo >= 9.5.13-2.9.1
  • postgresql95-server >= 9.5.13-2.9.1
  • postgresql95-server-debuginfo >= 9.5.13-2.9.1
  • postgresql95-test >= 9.5.13-2.9.1
  • postgresql96 >= 9.6.9-18.1
  • postgresql96-contrib >= 9.6.9-18.1
  • postgresql96-contrib-debuginfo >= 9.6.9-18.1
  • postgresql96-debuginfo >= 9.6.9-18.1
  • postgresql96-debugsource >= 9.6.9-18.1
  • postgresql96-devel >= 9.6.9-18.1
  • postgresql96-devel-debuginfo >= 9.6.9-18.1
  • postgresql96-docs >= 9.6.9-18.1
  • postgresql96-libs >= 9.6.9-18.1
  • postgresql96-libs-debugsource >= 9.6.9-18.1
  • postgresql96-plperl >= 9.6.9-18.1
  • postgresql96-plperl-debuginfo >= 9.6.9-18.1
  • postgresql96-plpython >= 9.6.9-18.1
  • postgresql96-plpython-debuginfo >= 9.6.9-18.1
  • postgresql96-pltcl >= 9.6.9-18.1
  • postgresql96-pltcl-debuginfo >= 9.6.9-18.1
  • postgresql96-server >= 9.6.9-18.1
  • postgresql96-server-debuginfo >= 9.6.9-18.1
  • postgresql96-test >= 9.6.9-18.1
Patchnames:
openSUSE-2018-638
openSUSE-2018-696


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 postgresql Unsupported
SUSE Linux Enterprise Desktop 12 SP2 postgresql94 Unsupported
SUSE Linux Enterprise Desktop 12 SP2 postgresql96 Unsupported
SUSE Linux Enterprise Desktop 12 SP3 postgresql96 Released
SUSE Linux Enterprise SDK 12 SP2 postgresql Unsupported
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql91 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP4 postgresql Not affected
SUSE Linux Enterprise Server 11 SP4 postgresql94 Not affected
SUSE Linux Enterprise Server 12 GA LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 12 GA LTSS postgresql96 Affected
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql96 Affected
SUSE Linux Enterprise Server 12 SP2 postgresql94 Unsupported
SUSE Linux Enterprise Server 12 SP2 postgresql96 Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS postgresql96 Affected
SUSE Linux Enterprise Server 12 SP3 postgresql96 Released
SUSE Linux Enterprise Workstation Extension 12 SP2 postgresql Unsupported