Upstream information

CVE-2018-10906 at MITRE

Description

In fuse before versions 2.9.8 and 3.x before 3.2.5, fusermount is vulnerable to a restriction bypass when SELinux is active. This allows non-root users to mount a FUSE file system with the 'allow_other' mount option regardless of whether 'user_allow_other' is set in the fuse configuration. An attacker may use this flaw to mount a FUSE file system, accessible by other users, and trick them into accessing files on that file system, possibly causing Denial of Service or other unspecified effects.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 6.7
Vector AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity High
Privileges Required Low
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1101797 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • fuse >= 2.9.3-6.3.1
  • libfuse2 >= 2.9.3-6.3.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-2299
SUSE CaaS Platform 3.0
  • fuse >= 2.9.3-6.3.1
  • libfuse2 >= 2.9.3-6.3.1
Patchnames:
SUSE-CAASP-3.0-2018-2299
SUSE CaaS Platform ALL
  • fuse >= 2.9.3-6.3.1
  • libfuse2 >= 2.9.3-6.3.1
Patchnames:
SUSE-CAASP-ALL-2018-2299
SUSE Linux Enterprise Desktop 12 SP3
  • fuse >= 2.9.3-6.3.1
  • libfuse2 >= 2.9.3-6.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2299
SUSE Linux Enterprise Module for Basesystem 15
  • fuse >= 2.9.7-3.3.1
  • fuse-devel >= 2.9.7-3.3.1
  • fuse-doc >= 2.9.7-3.3.1
  • libfuse2 >= 2.9.7-3.3.1
  • libulockmgr1 >= 2.9.7-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2340
SUSE Linux Enterprise Server 12 SP3
  • fuse >= 2.9.3-6.3.1
  • libfuse2 >= 2.9.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2299
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • fuse >= 2.9.3-6.3.1
  • libfuse2 >= 2.9.3-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2299
SUSE Linux Enterprise Software Development Kit 12 SP3
  • fuse >= 2.9.3-6.3.1
  • fuse-devel >= 2.9.3-6.3.1
  • fuse-devel-static >= 2.9.3-6.3.1
  • libulockmgr1 >= 2.9.3-6.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2299
openSUSE Leap 15.0
  • fuse >= 2.9.7-lp150.2.3.1
  • fuse-debuginfo >= 2.9.7-lp150.2.3.1
  • fuse-debugsource >= 2.9.7-lp150.2.3.1
  • fuse-devel >= 2.9.7-lp150.2.3.1
  • fuse-devel-static >= 2.9.7-lp150.2.3.1
  • fuse-doc >= 2.9.7-lp150.2.3.1
  • libfuse2 >= 2.9.7-lp150.2.3.1
  • libfuse2-32bit >= 2.9.7-lp150.2.3.1
  • libfuse2-32bit-debuginfo >= 2.9.7-lp150.2.3.1
  • libfuse2-debuginfo >= 2.9.7-lp150.2.3.1
  • libulockmgr1 >= 2.9.7-lp150.2.3.1
  • libulockmgr1-debuginfo >= 2.9.7-lp150.2.3.1
Patchnames:
openSUSE-2018-1228
openSUSE Leap 42.3
  • fuse >= 2.9.3-12.3.2
  • fuse-debuginfo >= 2.9.3-12.3.2
  • fuse-debugsource >= 2.9.3-12.3.2
  • fuse-devel >= 2.9.3-12.3.2
  • fuse-devel-static >= 2.9.3-12.3.2
  • libfuse2 >= 2.9.3-12.3.2
  • libfuse2-32bit >= 2.9.3-12.3.2
  • libfuse2-debuginfo >= 2.9.3-12.3.2
  • libfuse2-debuginfo-32bit >= 2.9.3-12.3.2
  • libulockmgr1 >= 2.9.3-12.3.2
  • libulockmgr1-debuginfo >= 2.9.3-12.3.2
Patchnames:
openSUSE-2018-1225


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 fuse Released
CaaS Platform 2.0 fuse Released
CaaS Platform 3.0 fuse Released
OpenStack Cloud Magnum Orchestration 7.0 fuse Released
SUSE Linux Enterprise Desktop 12 SP3 fuse Released
SUSE Linux Enterprise Module for Basesystem 15 GA fuse Released
SUSE Linux Enterprise SDK 11 SP4 fuse Affected
SUSE Linux Enterprise SDK 12 SP3 fuse Released
SUSE Linux Enterprise Server 11 SP3 LTSS fuse Affected
SUSE Linux Enterprise Server 11 SP4 fuse Affected
SUSE Linux Enterprise Server 12 GA LTSS fuse Affected
SUSE Linux Enterprise Server 12 SP1 LTSS fuse Affected
SUSE Linux Enterprise Server 12 SP2 LTSS fuse Affected
SUSE Linux Enterprise Server 12 SP3 fuse Released