Upstream information

CVE-2018-10873 at MITRE

Description

A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 8.8
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1104448 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libspice-client-glib-2_0-8 >= 0.33-3.6.1
  • libspice-client-glib-helper >= 0.33-3.6.1
  • libspice-client-gtk-3_0-5 >= 0.33-3.6.1
  • libspice-controller0 >= 0.33-3.6.1
  • libspice-server1 >= 0.12.8-6.1
  • spice >= 0.12.8-6.1
  • spice-gtk >= 0.33-3.6.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-3.6.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-3.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1824
SUSE-SLE-DESKTOP-12-SP3-2018-1825
SUSE Linux Enterprise Module for Basesystem 15
  • libspice-client-glib-2_0-8 >= 0.34-3.3.1
  • libspice-client-glib-helper >= 0.34-3.3.1
  • libspice-client-gtk-3_0-5 >= 0.34-3.3.1
  • libspice-controller0 >= 0.34-3.3.1
  • spice-gtk >= 0.34-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1900
SUSE Linux Enterprise Module for Server Applications 15
  • libspice-server-devel >= 0.14.0-4.3.1
  • libspice-server1 >= 0.14.0-4.3.1
  • spice >= 0.14.0-4.3.1
  • spice-gtk >= 0.34-3.3.1
  • spice-gtk-devel >= 0.34-3.3.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.34-3.3.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.34-3.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2018-1800
SUSE-SLE-Module-Server-Applications-15-2018-1900
SUSE Linux Enterprise Server 11 SP4
  • libspice-server1 >= 0.12.4-15.1
  • spice >= 0.12.4-15.1
Patchnames:
slessp4-spice-13762
SUSE Linux Enterprise Server 12 SP3
  • libspice-client-glib-2_0-8 >= 0.33-3.6.1
  • libspice-client-glib-helper >= 0.33-3.6.1
  • libspice-client-gtk-3_0-5 >= 0.33-3.6.1
  • libspice-controller0 >= 0.33-3.6.1
  • libspice-server1 >= 0.12.8-6.1
  • spice >= 0.12.8-6.1
  • spice-gtk >= 0.33-3.6.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-3.6.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1824
SUSE-SLE-SERVER-12-SP3-2018-1825
SUSE Linux Enterprise Server 12-LTSS
  • libspice-client-glib-2_0-8 >= 0.25-5.3.1
  • libspice-client-gtk-2_0-4 >= 0.25-5.3.1
  • libspice-client-gtk-3_0-4 >= 0.25-5.3.1
  • libspice-controller0 >= 0.25-5.3.1
  • libspice-server1 >= 0.12.4-8.18.1
  • spice >= 0.12.4-8.18.1
  • spice-gtk >= 0.25-5.3.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.25-5.3.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.25-5.3.1
Patchnames:
SUSE-SLE-SERVER-12-2018-1816
SUSE-SLE-SERVER-12-2018-1826
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libspice-server1 >= 0.12.4-15.1
  • spice >= 0.12.4-15.1
Patchnames:
slessp4-spice-13762
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libspice-client-glib-2_0-8 >= 0.33-3.6.1
  • libspice-client-glib-helper >= 0.33-3.6.1
  • libspice-client-gtk-3_0-5 >= 0.33-3.6.1
  • libspice-controller0 >= 0.33-3.6.1
  • libspice-server1 >= 0.12.8-6.1
  • spice >= 0.12.8-6.1
  • spice-gtk >= 0.33-3.6.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-3.6.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1824
SUSE-SLE-SERVER-12-SP3-2018-1825
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • libspice-client-glib-2_0-8 >= 0.25-5.3.1
  • libspice-client-gtk-2_0-4 >= 0.25-5.3.1
  • libspice-client-gtk-3_0-4 >= 0.25-5.3.1
  • libspice-controller0 >= 0.25-5.3.1
  • libspice-server1 >= 0.12.4-8.18.1
  • spice >= 0.12.4-8.18.1
  • spice-gtk >= 0.25-5.3.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.25-5.3.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.25-5.3.1
Patchnames:
SUSE-SLE-SERVER-12-2018-1816
SUSE-SLE-SERVER-12-2018-1826
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libspice-server-devel >= 0.12.4-15.1
  • spice >= 0.12.4-15.1
Patchnames:
sdksp4-spice-13762
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libspice-server-devel >= 0.12.8-6.1
  • spice >= 0.12.8-6.1
  • spice-gtk >= 0.33-3.6.1
  • spice-gtk-devel >= 0.33-3.6.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-3.6.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1824
SUSE-SLE-SDK-12-SP3-2018-1825
openSUSE Leap 15.0
  • libspice-client-glib-2_0-8 >= 0.34-lp150.2.3.1
  • libspice-client-glib-2_0-8-debuginfo >= 0.34-lp150.2.3.1
  • libspice-client-glib-helper >= 0.34-lp150.2.3.1
  • libspice-client-glib-helper-debuginfo >= 0.34-lp150.2.3.1
  • libspice-client-gtk-3_0-5 >= 0.34-lp150.2.3.1
  • libspice-client-gtk-3_0-5-debuginfo >= 0.34-lp150.2.3.1
  • libspice-controller0 >= 0.34-lp150.2.3.1
  • libspice-controller0-debuginfo >= 0.34-lp150.2.3.1
  • libspice-server-devel >= 0.14.0-lp150.3.3.1
  • libspice-server1 >= 0.14.0-lp150.3.3.1
  • libspice-server1-debuginfo >= 0.14.0-lp150.3.3.1
  • spice >= 0.14.0-lp150.3.3.1
  • spice-debugsource >= 0.14.0-lp150.3.3.1
  • spice-gtk >= 0.34-lp150.2.3.1
  • spice-gtk-debuginfo >= 0.34-lp150.2.3.1
  • spice-gtk-debugsource >= 0.34-lp150.2.3.1
  • spice-gtk-devel >= 0.34-lp150.2.3.1
  • spice-gtk-lang >= 0.34-lp150.2.3.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.34-lp150.2.3.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.34-lp150.2.3.1
Patchnames:
openSUSE-2018-1015
openSUSE-2018-956
openSUSE Leap 42.3
  • libspice-client-glib-2_0-8 >= 0.33-2.7.1
  • libspice-client-glib-2_0-8-debuginfo >= 0.33-2.7.1
  • libspice-client-glib-helper >= 0.33-2.7.1
  • libspice-client-glib-helper-debuginfo >= 0.33-2.7.1
  • libspice-client-gtk-3_0-5 >= 0.33-2.7.1
  • libspice-client-gtk-3_0-5-debuginfo >= 0.33-2.7.1
  • libspice-controller0 >= 0.33-2.7.1
  • libspice-controller0-debuginfo >= 0.33-2.7.1
  • libspice-server-devel >= 0.12.8-7.1
  • libspice-server1 >= 0.12.8-7.1
  • libspice-server1-debuginfo >= 0.12.8-7.1
  • spice >= 0.12.8-7.1
  • spice-debugsource >= 0.12.8-7.1
  • spice-gtk >= 0.33-2.7.1
  • spice-gtk-debuginfo >= 0.33-2.7.1
  • spice-gtk-debugsource >= 0.33-2.7.1
  • spice-gtk-devel >= 0.33-2.7.1
  • spice-gtk-lang >= 0.33-2.7.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-2.7.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-2.7.1
Patchnames:
openSUSE-2018-957
openSUSE-2018-958


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 spice Released
SUSE Linux Enterprise Desktop 12 SP3 spice-gtk Released
SUSE Linux Enterprise Module for Basesystem 15 GA spice-gtk Released
SUSE Linux Enterprise Module for Server Applications 15 GA spice Released
SUSE Linux Enterprise Module for Server Applications 15 GA spice-gtk Released
SUSE Linux Enterprise SDK 11 SP4 spice Released
SUSE Linux Enterprise SDK 12 SP3 spice Released
SUSE Linux Enterprise SDK 12 SP3 spice-gtk Released
SUSE Linux Enterprise Server 11 SP4 spice Released
SUSE Linux Enterprise Server 12 GA LTSS spice Released
SUSE Linux Enterprise Server 12 GA LTSS spice-gtk Released
SUSE Linux Enterprise Server 12 SP3 spice Released
SUSE Linux Enterprise Server 12 SP3 spice-gtk Released