Upstream information

CVE-2018-10852 at MITRE

Description

The UNIX pipe which sudo uses to contact SSSD and read the available sudo rules from SSSD has too wide permissions, which means that anyone who can send a message using the same raw protocol that sudo and SSSD use can read the sudo rules available for any user. This affects versions of SSSD before 1.16.3.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 3.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entry: 1098377 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • libipa_hbac0 >= 1.13.4-34.23.1
  • libsss_idmap0 >= 1.13.4-34.23.1
  • libsss_sudo >= 1.13.4-34.23.1
  • python-sssd-config >= 1.13.4-34.23.1
  • sssd >= 1.13.4-34.23.1
  • sssd-32bit >= 1.13.4-34.23.1
  • sssd-ad >= 1.13.4-34.23.1
  • sssd-ipa >= 1.13.4-34.23.1
  • sssd-krb5 >= 1.13.4-34.23.1
  • sssd-krb5-common >= 1.13.4-34.23.1
  • sssd-ldap >= 1.13.4-34.23.1
  • sssd-proxy >= 1.13.4-34.23.1
  • sssd-tools >= 1.13.4-34.23.1
Patchnames:
SUSE-Storage-4-2019-81
SUSE Linux Enterprise Desktop 12 SP3
  • libipa_hbac0 >= 1.13.4-34.23.1
  • libsss_idmap0 >= 1.13.4-34.23.1
  • libsss_nss_idmap0 >= 1.13.4-34.23.1
  • libsss_sudo >= 1.13.4-34.23.1
  • python-sssd-config >= 1.13.4-34.23.1
  • sssd >= 1.13.4-34.23.1
  • sssd-32bit >= 1.13.4-34.23.1
  • sssd-ad >= 1.13.4-34.23.1
  • sssd-ipa >= 1.13.4-34.23.1
  • sssd-krb5 >= 1.13.4-34.23.1
  • sssd-krb5-common >= 1.13.4-34.23.1
  • sssd-ldap >= 1.13.4-34.23.1
  • sssd-proxy >= 1.13.4-34.23.1
  • sssd-tools >= 1.13.4-34.23.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-81
SUSE Linux Enterprise Desktop 12 SP4
  • libipa_hbac0 >= 1.16.1-4.3.2
  • libsss_certmap0 >= 1.16.1-4.3.2
  • libsss_idmap0 >= 1.16.1-4.3.2
  • libsss_nss_idmap0 >= 1.16.1-4.3.2
  • libsss_simpleifp0 >= 1.16.1-4.3.2
  • python-sssd-config >= 1.16.1-4.3.2
  • sssd >= 1.16.1-4.3.2
  • sssd-32bit >= 1.16.1-4.3.2
  • sssd-ad >= 1.16.1-4.3.2
  • sssd-ipa >= 1.16.1-4.3.2
  • sssd-krb5 >= 1.16.1-4.3.2
  • sssd-krb5-common >= 1.16.1-4.3.2
  • sssd-ldap >= 1.16.1-4.3.2
  • sssd-proxy >= 1.16.1-4.3.2
  • sssd-tools >= 1.16.1-4.3.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-556
SUSE Linux Enterprise Module for Basesystem 15
  • libipa_hbac-devel >= 1.16.1-3.3.1
  • libipa_hbac0 >= 1.16.1-3.3.1
  • libsss_certmap-devel >= 1.16.1-3.3.1
  • libsss_certmap0 >= 1.16.1-3.3.1
  • libsss_idmap-devel >= 1.16.1-3.3.1
  • libsss_idmap0 >= 1.16.1-3.3.1
  • libsss_nss_idmap-devel >= 1.16.1-3.3.1
  • libsss_nss_idmap0 >= 1.16.1-3.3.1
  • libsss_simpleifp-devel >= 1.16.1-3.3.1
  • libsss_simpleifp0 >= 1.16.1-3.3.1
  • python3-sssd-config >= 1.16.1-3.3.1
  • sssd >= 1.16.1-3.3.1
  • sssd-32bit >= 1.16.1-3.3.1
  • sssd-ad >= 1.16.1-3.3.1
  • sssd-ipa >= 1.16.1-3.3.1
  • sssd-krb5 >= 1.16.1-3.3.1
  • sssd-krb5-common >= 1.16.1-3.3.1
  • sssd-ldap >= 1.16.1-3.3.1
  • sssd-proxy >= 1.16.1-3.3.1
  • sssd-tools >= 1.16.1-3.3.1
  • sssd-wbclient >= 1.16.1-3.3.1
  • sssd-wbclient-devel >= 1.16.1-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1456
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libipa_hbac-devel >= 1.16.1-3.18.1
  • libipa_hbac0 >= 1.16.1-3.18.1
  • libsss_certmap-devel >= 1.16.1-3.18.1
  • libsss_certmap0 >= 1.16.1-3.18.1
  • libsss_idmap-devel >= 1.16.1-3.18.1
  • libsss_idmap0 >= 1.16.1-3.18.1
  • libsss_nss_idmap-devel >= 1.16.1-3.18.1
  • libsss_nss_idmap0 >= 1.16.1-3.18.1
  • libsss_simpleifp-devel >= 1.16.1-3.18.1
  • libsss_simpleifp0 >= 1.16.1-3.18.1
  • python3-sssd-config >= 1.16.1-3.18.1
  • sssd >= 1.16.1-3.18.1
  • sssd-32bit >= 1.16.1-3.18.1
  • sssd-ad >= 1.16.1-3.18.1
  • sssd-dbus >= 1.16.1-3.18.1
  • sssd-ipa >= 1.16.1-3.18.1
  • sssd-krb5 >= 1.16.1-3.18.1
  • sssd-krb5-common >= 1.16.1-3.18.1
  • sssd-ldap >= 1.16.1-3.18.1
  • sssd-proxy >= 1.16.1-3.18.1
  • sssd-tools >= 1.16.1-3.18.1
  • sssd-wbclient >= 1.16.1-3.18.1
  • sssd-wbclient-devel >= 1.16.1-3.18.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libipa_hbac-devel
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libipa_hbac0 >= 1.13.4-34.23.1
  • libsss_idmap0 >= 1.13.4-34.23.1
  • libsss_sudo >= 1.13.4-34.23.1
  • python-sssd-config >= 1.13.4-34.23.1
  • sssd >= 1.13.4-34.23.1
  • sssd-32bit >= 1.13.4-34.23.1
  • sssd-ad >= 1.13.4-34.23.1
  • sssd-ipa >= 1.13.4-34.23.1
  • sssd-krb5 >= 1.13.4-34.23.1
  • sssd-krb5-common >= 1.13.4-34.23.1
  • sssd-ldap >= 1.13.4-34.23.1
  • sssd-proxy >= 1.13.4-34.23.1
  • sssd-tools >= 1.13.4-34.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-81
SUSE Linux Enterprise Server 12 SP3
  • libipa_hbac0 >= 1.13.4-34.23.1
  • libsss_idmap0 >= 1.13.4-34.23.1
  • libsss_nss_idmap0 >= 1.13.4-34.23.1
  • libsss_sudo >= 1.13.4-34.23.1
  • python-sssd-config >= 1.13.4-34.23.1
  • sssd >= 1.13.4-34.23.1
  • sssd-32bit >= 1.13.4-34.23.1
  • sssd-ad >= 1.13.4-34.23.1
  • sssd-ipa >= 1.13.4-34.23.1
  • sssd-krb5 >= 1.13.4-34.23.1
  • sssd-krb5-common >= 1.13.4-34.23.1
  • sssd-ldap >= 1.13.4-34.23.1
  • sssd-proxy >= 1.13.4-34.23.1
  • sssd-tools >= 1.13.4-34.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-81
SUSE Linux Enterprise Server 12 SP4
  • libipa_hbac0 >= 1.16.1-4.3.2
  • libsss_certmap0 >= 1.16.1-4.3.2
  • libsss_idmap0 >= 1.16.1-4.3.2
  • libsss_nss_idmap0 >= 1.16.1-4.3.2
  • libsss_simpleifp0 >= 1.16.1-4.3.2
  • python-sssd-config >= 1.16.1-4.3.2
  • sssd >= 1.16.1-4.3.2
  • sssd-32bit >= 1.16.1-4.3.2
  • sssd-ad >= 1.16.1-4.3.2
  • sssd-ipa >= 1.16.1-4.3.2
  • sssd-krb5 >= 1.16.1-4.3.2
  • sssd-krb5-common >= 1.16.1-4.3.2
  • sssd-ldap >= 1.16.1-4.3.2
  • sssd-proxy >= 1.16.1-4.3.2
  • sssd-tools >= 1.16.1-4.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-556
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libipa_hbac0 >= 1.13.4-34.23.1
  • libsss_idmap0 >= 1.13.4-34.23.1
  • libsss_sudo >= 1.13.4-34.23.1
  • python-sssd-config >= 1.13.4-34.23.1
  • sssd >= 1.13.4-34.23.1
  • sssd-32bit >= 1.13.4-34.23.1
  • sssd-ad >= 1.13.4-34.23.1
  • sssd-ipa >= 1.13.4-34.23.1
  • sssd-krb5 >= 1.13.4-34.23.1
  • sssd-krb5-common >= 1.13.4-34.23.1
  • sssd-ldap >= 1.13.4-34.23.1
  • sssd-proxy >= 1.13.4-34.23.1
  • sssd-tools >= 1.13.4-34.23.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-81
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libipa_hbac0 >= 1.13.4-34.23.1
  • libsss_idmap0 >= 1.13.4-34.23.1
  • libsss_sudo >= 1.13.4-34.23.1
  • python-sssd-config >= 1.13.4-34.23.1
  • sssd >= 1.13.4-34.23.1
  • sssd-32bit >= 1.13.4-34.23.1
  • sssd-ad >= 1.13.4-34.23.1
  • sssd-ipa >= 1.13.4-34.23.1
  • sssd-krb5 >= 1.13.4-34.23.1
  • sssd-krb5-common >= 1.13.4-34.23.1
  • sssd-ldap >= 1.13.4-34.23.1
  • sssd-proxy >= 1.13.4-34.23.1
  • sssd-tools >= 1.13.4-34.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-81
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libipa_hbac0 >= 1.13.4-34.23.1
  • libsss_idmap0 >= 1.13.4-34.23.1
  • libsss_nss_idmap0 >= 1.13.4-34.23.1
  • libsss_sudo >= 1.13.4-34.23.1
  • python-sssd-config >= 1.13.4-34.23.1
  • sssd >= 1.13.4-34.23.1
  • sssd-32bit >= 1.13.4-34.23.1
  • sssd-ad >= 1.13.4-34.23.1
  • sssd-ipa >= 1.13.4-34.23.1
  • sssd-krb5 >= 1.13.4-34.23.1
  • sssd-krb5-common >= 1.13.4-34.23.1
  • sssd-ldap >= 1.13.4-34.23.1
  • sssd-proxy >= 1.13.4-34.23.1
  • sssd-tools >= 1.13.4-34.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-81
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libipa_hbac0 >= 1.16.1-4.3.2
  • libsss_certmap0 >= 1.16.1-4.3.2
  • libsss_idmap0 >= 1.16.1-4.3.2
  • libsss_nss_idmap0 >= 1.16.1-4.3.2
  • libsss_simpleifp0 >= 1.16.1-4.3.2
  • python-sssd-config >= 1.16.1-4.3.2
  • sssd >= 1.16.1-4.3.2
  • sssd-32bit >= 1.16.1-4.3.2
  • sssd-ad >= 1.16.1-4.3.2
  • sssd-ipa >= 1.16.1-4.3.2
  • sssd-krb5 >= 1.16.1-4.3.2
  • sssd-krb5-common >= 1.16.1-4.3.2
  • sssd-ldap >= 1.16.1-4.3.2
  • sssd-proxy >= 1.16.1-4.3.2
  • sssd-tools >= 1.16.1-4.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-556
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libipa_hbac-devel >= 1.13.4-34.23.1
  • libsss_idmap-devel >= 1.13.4-34.23.1
  • libsss_nss_idmap-devel >= 1.13.4-34.23.1
  • sssd >= 1.13.4-34.23.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-81
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libipa_hbac-devel >= 1.16.1-4.3.2
  • libsss_idmap-devel >= 1.16.1-4.3.2
  • libsss_nss_idmap-devel >= 1.16.1-4.3.2
  • sssd >= 1.16.1-4.3.2
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-556
SUSE OpenStack Cloud 7
  • libipa_hbac0 >= 1.13.4-34.23.1
  • libsss_idmap0 >= 1.13.4-34.23.1
  • libsss_sudo >= 1.13.4-34.23.1
  • python-sssd-config >= 1.13.4-34.23.1
  • sssd >= 1.13.4-34.23.1
  • sssd-32bit >= 1.13.4-34.23.1
  • sssd-ad >= 1.13.4-34.23.1
  • sssd-ipa >= 1.13.4-34.23.1
  • sssd-krb5 >= 1.13.4-34.23.1
  • sssd-krb5-common >= 1.13.4-34.23.1
  • sssd-ldap >= 1.13.4-34.23.1
  • sssd-proxy >= 1.13.4-34.23.1
  • sssd-tools >= 1.13.4-34.23.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-81
openSUSE Leap 15.0
  • libipa_hbac-devel >= 1.16.1-lp150.2.3.1
  • libipa_hbac0 >= 1.16.1-lp150.2.3.1
  • libipa_hbac0-debuginfo >= 1.16.1-lp150.2.3.1
  • libnfsidmap-sss >= 1.16.1-lp150.2.3.1
  • libnfsidmap-sss-debuginfo >= 1.16.1-lp150.2.3.1
  • libsss_certmap-devel >= 1.16.1-lp150.2.3.1
  • libsss_certmap0 >= 1.16.1-lp150.2.3.1
  • libsss_certmap0-debuginfo >= 1.16.1-lp150.2.3.1
  • libsss_idmap-devel >= 1.16.1-lp150.2.3.1
  • libsss_idmap0 >= 1.16.1-lp150.2.3.1
  • libsss_idmap0-debuginfo >= 1.16.1-lp150.2.3.1
  • libsss_nss_idmap-devel >= 1.16.1-lp150.2.3.1
  • libsss_nss_idmap0 >= 1.16.1-lp150.2.3.1
  • libsss_nss_idmap0-debuginfo >= 1.16.1-lp150.2.3.1
  • libsss_simpleifp-devel >= 1.16.1-lp150.2.3.1
  • libsss_simpleifp0 >= 1.16.1-lp150.2.3.1
  • libsss_simpleifp0-debuginfo >= 1.16.1-lp150.2.3.1
  • python3-ipa_hbac >= 1.16.1-lp150.2.3.1
  • python3-ipa_hbac-debuginfo >= 1.16.1-lp150.2.3.1
  • python3-sss-murmur >= 1.16.1-lp150.2.3.1
  • python3-sss-murmur-debuginfo >= 1.16.1-lp150.2.3.1
  • python3-sss_nss_idmap >= 1.16.1-lp150.2.3.1
  • python3-sss_nss_idmap-debuginfo >= 1.16.1-lp150.2.3.1
  • python3-sssd-config >= 1.16.1-lp150.2.3.1
  • python3-sssd-config-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd >= 1.16.1-lp150.2.3.1
  • sssd-32bit >= 1.16.1-lp150.2.3.1
  • sssd-32bit-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd-ad >= 1.16.1-lp150.2.3.1
  • sssd-ad-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd-dbus >= 1.16.1-lp150.2.3.1
  • sssd-dbus-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd-debugsource >= 1.16.1-lp150.2.3.1
  • sssd-ipa >= 1.16.1-lp150.2.3.1
  • sssd-ipa-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd-krb5 >= 1.16.1-lp150.2.3.1
  • sssd-krb5-common >= 1.16.1-lp150.2.3.1
  • sssd-krb5-common-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd-krb5-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd-ldap >= 1.16.1-lp150.2.3.1
  • sssd-ldap-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd-proxy >= 1.16.1-lp150.2.3.1
  • sssd-proxy-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd-tools >= 1.16.1-lp150.2.3.1
  • sssd-tools-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd-wbclient >= 1.16.1-lp150.2.3.1
  • sssd-wbclient-debuginfo >= 1.16.1-lp150.2.3.1
  • sssd-wbclient-devel >= 1.16.1-lp150.2.3.1
  • sssd-winbind-idmap >= 1.16.1-lp150.2.3.1
  • sssd-winbind-idmap-debuginfo >= 1.16.1-lp150.2.3.1
Patchnames:
openSUSE-2019-574
openSUSE Leap 42.3
  • libipa_hbac-devel >= 1.13.4-12.1
  • libipa_hbac0 >= 1.13.4-12.1
  • libipa_hbac0-debuginfo >= 1.13.4-12.1
  • libsss_idmap-devel >= 1.13.4-12.1
  • libsss_idmap0 >= 1.13.4-12.1
  • libsss_idmap0-debuginfo >= 1.13.4-12.1
  • libsss_nss_idmap-devel >= 1.13.4-12.1
  • libsss_nss_idmap0 >= 1.13.4-12.1
  • libsss_nss_idmap0-debuginfo >= 1.13.4-12.1
  • libsss_sudo >= 1.13.4-12.1
  • libsss_sudo-debuginfo >= 1.13.4-12.1
  • python-ipa_hbac >= 1.13.4-12.1
  • python-ipa_hbac-debuginfo >= 1.13.4-12.1
  • python-sss_nss_idmap >= 1.13.4-12.1
  • python-sss_nss_idmap-debuginfo >= 1.13.4-12.1
  • python-sssd-config >= 1.13.4-12.1
  • python-sssd-config-debuginfo >= 1.13.4-12.1
  • sssd >= 1.13.4-12.1
  • sssd-32bit >= 1.13.4-12.1
  • sssd-ad >= 1.13.4-12.1
  • sssd-ad-debuginfo >= 1.13.4-12.1
  • sssd-debuginfo >= 1.13.4-12.1
  • sssd-debuginfo-32bit >= 1.13.4-12.1
  • sssd-debugsource >= 1.13.4-12.1
  • sssd-ipa >= 1.13.4-12.1
  • sssd-ipa-debuginfo >= 1.13.4-12.1
  • sssd-krb5 >= 1.13.4-12.1
  • sssd-krb5-common >= 1.13.4-12.1
  • sssd-krb5-common-debuginfo >= 1.13.4-12.1
  • sssd-krb5-debuginfo >= 1.13.4-12.1
  • sssd-ldap >= 1.13.4-12.1
  • sssd-ldap-debuginfo >= 1.13.4-12.1
  • sssd-proxy >= 1.13.4-12.1
  • sssd-proxy-debuginfo >= 1.13.4-12.1
  • sssd-tools >= 1.13.4-12.1
  • sssd-tools-debuginfo >= 1.13.4-12.1
Patchnames:
openSUSE-2019-51


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 sssd Released
SUSE Linux Enterprise Desktop 12 SP4 sssd In progress
SUSE Linux Enterprise High Performance Computing 12 sssd In progress
SUSE Linux Enterprise Module for Basesystem 15 GA sssd Released
SUSE Linux Enterprise SDK 11 SP4 sssd Not affected
SUSE Linux Enterprise SDK 12 SP3 sssd Released
SUSE Linux Enterprise SDK 12 SP4 sssd Released
SUSE Linux Enterprise Server 11 SP3 LTSS sssd Not affected
SUSE Linux Enterprise Server 11 SP4 sssd Not affected
SUSE Linux Enterprise Server 12 GA LTSS sssd Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS sssd Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS sssd Released
SUSE Linux Enterprise Server 12 SP3 sssd Released
SUSE Linux Enterprise Server 12 SP4 sssd In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sssd Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 sssd In progress