Upstream information

CVE-2018-10851 at MITRE

Description

PowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor 3.2 up to 4.1.4 excluding 4.1.5 and 4.0.9, are vulnerable to a memory leak while parsing malformed records that can lead to remote denial of service.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entries: 1114157 [IN_PROGRESS], 1114169 [IN_PROGRESS], 1114170 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 12 SP1
  • pdns >= 4.1.5-14.1
  • pdns-backend-godbc >= 4.1.5-14.1
  • pdns-backend-godbc-debuginfo >= 4.1.5-14.1
  • pdns-backend-ldap >= 4.1.5-14.1
  • pdns-backend-ldap-debuginfo >= 4.1.5-14.1
  • pdns-backend-lua >= 4.1.5-14.1
  • pdns-backend-lua-debuginfo >= 4.1.5-14.1
  • pdns-backend-mydns >= 4.1.5-14.1
  • pdns-backend-mydns-debuginfo >= 4.1.5-14.1
  • pdns-backend-mysql >= 4.1.5-14.1
  • pdns-backend-mysql-debuginfo >= 4.1.5-14.1
  • pdns-backend-postgresql >= 4.1.5-14.1
  • pdns-backend-postgresql-debuginfo >= 4.1.5-14.1
  • pdns-backend-remote >= 4.1.5-14.1
  • pdns-backend-remote-debuginfo >= 4.1.5-14.1
  • pdns-backend-sqlite3 >= 4.1.5-14.1
  • pdns-backend-sqlite3-debuginfo >= 4.1.5-14.1
  • pdns-debuginfo >= 4.1.5-14.1
  • pdns-debugsource >= 4.1.5-14.1
  • pdns-recursor >= 4.1.8-13.1
  • pdns-recursor-debuginfo >= 4.1.8-13.1
  • pdns-recursor-debugsource >= 4.1.8-13.1
Patchnames:
openSUSE-2018-1524
openSUSE-2018-1525
SUSE Package Hub for SUSE Linux Enterprise 15
  • pdns >= 4.1.2-bp150.2.3.1
  • pdns-backend-geoip >= 4.1.2-bp150.2.3.1
  • pdns-backend-godbc >= 4.1.2-bp150.2.3.1
  • pdns-backend-ldap >= 4.1.2-bp150.2.3.1
  • pdns-backend-lua >= 4.1.2-bp150.2.3.1
  • pdns-backend-mydns >= 4.1.2-bp150.2.3.1
  • pdns-backend-mysql >= 4.1.2-bp150.2.3.1
  • pdns-backend-postgresql >= 4.1.2-bp150.2.3.1
  • pdns-backend-remote >= 4.1.2-bp150.2.3.1
  • pdns-backend-sqlite3 >= 4.1.2-bp150.2.3.1
  • pdns-recursor >= 4.1.2-bp150.2.3.1
Patchnames:
openSUSE-2018-1570
openSUSE-2018-1571
openSUSE Leap 15.0
  • pdns >= 4.1.2-lp150.3.6.1
  • pdns-backend-geoip >= 4.1.2-lp150.3.6.1
  • pdns-backend-geoip-debuginfo >= 4.1.2-lp150.3.6.1
  • pdns-backend-godbc >= 4.1.2-lp150.3.6.1
  • pdns-backend-godbc-debuginfo >= 4.1.2-lp150.3.6.1
  • pdns-backend-ldap >= 4.1.2-lp150.3.6.1
  • pdns-backend-ldap-debuginfo >= 4.1.2-lp150.3.6.1
  • pdns-backend-lua >= 4.1.2-lp150.3.6.1
  • pdns-backend-lua-debuginfo >= 4.1.2-lp150.3.6.1
  • pdns-backend-mydns >= 4.1.2-lp150.3.6.1
  • pdns-backend-mydns-debuginfo >= 4.1.2-lp150.3.6.1
  • pdns-backend-mysql >= 4.1.2-lp150.3.6.1
  • pdns-backend-mysql-debuginfo >= 4.1.2-lp150.3.6.1
  • pdns-backend-postgresql >= 4.1.2-lp150.3.6.1
  • pdns-backend-postgresql-debuginfo >= 4.1.2-lp150.3.6.1
  • pdns-backend-remote >= 4.1.2-lp150.3.6.1
  • pdns-backend-remote-debuginfo >= 4.1.2-lp150.3.6.1
  • pdns-backend-sqlite3 >= 4.1.2-lp150.3.6.1
  • pdns-backend-sqlite3-debuginfo >= 4.1.2-lp150.3.6.1
  • pdns-debuginfo >= 4.1.2-lp150.3.6.1
  • pdns-debugsource >= 4.1.2-lp150.3.6.1
  • pdns-recursor >= 4.1.2-lp150.2.3.1
  • pdns-recursor-debuginfo >= 4.1.2-lp150.2.3.1
  • pdns-recursor-debugsource >= 4.1.2-lp150.2.3.1
Patchnames:
openSUSE-2018-1565
openSUSE-2018-1566
openSUSE Leap 42.3
  • pdns >= 4.0.3-15.2
  • pdns-backend-geoip >= 4.0.3-15.2
  • pdns-backend-geoip-debuginfo >= 4.0.3-15.2
  • pdns-backend-godbc >= 4.0.3-15.2
  • pdns-backend-godbc-debuginfo >= 4.0.3-15.2
  • pdns-backend-ldap >= 4.0.3-15.2
  • pdns-backend-ldap-debuginfo >= 4.0.3-15.2
  • pdns-backend-lua >= 4.0.3-15.2
  • pdns-backend-lua-debuginfo >= 4.0.3-15.2
  • pdns-backend-mydns >= 4.0.3-15.2
  • pdns-backend-mydns-debuginfo >= 4.0.3-15.2
  • pdns-backend-mysql >= 4.0.3-15.2
  • pdns-backend-mysql-debuginfo >= 4.0.3-15.2
  • pdns-backend-postgresql >= 4.0.3-15.2
  • pdns-backend-postgresql-debuginfo >= 4.0.3-15.2
  • pdns-backend-remote >= 4.0.3-15.2
  • pdns-backend-remote-debuginfo >= 4.0.3-15.2
  • pdns-backend-sqlite3 >= 4.0.3-15.2
  • pdns-backend-sqlite3-debuginfo >= 4.0.3-15.2
  • pdns-debuginfo >= 4.0.3-15.2
  • pdns-debugsource >= 4.0.3-15.2
  • pdns-recursor >= 4.0.5-9.1
  • pdns-recursor-debuginfo >= 4.0.5-9.1
  • pdns-recursor-debugsource >= 4.0.5-9.1
Patchnames:
openSUSE-2018-1564
openSUSE-2018-1594


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 pdns Affected
SUSE Openstack Cloud 8 pdns Affected