Upstream information

CVE-2018-10844 at MITRE

Description

It was found that the GnuTLS implementation of HMAC-SHA-256 was vulnerable to a Lucky thirteen style attack. Remote attackers could use this flaw to conduct distinguishing attacks and plaintext-recovery attacks via statistical analysis of timing data using crafted packets.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 5.3
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network Adjacent Network
Access Complexity High High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entries: 1105437 [RESOLVED / FIXED], 1105459 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-Storage-4-2018-1977
SUSE Linux Enterprise Desktop 12 SP3
  • gnutls >= 3.3.27-3.3.1
  • libgnutls28 >= 3.3.27-3.3.1
  • libgnutls28-32bit >= 3.3.27-3.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1990
SUSE Linux Enterprise Desktop 12 SP4
  • gnutls >= 3.3.27-3.3.1
  • libgnutls28 >= 3.3.27-3.3.1
  • libgnutls28-32bit >= 3.3.27-3.3.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA gnutls
SUSE Linux Enterprise Module for Basesystem 15
  • gnutls >= 3.6.2-6.3.1
  • libgnutls-devel >= 3.6.2-6.3.1
  • libgnutls30 >= 3.6.2-6.3.1
  • libgnutlsxx-devel >= 3.6.2-6.3.1
  • libgnutlsxx28 >= 3.6.2-6.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2070
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • gnutls >= 3.6.7-6.8.1
  • libgnutls-devel >= 3.6.7-6.8.1
  • libgnutls30 >= 3.6.7-6.8.1
  • libgnutls30-32bit >= 3.6.7-6.8.1
  • libgnutlsxx-devel >= 3.6.7-6.8.1
  • libgnutlsxx28 >= 3.6.7-6.8.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA gnutls
SUSE Linux Enterprise Module for Desktop Applications 15
  • gnutls >= 3.6.2-6.3.1
  • libgnutls30-32bit >= 3.6.2-6.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-2070
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-1977
SUSE Linux Enterprise Server 12 SP1-LTSS
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1977
SUSE Linux Enterprise Server 12 SP2-BCL
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1977
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1977
SUSE Linux Enterprise Server 12 SP2-LTSS
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1977
SUSE Linux Enterprise Server 12 SP3
  • gnutls >= 3.3.27-3.3.1
  • libgnutls-openssl27 >= 3.3.27-3.3.1
  • libgnutls28 >= 3.3.27-3.3.1
  • libgnutls28-32bit >= 3.3.27-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1990
SUSE Linux Enterprise Server 12 SP4
  • gnutls >= 3.3.27-3.3.1
  • libgnutls-openssl27 >= 3.3.27-3.3.1
  • libgnutls28 >= 3.3.27-3.3.1
  • libgnutls28-32bit >= 3.3.27-3.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA gnutls
SUSE Linux Enterprise Server 12-LTSS
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-2018-1977
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-1977
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1977
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-1977
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1977
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1977
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1977
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • gnutls >= 3.3.27-3.3.1
  • libgnutls-openssl27 >= 3.3.27-3.3.1
  • libgnutls28 >= 3.3.27-3.3.1
  • libgnutls28-32bit >= 3.3.27-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1990
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-2018-1977
SUSE Linux Enterprise Software Development Kit 12 SP3
  • gnutls >= 3.3.27-3.3.1
  • libgnutls-devel >= 3.3.27-3.3.1
  • libgnutls-openssl-devel >= 3.3.27-3.3.1
  • libgnutlsxx-devel >= 3.3.27-3.3.1
  • libgnutlsxx28 >= 3.3.27-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1990
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libgnutls-devel >= 3.3.27-3.3.1
  • libgnutls-openssl-devel >= 3.3.27-3.3.1
  • libgnutlsxx-devel >= 3.3.27-3.3.1
  • libgnutlsxx28 >= 3.3.27-3.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libgnutls-devel
SUSE OpenStack Cloud 7
  • gnutls >= 3.2.15-18.6.1
  • libgnutls-openssl27 >= 3.2.15-18.6.1
  • libgnutls28 >= 3.2.15-18.6.1
  • libgnutls28-32bit >= 3.2.15-18.6.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1977
openSUSE Leap 15.0
  • gnutls >= 3.6.2-lp150.6.1
  • gnutls-debuginfo >= 3.6.2-lp150.6.1
  • gnutls-debugsource >= 3.6.2-lp150.6.1
  • gnutls-guile >= 3.6.2-lp150.6.1
  • gnutls-guile-debuginfo >= 3.6.2-lp150.6.1
  • libgnutls-dane-devel >= 3.6.2-lp150.6.1
  • libgnutls-dane0 >= 3.6.2-lp150.6.1
  • libgnutls-dane0-debuginfo >= 3.6.2-lp150.6.1
  • libgnutls-devel >= 3.6.2-lp150.6.1
  • libgnutls-devel-32bit >= 3.6.2-lp150.6.1
  • libgnutls30 >= 3.6.2-lp150.6.1
  • libgnutls30-32bit >= 3.6.2-lp150.6.1
  • libgnutls30-32bit-debuginfo >= 3.6.2-lp150.6.1
  • libgnutls30-debuginfo >= 3.6.2-lp150.6.1
  • libgnutlsxx-devel >= 3.6.2-lp150.6.1
  • libgnutlsxx28 >= 3.6.2-lp150.6.1
  • libgnutlsxx28-debuginfo >= 3.6.2-lp150.6.1
Patchnames:
openSUSE-2019-746
openSUSE Leap 42.3
  • gnutls >= 3.3.27-2.3.1
  • gnutls-debuginfo >= 3.3.27-2.3.1
  • gnutls-debugsource >= 3.3.27-2.3.1
  • libgnutls-devel >= 3.3.27-2.3.1
  • libgnutls-devel-32bit >= 3.3.27-2.3.1
  • libgnutls-openssl-devel >= 3.3.27-2.3.1
  • libgnutls-openssl27 >= 3.3.27-2.3.1
  • libgnutls-openssl27-debuginfo >= 3.3.27-2.3.1
  • libgnutls28 >= 3.3.27-2.3.1
  • libgnutls28-32bit >= 3.3.27-2.3.1
  • libgnutls28-debuginfo >= 3.3.27-2.3.1
  • libgnutls28-debuginfo-32bit >= 3.3.27-2.3.1
  • libgnutlsxx-devel >= 3.3.27-2.3.1
  • libgnutlsxx28 >= 3.3.27-2.3.1
  • libgnutlsxx28-debuginfo >= 3.3.27-2.3.1
Patchnames:
openSUSE-2018-1049


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 gnutls Released
SUSE Linux Enterprise High Availability Extension 11 SP4 gnutls Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA gnutls Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA gnutls Released
SUSE Linux Enterprise SDK 11 SP4 gnutls Not affected
SUSE Linux Enterprise SDK 12 SP3 gnutls Released
SUSE Linux Enterprise Server 11 SP3 LTSS gnutls Not affected
SUSE Linux Enterprise Server 11 SP4 gnutls Not affected
SUSE Linux Enterprise Server 12 GA LTSS gnutls Released
SUSE Linux Enterprise Server 12 SP1 LTSS gnutls Released
SUSE Linux Enterprise Server 12 SP2 LTSS gnutls Released
SUSE Linux Enterprise Server 12 SP3 gnutls Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gnutls Released