Upstream information

CVE-2018-10733 at MITRE

Description

There is a heap-based buffer over-read in the function ft_font_face_hash of gxps-fonts.c in libgxps through 0.3.0. A crafted input will lead to a remote denial of service attack.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.9
Vector AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entry: 1092125 [NEW]

No SUSE Security Announcements cross referenced.

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Desktop 12 SP3
  • libgxps >= 0.2.2-10.3.1
  • libgxps-debugsource >= 0.2.2-10.3.1
  • libgxps2 >= 0.2.2-10.3.1
  • libgxps2-debuginfo >= 0.2.2-10.3.1
SUSE Linux Enterprise Server 12 SP3
  • libgxps >= 0.2.2-10.3.1
  • libgxps-debugsource >= 0.2.2-10.3.1
  • libgxps2 >= 0.2.2-10.3.1
  • libgxps2-debuginfo >= 0.2.2-10.3.1
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libgxps >= 0.2.2-10.3.1
  • libgxps-debugsource >= 0.2.2-10.3.1
  • libgxps2 >= 0.2.2-10.3.1
  • libgxps2-debuginfo >= 0.2.2-10.3.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libgxps >= 0.2.2-10.3.1
  • libgxps-debugsource >= 0.2.2-10.3.1
  • libgxps-devel >= 0.2.2-10.3.1
  • typelib-1_0-GXPS-0_1 >= 0.2.2-10.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 libgxps Affected
SUSE Linux Enterprise Desktop 12 SP3 libgxps In progress
SUSE Linux Enterprise Module for Desktop Applications 15 GA libgxps In progress
SUSE Linux Enterprise SDK 12 SP2 libgxps Affected
SUSE Linux Enterprise SDK 12 SP3 libgxps In progress
SUSE Linux Enterprise Server 12 GA LTSS libgxps Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libgxps Affected
SUSE Linux Enterprise Server 12 SP2 libgxps Affected
SUSE Linux Enterprise Server 12 SP2 LTSS libgxps Affected
SUSE Linux Enterprise Server 12 SP3 libgxps In progress