Upstream information

CVE-2018-1063 at MITRE

Description

Context relabeling of filesystems is vulnerable to symbolic link attack, allowing a local, unprivileged malicious entity to change the SELinux context of an arbitrary file to a context with few restrictions. This only happens when the relabeling process is done, usually when taking SELinux state from disabled to enable (permissive or enforcing). The issue was found in policycoreutils 2.5-11.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.3
Vector AV:L/AC:M/Au:N/C:P/I:P/A:N
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 4.4 5.3
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact None Low
SUSE Bugzilla entry: 1083624 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • policycoreutils >= 2.6-3.12
  • policycoreutils-lang >= 2.6-3.12
  • policycoreutils-newrole >= 2.6-3.12
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA policycoreutils
SUSE Linux Enterprise Server 11 SP4
  • policycoreutils >= 2.0.79-4.9.3.3
Patchnames:
slessp4-policycoreutils-13556
SUSE Linux Enterprise Server 12 SP2
  • policycoreutils >= 2.5-10.3.1
  • policycoreutils-python >= 2.5-10.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-622
SUSE Linux Enterprise Server 12 SP3
  • policycoreutils >= 2.5-10.3.1
  • policycoreutils-python >= 2.5-10.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-622
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • policycoreutils >= 2.5-10.3.1
  • policycoreutils-python >= 2.5-10.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-622
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • policycoreutils >= 2.0.79-4.9.3.3
Patchnames:
slessp4-policycoreutils-13556
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • policycoreutils >= 2.5-10.3.1
  • policycoreutils-python >= 2.5-10.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-622
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • policycoreutils >= 2.5-10.3.1
  • policycoreutils-python >= 2.5-10.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-622
openSUSE Leap 42.3
  • policycoreutils >= 2.5-6.4.1
  • policycoreutils-debuginfo >= 2.5-6.4.1
  • policycoreutils-debugsource >= 2.5-6.4.1
  • policycoreutils-gui >= 2.5-6.4.1
  • policycoreutils-lang >= 2.5-6.4.1
  • policycoreutils-newrole >= 2.5-6.4.1
  • policycoreutils-newrole-debuginfo >= 2.5-6.4.1
  • policycoreutils-python >= 2.5-6.4.1
  • policycoreutils-python-debuginfo >= 2.5-6.4.1
  • policycoreutils-sandbox >= 2.5-6.4.1
  • policycoreutils-sandbox-debuginfo >= 2.5-6.4.1
Patchnames:
openSUSE-2018-362


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Server 11 SP3 LTSS policycoreutils Affected
SUSE Linux Enterprise Server 11 SP4 policycoreutils Released
SUSE Linux Enterprise Server 12 SP2 policycoreutils Released
SUSE Linux Enterprise Server 12 SP3 policycoreutils Released