Upstream information

CVE-2018-1052 at MITRE

Description

Memory disclosure vulnerability in table partitioning was found in postgresql 10.x before 10.2, allowing an authenticated attacker to read arbitrary bytes of server memory via purpose-crafted insert to a partitioned table.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 1077983 [RESOLVED / FIXED], 1080253 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libpq5 >= 10.3-2.8
  • postgresql10 >= 10.3-2.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libpq5
SUSE Linux Enterprise Module for Server Applications 15
  • libecpg6 >= 10.3-2.8
  • postgresql10-contrib >= 10.3-2.8
  • postgresql10-devel >= 10.3-2.8
  • postgresql10-docs >= 10.3-2.8
  • postgresql10-plperl >= 10.3-2.8
  • postgresql10-plpython >= 10.3-2.8
  • postgresql10-pltcl >= 10.3-2.8
  • postgresql10-server >= 10.3-2.8
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA libecpg6
openSUSE Leap 15.0
  • libpq5 >= 10.3-lp150.2.2
  • postgresql10 >= 10.3-lp150.2.1
  • postgresql10-server >= 10.3-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA libpq5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 postgresql Unsupported
SUSE Linux Enterprise Desktop 12 SP2 postgresql94 Unsupported
SUSE Linux Enterprise Module for Basesystem 15 GA postgresql10 Not affected
SUSE Linux Enterprise Module for Server Applications 15 GA postgresql10 Not affected
SUSE Linux Enterprise SDK 12 SP2 postgresql Unsupported
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql91 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP4 postgresql Not affected
SUSE Linux Enterprise Server 11 SP4 postgresql94 Not affected
SUSE Linux Enterprise Server 12 GA LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 12 SP2 postgresql94 Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP2 postgresql Unsupported