Upstream information

CVE-2018-1000622 at MITRE


The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
Base Score 5.3
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entry: 1100691 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Development Tools 15
  • rust >= 1.24.1-3.6.1
  • rust-std >= 1.24.1-3.6.1
openSUSE Leap 15.0
  • rust >= 1.24.1-lp150.2.4.1
  • rust-debuginfo >= 1.24.1-lp150.2.4.1
  • rust-debugsource >= 1.24.1-lp150.2.4.1
  • rust-doc >= 1.24.1-lp150.2.4.1
  • rust-gdb >= 1.24.1-lp150.2.4.1
  • rust-src >= 1.24.1-lp150.2.4.1
  • rust-std >= 1.24.1-lp150.2.4.1
  • rust-std-debuginfo >= 1.24.1-lp150.2.4.1

Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Development Tools 15 GA rust Released