Upstream information

CVE-2018-1000301 at MITRE

Description

curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl = 7.60.0.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1092098 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-939
SUSE CaaS Platform ALL
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
Patchnames:
SUSE-CAASP-ALL-2018-939
SUSE Enterprise Storage 4
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
  • libcurl4-32bit >= 7.37.0-37.23.1
Patchnames:
SUSE-Storage-4-2018-939
SUSE Linux Enterprise Desktop 12 SP3
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
  • libcurl4-32bit >= 7.37.0-37.23.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-939
SUSE Linux Enterprise Module for Basesystem 15
  • curl >= 7.60.0-1.1
  • libcurl-devel >= 7.60.0-1.1
  • libcurl4 >= 7.60.0-1.1
  • libcurl4-32bit >= 7.60.0-1.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA curl
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
  • libcurl4-32bit >= 7.37.0-37.23.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-939
SUSE Linux Enterprise Server 11 SP4
  • curl >= 7.37.0-70.30.1
  • libcurl4 >= 7.37.0-70.30.1
  • libcurl4-32bit >= 7.37.0-70.30.1
  • libcurl4-x86 >= 7.37.0-70.30.1
Patchnames:
slessp4-curl-13633
SUSE Linux Enterprise Server 11-SECURITY
  • curl-openssl1 >= 7.37.0-70.30.1
  • libcurl4-openssl1 >= 7.37.0-70.30.1
  • libcurl4-openssl1-32bit >= 7.37.0-70.30.1
  • libcurl4-openssl1-x86 >= 7.37.0-70.30.1
Patchnames:
secsp3-curl-13633
SUSE Linux Enterprise Server 12 SP1-LTSS
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
  • libcurl4-32bit >= 7.37.0-37.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-939
SUSE Linux Enterprise Server 12 SP2-LTSS
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
  • libcurl4-32bit >= 7.37.0-37.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-939
SUSE Linux Enterprise Server 12 SP3
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
  • libcurl4-32bit >= 7.37.0-37.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-939
SUSE Linux Enterprise Server 12-LTSS
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
  • libcurl4-32bit >= 7.37.0-37.23.1
Patchnames:
SUSE-SLE-SERVER-12-2018-939
SUSE Linux Enterprise Software Development Kit 11 SP4
  • curl >= 7.37.0-70.30.1
  • libcurl-devel >= 7.37.0-70.30.1
Patchnames:
sdksp4-curl-13633
SUSE Linux Enterprise Software Development Kit 12 SP3
  • curl >= 7.37.0-37.23.1
  • libcurl-devel >= 7.37.0-37.23.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-939
SUSE Linux Enterprise for SAP 12 SP1
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
  • libcurl4-32bit >= 7.37.0-37.23.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-939
SUSE Linux Enterprise for SAP 12 SP2
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
  • libcurl4-32bit >= 7.37.0-37.23.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-939
SUSE OpenStack Cloud 6
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
  • libcurl4-32bit >= 7.37.0-37.23.1
Patchnames:
SUSE-OpenStack-Cloud-6-2018-939
SUSE OpenStack Cloud 7
  • curl >= 7.37.0-37.23.1
  • libcurl4 >= 7.37.0-37.23.1
  • libcurl4-32bit >= 7.37.0-37.23.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-939
openSUSE Leap 15.0
  • curl >= 7.60.0-lp150.2.3.1
  • curl-debuginfo >= 7.60.0-lp150.2.3.1
  • curl-debugsource >= 7.60.0-lp150.2.3.1
  • curl-mini >= 7.60.0-lp150.2.3.1
  • curl-mini-debuginfo >= 7.60.0-lp150.2.3.1
  • curl-mini-debugsource >= 7.60.0-lp150.2.3.1
  • libcurl-devel >= 7.60.0-lp150.2.3.1
  • libcurl-devel-32bit >= 7.60.0-lp150.2.3.1
  • libcurl-mini-devel >= 7.60.0-lp150.2.3.1
  • libcurl4 >= 7.60.0-lp150.2.3.1
  • libcurl4-32bit >= 7.60.0-lp150.2.3.1
  • libcurl4-32bit-debuginfo >= 7.60.0-lp150.2.3.1
  • libcurl4-debuginfo >= 7.60.0-lp150.2.3.1
  • libcurl4-mini >= 7.60.0-lp150.2.3.1
  • libcurl4-mini-debuginfo >= 7.60.0-lp150.2.3.1
Patchnames:
openSUSE-2018-589
openSUSE Leap 42.3
  • curl >= 7.37.0-36.1
  • curl-debuginfo >= 7.37.0-36.1
  • curl-debugsource >= 7.37.0-36.1
  • libcurl-devel >= 7.37.0-36.1
  • libcurl-devel-32bit >= 7.37.0-36.1
  • libcurl4 >= 7.37.0-36.1
  • libcurl4-32bit >= 7.37.0-36.1
  • libcurl4-debuginfo >= 7.37.0-36.1
  • libcurl4-debuginfo-32bit >= 7.37.0-36.1
Patchnames:
openSUSE-2018-471


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 curl Released
OpenStack Cloud Magnum Orchestration 7.0 curl Released
SUSE Linux Enterprise Desktop 12 SP2 curl Unsupported
SUSE Linux Enterprise Desktop 12 SP3 curl Released
SUSE Linux Enterprise SDK 11 SP4 curl Released
SUSE Linux Enterprise SDK 12 SP2 curl Unsupported
SUSE Linux Enterprise SDK 12 SP3 curl Released
SUSE Linux Enterprise Server 11 SP3 LTSS curl Not affected
SUSE Linux Enterprise Server 11 SP4 curl Released
SUSE Linux Enterprise Server 12 GA LTSS curl Released
SUSE Linux Enterprise Server 12 SP1 LTSS curl Released
SUSE Linux Enterprise Server 12 SP2 curl Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS curl Released
SUSE Linux Enterprise Server 12 SP3 curl Released
SUSE Studio Onsite 1.3 curl Not affected