Upstream information

CVE-2018-1000076 at MITRE

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.5
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact None
SUSE Bugzilla entry: 1082009 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 ruby2.1 Affected
OpenStack Cloud Magnum Orchestration 7.0 ruby2.1 Affected
SUSE Lifecycle Management Server 1.3 rubygems Affected
SUSE Linux Enterprise Desktop 12 SP2 ruby2.1 Unsupported
SUSE Linux Enterprise Desktop 12 SP3 ruby2.1 Affected
SUSE Linux Enterprise High Availability Extension 11 SP4 rubygems Affected
SUSE Linux Enterprise SDK 11 SP4 rubygems Affected
SUSE Linux Enterprise SDK 12 SP2 ruby2.1 Unsupported
SUSE Linux Enterprise SDK 12 SP3 ruby2.1 Affected
SUSE Linux Enterprise Server 12 GA LTSS ruby2.1 Affected
SUSE Linux Enterprise Server 12 SP1 LTSS ruby2.1 Affected
SUSE Linux Enterprise Server 12 SP2 ruby2.1 Unsupported
SUSE Linux Enterprise Server 12 SP3 ruby2.1 Affected
SUSE Studio Onsite 1.3 ruby19 Ignore
SUSE Studio Onsite 1.3 rubygems Affected