Upstream information

CVE-2018-1000030 at MITRE

Description

Python 2.7.14 is vulnerable to a Heap-Buffer-Overflow as well as a Heap-Use-After-Free. Python versions prior to 2.7.14 may also be vulnerable and it appears that Python 2.7.17 and prior may also be vulnerable however this has not been confirmed. The vulnerability lies when multiply threads are handling large amounts of data. In both cases there is essentially a race condition that occurs. For the Heap-Buffer-Overflow, Thread 2 is creating the size for a buffer, but Thread1 is already writing to the buffer without knowing how much to write. So when a large amount of data is being processed, it is very easy to cause memory corruption using a Heap-Buffer-Overflow. As for the Use-After-Free, Thread3->Malloc->Thread1->Free's->Thread2-Re-uses-Free'd Memory. The PSRT has stated that this is not a security vulnerability due to the fact that the attacker must be able to run code, however in some situations, such as function as a service, this vulnerability can potentially be used by an attacker to violate a trust boundary, as such the DWF feels this issue deserves a CVE.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 7
Vector AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity High
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

Note from the SUSE Security Team

SUSE does not consider this as a security issue. For older python versions the backport to fix this would risk introducing regressions and will not be added.

SUSE Bugzilla entry: 1079300 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libpython2_7-1_0 >= 2.7.13-28.3.2
  • python >= 2.7.13-28.3.2
  • python-base >= 2.7.13-28.3.2
  • python-xml >= 2.7.13-28.3.2
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-964
SUSE CaaS Platform ALL
  • libpython2_7-1_0 >= 2.7.13-28.3.2
  • python >= 2.7.13-28.3.2
  • python-base >= 2.7.13-28.3.2
  • python-xml >= 2.7.13-28.3.2
Patchnames:
SUSE-CAASP-ALL-2018-964
SUSE Enterprise Storage 5
  • python >= 2.7.13-28.3.2
  • python-strict-tls-check >= 2.7.13-28.3.2
Patchnames:
SUSE-Storage-5-2018-964
SUSE Linux Enterprise Desktop 12 SP3
  • libpython2_7-1_0 >= 2.7.13-28.3.2
  • libpython2_7-1_0-32bit >= 2.7.13-28.3.2
  • python >= 2.7.13-28.3.2
  • python-base >= 2.7.13-28.3.2
  • python-curses >= 2.7.13-28.3.2
  • python-devel >= 2.7.13-28.3.2
  • python-tk >= 2.7.13-28.3.2
  • python-xml >= 2.7.13-28.3.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-964
SUSE Linux Enterprise Server 12 SP3
  • libpython2_7-1_0 >= 2.7.13-28.3.2
  • libpython2_7-1_0-32bit >= 2.7.13-28.3.2
  • python >= 2.7.13-28.3.2
  • python-32bit >= 2.7.13-28.3.2
  • python-base >= 2.7.13-28.3.2
  • python-base-32bit >= 2.7.13-28.3.2
  • python-curses >= 2.7.13-28.3.2
  • python-demo >= 2.7.13-28.3.2
  • python-doc >= 2.7.13-28.3.3
  • python-doc-pdf >= 2.7.13-28.3.3
  • python-gdbm >= 2.7.13-28.3.2
  • python-idle >= 2.7.13-28.3.2
  • python-tk >= 2.7.13-28.3.2
  • python-xml >= 2.7.13-28.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-964
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libpython2_7-1_0 >= 2.7.13-28.3.2
  • libpython2_7-1_0-32bit >= 2.7.13-28.3.2
  • python >= 2.7.13-28.3.2
  • python-32bit >= 2.7.13-28.3.2
  • python-base >= 2.7.13-28.3.2
  • python-base-32bit >= 2.7.13-28.3.2
  • python-curses >= 2.7.13-28.3.2
  • python-demo >= 2.7.13-28.3.2
  • python-doc >= 2.7.13-28.3.3
  • python-doc-pdf >= 2.7.13-28.3.3
  • python-gdbm >= 2.7.13-28.3.2
  • python-idle >= 2.7.13-28.3.2
  • python-tk >= 2.7.13-28.3.2
  • python-xml >= 2.7.13-28.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-964
SUSE Linux Enterprise Software Development Kit 12 SP3
  • python-base >= 2.7.13-28.3.2
  • python-devel >= 2.7.13-28.3.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-964
SUSE Linux Enterprise Workstation Extension 12 SP3
  • python-base >= 2.7.13-28.3.2
  • python-devel >= 2.7.13-28.3.2
Patchnames:
SUSE-SLE-WE-12-SP3-2018-964
openSUSE Leap 42.3
  • libpython2_7-1_0 >= 2.7.13-27.3.1
  • libpython2_7-1_0-32bit >= 2.7.13-27.3.1
  • libpython2_7-1_0-debuginfo >= 2.7.13-27.3.1
  • libpython2_7-1_0-debuginfo-32bit >= 2.7.13-27.3.1
  • python >= 2.7.13-27.3.1
  • python-32bit >= 2.7.13-27.3.1
  • python-base >= 2.7.13-27.3.1
  • python-base-32bit >= 2.7.13-27.3.1
  • python-base-debuginfo >= 2.7.13-27.3.1
  • python-base-debuginfo-32bit >= 2.7.13-27.3.1
  • python-base-debugsource >= 2.7.13-27.3.1
  • python-curses >= 2.7.13-27.3.1
  • python-curses-debuginfo >= 2.7.13-27.3.1
  • python-debuginfo >= 2.7.13-27.3.1
  • python-debuginfo-32bit >= 2.7.13-27.3.1
  • python-debugsource >= 2.7.13-27.3.1
  • python-demo >= 2.7.13-27.3.1
  • python-devel >= 2.7.13-27.3.1
  • python-doc >= 2.7.13-27.3.1
  • python-doc-pdf >= 2.7.13-27.3.1
  • python-gdbm >= 2.7.13-27.3.1
  • python-gdbm-debuginfo >= 2.7.13-27.3.1
  • python-idle >= 2.7.13-27.3.1
  • python-tk >= 2.7.13-27.3.1
  • python-tk-debuginfo >= 2.7.13-27.3.1
  • python-xml >= 2.7.13-27.3.1
  • python-xml-debuginfo >= 2.7.13-27.3.1
Patchnames:
openSUSE-2018-511


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 python Released
OpenStack Cloud Magnum Orchestration 7.0 python Released
SUSE Linux Enterprise Desktop 12 SP2 python In progress
SUSE Linux Enterprise Desktop 12 SP3 python Released
SUSE Linux Enterprise SDK 11 SP4 python Ignore
SUSE Linux Enterprise Server 11 SP3 LTSS python Ignore
SUSE Linux Enterprise Server 11 SP4 python Ignore
SUSE Linux Enterprise Server 12 SP1 LTSS python Affected
SUSE Linux Enterprise Server 12 SP2 python In progress
SUSE Linux Enterprise Server 12 SP3 python Released
SUSE Storage 5 python Released