Upstream information

CVE-2018-1000028 at MITRE

Description

Linux kernel version after commit bdcf0a423ea1 - 4.15-rc4+, 4.14.8+, 4.9.76+, 4.4.111+ contains a Incorrect Access Control vulnerability in NFS server (nfsd) that can result in remote users reading or writing files they should not be able to via NFS. This attack appear to be exploitable via NFS server must export a filesystem with the "rootsquash" options enabled. This vulnerability appears to have been fixed in after commit 1995266727fa.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  SUSE
Base Score 5.4
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
SUSE Bugzilla entry: 1078287 [IN_PROGRESS]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 15
  • cluster-md-kmp-default >= 4.12.14-23.1
  • dlm-kmp-default >= 4.12.14-23.1
  • gfs2-kmp-default >= 4.12.14-23.1
  • ocfs2-kmp-default >= 4.12.14-23.1
Patchnames:
SUSE Linux Enterprise High Availability 15 GA cluster-md-kmp-default
SUSE Linux Enterprise Module for Basesystem 15
  • kernel-default >= 4.12.14-23.1
  • kernel-default-devel >= 4.12.14-23.1
  • kernel-devel >= 4.12.14-23.1
  • kernel-macros >= 4.12.14-23.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA kernel-default
SUSE Linux Enterprise Module for Development Tools 15
  • kernel-docs >= 4.12.14-23.1
  • kernel-obs-build >= 4.12.14-23.1
  • kernel-source >= 4.12.14-23.1
  • kernel-syms >= 4.12.14-23.1
  • kernel-vanilla-base >= 4.12.14-23.1
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA kernel-docs
SUSE Linux Enterprise Module for Legacy Software 15
  • reiserfs-kmp-default >= 4.12.14-23.1
Patchnames:
SUSE Linux Enterprise Module for Legacy Software 15 GA reiserfs-kmp-default
SUSE Linux Enterprise Module for Live Patching 15
  • kernel-default-livepatch >= 4.12.14-23.1
Patchnames:
SUSE Linux Enterprise Module for Live Patching 15 GA kernel-default-livepatch
SUSE Linux Enterprise Workstation Extension 15
  • kernel-default-extra >= 4.12.14-23.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 GA kernel-default-extra
openSUSE Leap 15.0
  • kernel-default >= 4.12.14-lp150.11.4
  • kernel-vanilla-base >= 4.12.14-lp150.11.4
Patchnames:
openSUSE Leap 15.0 GA kernel-default


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 kernel-source Already fixed
SUSE Linux Enterprise Desktop 12 SP3 kernel-source Already fixed
SUSE Linux Enterprise Server 11 SP4 kernel-source Not affected
SUSE Linux Enterprise Server 12 SP2 kernel-source Already fixed
SUSE Linux Enterprise Server 12 SP3 kernel-source Already fixed