Upstream information

CVE-2018-0737 at MITRE

Description

The OpenSSL RSA Key generation algorithm has been shown to be vulnerable to a cache timing side channel attack. An attacker with sufficient access to mount cache timing attacks during the RSA key generation process could recover the private key. Fixed in OpenSSL 1.1.0i-dev (Affected 1.1.0-1.1.0h). Fixed in OpenSSL 1.0.2p-dev (Affected 1.0.2b-1.0.2o).

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 4.7
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
Access Vector Network Local
Access Complexity High High
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entries: 1089039 [CONFIRMED], 1089041 [RESOLVED / DUPLICATE], 1089044 [RESOLVED / DUPLICATE], 1089045 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libopenssl-1_1-devel >= 1.1.0h-2.3
  • libopenssl1_1 >= 1.1.0h-2.3
  • libopenssl1_1-32bit >= 1.1.0h-2.3
  • libopenssl1_1-hmac >= 1.1.0h-2.3
  • libopenssl1_1-hmac-32bit >= 1.1.0h-2.3
  • openssl-1_1 >= 1.1.0h-2.3
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libopenssl-1_1-devel
openSUSE Leap 15.0
  • libopenssl1_1 >= 1.1.0h-lp150.2.1
  • libopenssl1_1-32bit >= 1.1.0h-lp150.2.1
  • openssl-1_1 >= 1.1.0h-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA libopenssl1_1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 openssl Affected
OpenStack Cloud Magnum Orchestration 7.0 openssl Affected
SUSE Linux Enterprise Desktop 12 SP2 compat-openssl098 Unsupported
SUSE Linux Enterprise Desktop 12 SP2 openssl Unsupported
SUSE Linux Enterprise Desktop 12 SP3 compat-openssl098 Affected
SUSE Linux Enterprise Desktop 12 SP3 openssl Affected
SUSE Linux Enterprise Module for Legacy Software 12 compat-openssl098 Affected
SUSE Linux Enterprise SDK 11 SP4 openssl Affected
SUSE Linux Enterprise SDK 12 SP2 openssl Unsupported
SUSE Linux Enterprise SDK 12 SP3 openssl Affected
SUSE Linux Enterprise Security Module 11.3 GA openssl1 Affected
SUSE Linux Enterprise Server 11 SP3 LTSS openssl Affected
SUSE Linux Enterprise Server 11 SP4 openssl Affected
SUSE Linux Enterprise Server 12 SP2 openssl Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS openssl Affected
SUSE Linux Enterprise Server 12 SP3 openssl Affected
SUSE Linux Enterprise Server for SAP 12 SP1 compat-openssl098 Affected
SUSE Linux Enterprise Server for SAP 12 SP2 compat-openssl098 Affected
SUSE Linux Enterprise Server for SAP 12 SP3 compat-openssl098 Affected
SUSE Studio Onsite 1.3 openssl Affected