Upstream information

CVE-2018-0734 at MITRE

Description

The OpenSSL DSA signature algorithm has been shown to be vulnerable to a timing side channel attack. An attacker could use variations in the signing algorithm to recover the private key. Fixed in OpenSSL 1.1.1a-dev (Affected 1.1.1). Fixed in OpenSSL 1.1.0j-dev (Affected 1.1.0-1.1.0i). Fixed in OpenSSL 1.0.2q-dev (Affected 1.0.2-1.0.2p).

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 5.9
Vector AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
Access Vector Local
Access Complexity High
Privileges Required None
User Interaction None
Scope Changed
Confidentiality Impact High
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 1113534 [IN_PROGRESS], 1113652 [CONFIRMED], 1113742 [NEW]

No SUSE Security Announcements cross referenced.

List of packages in QA

Product(s) Package(s)
Openstack Cloud Magnum Orchestration 7
  • libopenssl1_0_0 >= 1.0.2j-60.44.1
  • libopenssl1_0_0-debuginfo >= 1.0.2j-60.44.1
  • openssl >= 1.0.2j-60.44.1
  • openssl-debuginfo >= 1.0.2j-60.44.1
  • openssl-debugsource >= 1.0.2j-60.44.1
SUSE CaaS Platform 3.0
  • libopenssl1_0_0 >= 1.0.2j-60.44.1
  • libopenssl1_0_0-debuginfo >= 1.0.2j-60.44.1
  • openssl >= 1.0.2j-60.44.1
  • openssl-debuginfo >= 1.0.2j-60.44.1
  • openssl-debugsource >= 1.0.2j-60.44.1
SUSE CaaS Platform ALL
  • libopenssl1_0_0 >= 1.0.2j-60.44.1
  • libopenssl1_0_0-debuginfo >= 1.0.2j-60.44.1
  • openssl >= 1.0.2j-60.44.1
  • openssl-debuginfo >= 1.0.2j-60.44.1
  • openssl-debugsource >= 1.0.2j-60.44.1
SUSE Linux Enterprise Desktop 12 SP3
  • libopenssl-devel >= 1.0.2j-60.44.1
  • libopenssl1_0_0 >= 1.0.2j-60.44.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.44.1
  • libopenssl1_0_0-debuginfo >= 1.0.2j-60.44.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.2j-60.44.1
  • openssl >= 1.0.2j-60.44.1
  • openssl-debuginfo >= 1.0.2j-60.44.1
  • openssl-debugsource >= 1.0.2j-60.44.1
SUSE Linux Enterprise Module for Basesystem 15
  • libopenssl-1_1-devel >= 1.1.0i-4.15.1
  • libopenssl1_1 >= 1.1.0i-4.15.1
  • libopenssl1_1-32bit >= 1.1.0i-4.15.1
  • libopenssl1_1-32bit-debuginfo >= 1.1.0i-4.15.1
  • libopenssl1_1-debuginfo >= 1.1.0i-4.15.1
  • libopenssl1_1-hmac >= 1.1.0i-4.15.1
  • libopenssl1_1-hmac-32bit >= 1.1.0i-4.15.1
  • openssl-1_1 >= 1.1.0i-4.15.1
  • openssl-1_1-debuginfo >= 1.1.0i-4.15.1
  • openssl-1_1-debugsource >= 1.1.0i-4.15.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • openssl-1_1 >= 1.1.0i-4.15.1
  • openssl-1_1-doc >= 1.1.0i-4.15.1
SUSE Linux Enterprise Server 12 SP3
  • libopenssl-devel >= 1.0.2j-60.44.1
  • libopenssl1_0_0 >= 1.0.2j-60.44.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.44.1
  • libopenssl1_0_0-debuginfo >= 1.0.2j-60.44.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.2j-60.44.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.44.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.44.1
  • openssl >= 1.0.2j-60.44.1
  • openssl-debuginfo >= 1.0.2j-60.44.1
  • openssl-debugsource >= 1.0.2j-60.44.1
  • openssl-doc >= 1.0.2j-60.44.1
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libopenssl-devel >= 1.0.2j-60.44.1
  • libopenssl1_0_0 >= 1.0.2j-60.44.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.44.1
  • libopenssl1_0_0-debuginfo >= 1.0.2j-60.44.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.2j-60.44.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.44.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.44.1
  • openssl >= 1.0.2j-60.44.1
  • openssl-debuginfo >= 1.0.2j-60.44.1
  • openssl-debugsource >= 1.0.2j-60.44.1
  • openssl-doc >= 1.0.2j-60.44.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libopenssl-devel >= 1.0.2j-60.44.1
  • openssl >= 1.0.2j-60.44.1
  • openssl-debuginfo >= 1.0.2j-60.44.1
  • openssl-debugsource >= 1.0.2j-60.44.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 openssl In progress
CaaS Platform 2.0 openssl In progress
CaaS Platform 3.0 openssl In progress
OpenStack Cloud Magnum Orchestration 7.0 openssl In progress
SUSE Linux Enterprise Desktop 12 SP3 compat-openssl098 Affected
SUSE Linux Enterprise Desktop 12 SP3 openssl In progress
SUSE Linux Enterprise Module for Basesystem 15 GA openssl Ignore
SUSE Linux Enterprise Module for Basesystem 15 GA openssl-1_1 In progress
SUSE Linux Enterprise Module for Legacy Software 12 compat-openssl098 Affected
SUSE Linux Enterprise Module for Legacy Software 15 openssl-1_0_0 Affected
SUSE Linux Enterprise SDK 11 SP4 openssl Affected
SUSE Linux Enterprise SDK 12 SP3 openssl In progress
SUSE Linux Enterprise Security Module 11.3 GA openssl1 Affected
SUSE Linux Enterprise Server 11 SP3 LTSS openssl Affected
SUSE Linux Enterprise Server 11 SP4 openssl Affected
SUSE Linux Enterprise Server 12 GA LTSS openssl Affected
SUSE Linux Enterprise Server 12 SP2 LTSS openssl Affected
SUSE Linux Enterprise Server 12 SP3 openssl In progress
SUSE Linux Enterprise Server for SAP Applications 11 SP3 openssl Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA openssl Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 compat-openssl098 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 compat-openssl098 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openssl Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 compat-openssl098 Affected
SUSE Studio Onsite 1.3 openssl Affected