Upstream information

CVE-2018-0495 at MITRE

Description

Libgcrypt before 1.7.10 and 1.8.x before 1.8.3 allows a memory-cache side-channel attack on ECDSA signatures that can be mitigated through the use of blinding during the signing process in the _gcry_ecc_ecdsa_sign function in cipher/ecc-ecdsa.c, aka the Return Of the Hidden Number Problem or ROHNP. To discover an ECDSA key, the attacker needs access to either the local machine or a different virtual machine on the same physical host.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 1.9
Vector AV:L/AC:M/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 4.7 5.1
Vector AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Local Local
Access Complexity High High
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entry: 1097410 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libgcrypt >= 1.6.1-16.55.1
  • libgcrypt20 >= 1.6.1-16.55.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-1413
SUSE CaaS Platform 3.0
  • libgcrypt >= 1.6.1-16.61.1
  • libgcrypt20 >= 1.6.1-16.61.1
Patchnames:
SUSE-CAASP-3.0-2018-1697
SUSE CaaS Platform ALL
  • libgcrypt >= 1.6.1-16.55.1
  • libgcrypt20 >= 1.6.1-16.55.1
Patchnames:
SUSE-CAASP-ALL-2018-1413
SUSE Linux Enterprise Desktop 12 SP3
  • libgcrypt >= 1.6.1-16.55.1
  • libgcrypt20 >= 1.6.1-16.55.1
  • libgcrypt20-32bit >= 1.6.1-16.55.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1413
SUSE Linux Enterprise Module for Basesystem 15
  • libgcrypt >= 1.8.2-6.3.1
  • libgcrypt-devel >= 1.8.2-6.3.1
  • libgcrypt20 >= 1.8.2-6.3.1
  • libgcrypt20-32bit >= 1.8.2-6.3.1
  • libgcrypt20-hmac >= 1.8.2-6.3.1
  • libgcrypt20-hmac-32bit >= 1.8.2-6.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1347
SUSE Linux Enterprise Server 12 SP3
  • libgcrypt >= 1.6.1-16.55.1
  • libgcrypt20 >= 1.6.1-16.55.1
  • libgcrypt20-32bit >= 1.6.1-16.55.1
  • libgcrypt20-hmac >= 1.6.1-16.55.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.55.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1413
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libgcrypt >= 1.6.1-16.55.1
  • libgcrypt20 >= 1.6.1-16.55.1
  • libgcrypt20-32bit >= 1.6.1-16.55.1
  • libgcrypt20-hmac >= 1.6.1-16.55.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.55.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1413
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libgcrypt >= 1.6.1-16.55.1
  • libgcrypt-devel >= 1.6.1-16.55.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1413
openSUSE Leap 15.0
  • libgcrypt >= 1.8.2-lp150.5.3.1
  • libgcrypt-cavs >= 1.8.2-lp150.5.3.1
  • libgcrypt-cavs-debuginfo >= 1.8.2-lp150.5.3.1
  • libgcrypt-debugsource >= 1.8.2-lp150.5.3.1
  • libgcrypt-devel >= 1.8.2-lp150.5.3.1
  • libgcrypt-devel-32bit >= 1.8.2-lp150.5.3.1
  • libgcrypt-devel-32bit-debuginfo >= 1.8.2-lp150.5.3.1
  • libgcrypt-devel-debuginfo >= 1.8.2-lp150.5.3.1
  • libgcrypt20 >= 1.8.2-lp150.5.3.1
  • libgcrypt20-32bit >= 1.8.2-lp150.5.3.1
  • libgcrypt20-32bit-debuginfo >= 1.8.2-lp150.5.3.1
  • libgcrypt20-debuginfo >= 1.8.2-lp150.5.3.1
  • libgcrypt20-hmac >= 1.8.2-lp150.5.3.1
  • libgcrypt20-hmac-32bit >= 1.8.2-lp150.5.3.1
Patchnames:
openSUSE-2018-769
openSUSE Leap 42.3
  • libgcrypt >= 1.6.1-45.1
  • libgcrypt-cavs >= 1.6.1-45.1
  • libgcrypt-cavs-debuginfo >= 1.6.1-45.1
  • libgcrypt-debugsource >= 1.6.1-45.1
  • libgcrypt-devel >= 1.6.1-45.1
  • libgcrypt-devel-32bit >= 1.6.1-45.1
  • libgcrypt-devel-debuginfo >= 1.6.1-45.1
  • libgcrypt-devel-debuginfo-32bit >= 1.6.1-45.1
  • libgcrypt20 >= 1.6.1-45.1
  • libgcrypt20-32bit >= 1.6.1-45.1
  • libgcrypt20-debuginfo >= 1.6.1-45.1
  • libgcrypt20-debuginfo-32bit >= 1.6.1-45.1
  • libgcrypt20-hmac >= 1.6.1-45.1
  • libgcrypt20-hmac-32bit >= 1.6.1-45.1
Patchnames:
openSUSE-2018-795


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 libgcrypt Released
CaaS Platform 2.0 libgcrypt Released
OpenStack Cloud Magnum Orchestration 7.0 libgcrypt Released
SUSE Linux Enterprise Desktop 11 GA libgcrypt Ignore
SUSE Linux Enterprise Desktop 11 SP1 libgcrypt Ignore
SUSE Linux Enterprise Desktop 11 SP2 libgcrypt Ignore
SUSE Linux Enterprise Desktop 11 SP3 libgcrypt Ignore
SUSE Linux Enterprise Desktop 11 SP4 libgcrypt Ignore
SUSE Linux Enterprise Desktop 12 SP1 libgcrypt Affected
SUSE Linux Enterprise Desktop 12 SP2 libgcrypt Affected
SUSE Linux Enterprise Desktop 12 SP3 libgcrypt Released
SUSE Linux Enterprise Module for Basesystem 15 GA libgcrypt Released
SUSE Linux Enterprise SDK 11 SP4 libgcrypt Ignore
SUSE Linux Enterprise SDK 12 SP3 libgcrypt Released
SUSE Linux Enterprise Server 11 SP3 LTSS libgcrypt Ignore
SUSE Linux Enterprise Server 11 SP4 libgcrypt Ignore
SUSE Linux Enterprise Server 12 GA LTSS libgcrypt Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libgcrypt Affected
SUSE Linux Enterprise Server 12 SP2 LTSS libgcrypt Affected
SUSE Linux Enterprise Server 12 SP3 libgcrypt Released