Upstream information

CVE-2017-9788 at MITRE

Description

In Apache httpd before 2.2.34 and 2.4.x before 2.4.27, the value placeholder in [Proxy-]Authorization headers of type 'Digest' was not initialized or reset before or between successive key=value assignments by mod_auth_digest. Providing an initial key with no '=' assignment could reflect the stale value of uninitialized pool memory used by the prior request, leading to leakage of potentially confidential information, and a segfault in other cases resulting in denial of service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.4 4
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P AV:N/AC:H/Au:N/C:P/I:N/A:P
Access Vector Network Network
Access Complexity Low High
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.1 4.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1048576 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • apache2 >= 2.4.23-29.43.1
  • apache2-doc >= 2.4.23-29.43.1
  • apache2-example-pages >= 2.4.23-29.43.1
  • apache2-prefork >= 2.4.23-29.43.1
  • apache2-utils >= 2.4.23-29.43.1
  • apache2-worker >= 2.4.23-29.43.1
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • apache2 >= 2.2.34-70.5.1
  • apache2-doc >= 2.2.34-70.5.1
  • apache2-example-pages >= 2.2.34-70.5.1
  • apache2-prefork >= 2.2.34-70.5.1
  • apache2-utils >= 2.2.34-70.5.1
  • apache2-worker >= 2.2.34-70.5.1
Patchnames:
slessp4-apache2-13223
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • apache2 >= 2.4.16-20.10.1
  • apache2-doc >= 2.4.16-20.10.1
  • apache2-example-pages >= 2.4.16-20.10.1
  • apache2-prefork >= 2.4.16-20.10.1
  • apache2-utils >= 2.4.16-20.10.1
  • apache2-worker >= 2.4.16-20.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1510
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • apache2 >= 2.4.23-29.3.2
  • apache2-doc >= 2.4.23-29.3.2
  • apache2-example-pages >= 2.4.23-29.3.2
  • apache2-prefork >= 2.4.23-29.3.2
  • apache2-utils >= 2.4.23-29.3.2
  • apache2-worker >= 2.4.23-29.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1220
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • apache2 >= 2.4.23-29.3.2
  • apache2-doc >= 2.4.23-29.3.2
  • apache2-example-pages >= 2.4.23-29.3.2
  • apache2-prefork >= 2.4.23-29.3.2
  • apache2-utils >= 2.4.23-29.3.2
  • apache2-worker >= 2.4.23-29.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1220
SUSE Linux Enterprise Server 12 SP4
  • apache2 >= 2.4.23-29.24.1
  • apache2-doc >= 2.4.23-29.24.1
  • apache2-example-pages >= 2.4.23-29.24.1
  • apache2-prefork >= 2.4.23-29.24.1
  • apache2-utils >= 2.4.23-29.24.1
  • apache2-worker >= 2.4.23-29.24.1
SUSE Linux Enterprise Server 12-LTSS
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • apache2 >= 2.4.10-14.28.1
  • apache2-doc >= 2.4.10-14.28.1
  • apache2-example-pages >= 2.4.10-14.28.1
  • apache2-prefork >= 2.4.10-14.28.1
  • apache2-utils >= 2.4.10-14.28.1
  • apache2-worker >= 2.4.10-14.28.1
Patchnames:
SUSE-SLE-SERVER-12-2017-1709
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • apache2 >= 2.4.23-29.3.2
  • apache2-doc >= 2.4.23-29.3.2
  • apache2-example-pages >= 2.4.23-29.3.2
  • apache2-prefork >= 2.4.23-29.3.2
  • apache2-utils >= 2.4.23-29.3.2
  • apache2-worker >= 2.4.23-29.3.2
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1220
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • apache2 >= 2.4.16-20.10.1
  • apache2-doc >= 2.4.16-20.10.1
  • apache2-example-pages >= 2.4.16-20.10.1
  • apache2-prefork >= 2.4.16-20.10.1
  • apache2-utils >= 2.4.16-20.10.1
  • apache2-worker >= 2.4.16-20.10.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-1510
SUSE Linux Enterprise Software Development Kit 11 SP4
  • apache2 >= 2.2.34-70.5.1
  • apache2-devel >= 2.2.34-70.5.1
  • apache2-doc >= 2.2.34-70.5.1
  • apache2-example-pages >= 2.2.34-70.5.1
  • apache2-prefork >= 2.2.34-70.5.1
  • apache2-utils >= 2.2.34-70.5.1
  • apache2-worker >= 2.2.34-70.5.1
Patchnames:
sdksp4-apache2-13223
SUSE Linux Enterprise Software Development Kit 12 SP2
  • apache2 >= 2.4.23-29.3.2
  • apache2-devel >= 2.4.23-29.3.2
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1220
SUSE Linux Enterprise Software Development Kit 12 SP3
  • apache2 >= 2.4.23-29.3.2
  • apache2-devel >= 2.4.23-29.3.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1220
SUSE Linux Enterprise Software Development Kit 12 SP4
  • apache2-devel >= 2.4.23-29.24.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • apache2-devel >= 2.4.23-29.43.1
SUSE OpenStack Cloud 6
  • apache2 >= 2.4.16-20.10.1
  • apache2-doc >= 2.4.16-20.10.1
  • apache2-example-pages >= 2.4.16-20.10.1
  • apache2-prefork >= 2.4.16-20.10.1
  • apache2-utils >= 2.4.16-20.10.1
  • apache2-worker >= 2.4.16-20.10.1
Patchnames:
SUSE-OpenStack-Cloud-6-2017-1510
SUSE Studio Onsite 1.3
  • apache2 >= 2.2.34-70.5.1
  • apache2-devel >= 2.2.34-70.5.1
Patchnames:
slestso13-apache2-13223
openSUSE Leap 42.2
  • apache2 >= 2.4.23-8.9.1
  • apache2-debuginfo >= 2.4.23-8.9.1
  • apache2-debugsource >= 2.4.23-8.9.1
  • apache2-devel >= 2.4.23-8.9.1
  • apache2-doc >= 2.4.23-8.9.1
  • apache2-event >= 2.4.23-8.9.1
  • apache2-event-debuginfo >= 2.4.23-8.9.1
  • apache2-example-pages >= 2.4.23-8.9.1
  • apache2-prefork >= 2.4.23-8.9.1
  • apache2-prefork-debuginfo >= 2.4.23-8.9.1
  • apache2-utils >= 2.4.23-8.9.1
  • apache2-utils-debuginfo >= 2.4.23-8.9.1
  • apache2-worker >= 2.4.23-8.9.1
  • apache2-worker-debuginfo >= 2.4.23-8.9.1
Patchnames:
openSUSE-2017-865
openSUSE Leap 42.3
  • apache2 >= 2.4.23-13.1
  • apache2-debuginfo >= 2.4.23-13.1
  • apache2-debugsource >= 2.4.23-13.1
  • apache2-devel >= 2.4.23-13.1
  • apache2-doc >= 2.4.23-13.1
  • apache2-event >= 2.4.23-13.1
  • apache2-event-debuginfo >= 2.4.23-13.1
  • apache2-example-pages >= 2.4.23-13.1
  • apache2-prefork >= 2.4.23-13.1
  • apache2-prefork-debuginfo >= 2.4.23-13.1
  • apache2-utils >= 2.4.23-13.1
  • apache2-utils-debuginfo >= 2.4.23-13.1
  • apache2-worker >= 2.4.23-13.1
  • apache2-worker-debuginfo >= 2.4.23-13.1
Patchnames:
openSUSE-2017-865


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Performance Computing 12 SP5 apache2 Released
SUSE Linux Enterprise Server 11 SP1 apache2 Released
SUSE Linux Enterprise Server 11 SP3 apache2 Released
SUSE Linux Enterprise Server 11 SP3 LTSS apache2 Already fixed
SUSE Linux Enterprise Server 11 SP4 apache2 Released
SUSE Linux Enterprise Server 12 LTSS apache2 Released
SUSE Linux Enterprise Server 12 SP1 LTSS apache2 Released
SUSE Linux Enterprise Server 12 SP2 apache2 Released
SUSE Linux Enterprise Server 12 SP3 apache2 Released
SUSE Linux Enterprise Server 12 SP5 apache2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 apache2 Released
SUSE Linux Enterprise Server for the Raspberry Pi apache2 Released
SUSE Linux Enterprise Software Development Kit 11 SP4 apache2 Released
SUSE Linux Enterprise Software Development Kit 12 apache2 Released
SUSE Linux Enterprise Software Development Kit 12 SP3 apache2 Released
SUSE Studio Onsite apache2 Released