Upstream information

CVE-2017-9462 at MITRE

Description

In Mercurial before 4.1.3, "hg serve --stdio" allows remote authenticated users to launch the Python debugger, and consequently execute arbitrary code, by using --debugger as a repository name.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9 9
Vector AV:N/AC:L/Au:S/C:C/I:C/A:C AV:N/AC:L/Au:S/C:C/I:C/A:C
Access Vector Network Network
Access Complexity Low Low
Authentication Single Single
Confidentiality Impact Complete Complete
Integrity Impact Complete Complete
Availability Impact Complete Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 9
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Changed
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entry: 1043063 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • mercurial >= 2.3.2-0.17.1
Patchnames:
sdksp4-mercurial-13144
SUSE Linux Enterprise Software Development Kit 12 SP2
  • mercurial >= 2.8.2-14.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-981
SUSE Linux Enterprise Software Development Kit 12 SP3
  • mercurial >= 2.8.2-14.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA mercurial
openSUSE Leap 42.2
  • mercurial >= 3.8.3-2.5.1
  • mercurial-debuginfo >= 3.8.3-2.5.1
  • mercurial-debugsource >= 3.8.3-2.5.1
  • mercurial-lang >= 3.8.3-2.5.1
Patchnames:
openSUSE-2017-689


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP4 mercurial Released
SUSE Linux Enterprise SDK 12 SP2 mercurial Released