Upstream information

CVE-2017-9114 at MITRE

Description

In OpenEXR 2.2.0, an invalid read of size 1 in the refill function in ImfFastHuf.cpp could cause the application to crash.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 5.3
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entry: 1040114 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libIlmImf-Imf_2_1-21 >= 2.1.0-6.3.1
  • libIlmImf-Imf_2_1-21-32bit >= 2.1.0-6.3.1
  • openexr >= 2.1.0-6.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-398
SUSE Linux Enterprise Desktop 12 SP3
  • libIlmImf-Imf_2_1-21 >= 2.1.0-6.3.1
  • libIlmImf-Imf_2_1-21-32bit >= 2.1.0-6.3.1
  • openexr >= 2.1.0-6.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-398
SUSE Linux Enterprise Module for Desktop Applications 15
  • libIlmImf-2_2-23 >= 2.2.1-1.22
  • libIlmImfUtil-2_2-23 >= 2.2.1-1.22
  • openexr-devel >= 2.2.1-1.22
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libIlmImf-2_2-23
SUSE Linux Enterprise Server 11 SP4
  • OpenEXR >= 1.6.1-83.17.3.1
  • OpenEXR-32bit >= 1.6.1-83.17.3.1
  • OpenEXR-x86 >= 1.6.1-83.17.3.1
Patchnames:
slessp4-OpenEXR-13496
SUSE Linux Enterprise Server 12 SP2
  • libIlmImf-Imf_2_1-21 >= 2.1.0-6.3.1
  • openexr >= 2.1.0-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-398
SUSE Linux Enterprise Server 12 SP3
  • libIlmImf-Imf_2_1-21 >= 2.1.0-6.3.1
  • openexr >= 2.1.0-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-398
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libIlmImf-Imf_2_1-21 >= 2.1.0-6.3.1
  • openexr >= 2.1.0-6.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-398
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • OpenEXR >= 1.6.1-83.17.3.1
  • OpenEXR-32bit >= 1.6.1-83.17.3.1
  • OpenEXR-x86 >= 1.6.1-83.17.3.1
Patchnames:
slessp4-OpenEXR-13496
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libIlmImf-Imf_2_1-21 >= 2.1.0-6.3.1
  • openexr >= 2.1.0-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-398
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libIlmImf-Imf_2_1-21 >= 2.1.0-6.3.1
  • openexr >= 2.1.0-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-398
SUSE Linux Enterprise Software Development Kit 11 SP4
  • OpenEXR >= 1.6.1-83.17.3.1
  • OpenEXR-32bit >= 1.6.1-83.17.3.1
  • OpenEXR-devel >= 1.6.1-83.17.3.1
Patchnames:
sdksp4-OpenEXR-13496
SUSE Linux Enterprise Software Development Kit 12 SP2
  • openexr >= 2.1.0-6.3.1
  • openexr-devel >= 2.1.0-6.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-398
SUSE Linux Enterprise Software Development Kit 12 SP3
  • openexr >= 2.1.0-6.3.1
  • openexr-devel >= 2.1.0-6.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-398
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libIlmImf-Imf_2_1-21-32bit >= 2.1.0-6.3.1
  • openexr >= 2.1.0-6.3.1
Patchnames:
SUSE-SLE-WE-12-SP2-2018-398
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libIlmImf-Imf_2_1-21-32bit >= 2.1.0-6.3.1
  • openexr >= 2.1.0-6.3.1
Patchnames:
SUSE-SLE-WE-12-SP3-2018-398
openSUSE Leap 15.0
  • libIlmImf-2_2-23 >= 2.2.1-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libIlmImf-2_2-23
openSUSE Leap 42.3
  • libIlmImf-Imf_2_1-21 >= 2.1.0-10.3.1
  • libIlmImf-Imf_2_1-21-32bit >= 2.1.0-10.3.1
  • libIlmImf-Imf_2_1-21-debuginfo >= 2.1.0-10.3.1
  • libIlmImf-Imf_2_1-21-debuginfo-32bit >= 2.1.0-10.3.1
  • openexr >= 2.1.0-10.3.1
  • openexr-debuginfo >= 2.1.0-10.3.1
  • openexr-debugsource >= 2.1.0-10.3.1
  • openexr-devel >= 2.1.0-10.3.1
  • openexr-doc >= 2.1.0-10.3.1
Patchnames:
openSUSE-2018-229


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 openexr Released
SUSE Linux Enterprise Desktop 12 SP3 openexr Released
SUSE Linux Enterprise SDK 11 SP4 OpenEXR Released
SUSE Linux Enterprise SDK 12 SP2 openexr Released
SUSE Linux Enterprise SDK 12 SP3 openexr Released
SUSE Linux Enterprise Server 11 SP3 LTSS OpenEXR Not affected
SUSE Linux Enterprise Server 11 SP4 OpenEXR Released
SUSE Linux Enterprise Server 12 GA LTSS openexr Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS openexr Not affected
SUSE Linux Enterprise Server 12 SP2 openexr Released
SUSE Linux Enterprise Server 12 SP3 openexr Released
SUSE Linux Enterprise Workstation Extension 12 SP2 openexr Released
SUSE Linux Enterprise Workstation Extension 12 SP3 openexr Released