Upstream information

CVE-2017-9050 at MITRE

Description

libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the xmlDictAddString function in dict.c. This vulnerability causes programs that use libxml2, such as PHP, to crash. This vulnerability exists because of an incomplete fix for CVE-2016-1839.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.96 4.96
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
SUSE Bugzilla entries: 1039066 [NEW], 1039069 [RESOLVED / ], 1039661 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libxml2 >= 2.9.4-39.2
  • libxml2-2 >= 2.9.4-39.2
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-891
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-939
SUSE Linux Enterprise Desktop 12 SP2
  • libxml2 >= 2.9.4-39.2
  • libxml2-2 >= 2.9.4-39.2
  • libxml2-2-32bit >= 2.9.4-39.2
  • libxml2-tools >= 2.9.4-39.2
  • python-libxml2 >= 2.9.4-39.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-891
SUSE-SLE-DESKTOP-12-SP2-2017-939
SUSE Linux Enterprise Point of Sale 11 SP3
  • libxml2 >= 2.7.6-0.69.1
  • libxml2-doc >= 2.7.6-0.69.1
  • libxml2-python >= 2.7.6-0.69.3
Patchnames:
sleposp3-libxml2-13143
SUSE Linux Enterprise Server 11 SP3-LTSS
  • libxml2 >= 2.7.6-0.69.1
  • libxml2-32bit >= 2.7.6-0.69.1
  • libxml2-doc >= 2.7.6-0.69.1
  • libxml2-python >= 2.7.6-0.69.3
Patchnames:
slessp3-libxml2-13143
SUSE Linux Enterprise Server 11 SP4
  • libxml2 >= 2.7.6-0.69.1
  • libxml2-32bit >= 2.7.6-0.69.1
  • libxml2-doc >= 2.7.6-0.69.1
  • libxml2-python >= 2.7.6-0.69.3
  • libxml2-x86 >= 2.7.6-0.69.1
Patchnames:
slessp4-libxml2-13143
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libxml2 >= 2.9.1-26.15.1
  • libxml2-2 >= 2.9.1-26.15.1
  • libxml2-2-32bit >= 2.9.1-26.15.1
  • libxml2-doc >= 2.9.1-26.15.1
  • libxml2-tools >= 2.9.1-26.15.1
  • python-libxml2 >= 2.9.1-26.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-975
SUSE Linux Enterprise Server 12 SP2
  • libxml2 >= 2.9.4-39.2
  • libxml2-2 >= 2.9.4-39.2
  • libxml2-2-32bit >= 2.9.4-39.2
  • libxml2-doc >= 2.9.4-39.2
  • libxml2-tools >= 2.9.4-39.2
  • python-libxml2 >= 2.9.4-39.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-891
SUSE-SLE-SERVER-12-SP2-2017-939
SUSE Linux Enterprise Server 12-LTSS
  • libxml2 >= 2.9.1-26.15.1
  • libxml2-2 >= 2.9.1-26.15.1
  • libxml2-2-32bit >= 2.9.1-26.15.1
  • libxml2-doc >= 2.9.1-26.15.1
  • libxml2-tools >= 2.9.1-26.15.1
  • python-libxml2 >= 2.9.1-26.15.1
Patchnames:
SUSE-SLE-SERVER-12-2017-975
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libxml2 >= 2.9.4-39.2
  • libxml2-2 >= 2.9.4-39.2
  • libxml2-doc >= 2.9.4-39.2
  • libxml2-tools >= 2.9.4-39.2
  • python-libxml2 >= 2.9.4-39.2
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-891
SUSE-SLE-RPI-12-SP2-2017-939
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libxml2 >= 2.7.6-0.69.1
  • libxml2-devel >= 2.7.6-0.69.1
  • libxml2-devel-32bit >= 2.7.6-0.69.1
Patchnames:
sdksp4-libxml2-13143
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libxml2 >= 2.9.4-39.2
  • libxml2-devel >= 2.9.4-39.2
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-891
SUSE-SLE-SDK-12-SP2-2017-939
SUSE Linux Enterprise for SAP 12
  • libxml2 >= 2.9.1-26.15.1
  • libxml2-2 >= 2.9.1-26.15.1
  • libxml2-2-32bit >= 2.9.1-26.15.1
  • libxml2-doc >= 2.9.1-26.15.1
  • libxml2-tools >= 2.9.1-26.15.1
  • python-libxml2 >= 2.9.1-26.15.1
Patchnames:
SUSE-SLE-SAP-12-2017-975
SUSE Linux Enterprise for SAP 12 SP1
  • libxml2 >= 2.9.1-26.15.1
  • libxml2-2 >= 2.9.1-26.15.1
  • libxml2-2-32bit >= 2.9.1-26.15.1
  • libxml2-doc >= 2.9.1-26.15.1
  • libxml2-tools >= 2.9.1-26.15.1
  • python-libxml2 >= 2.9.1-26.15.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-975
openSUSE Leap 42.2
  • libxml2 >= 2.9.4-5.6.1
  • libxml2-2 >= 2.9.4-5.6.1
  • libxml2-2-32bit >= 2.9.4-5.6.1
  • libxml2-2-debuginfo >= 2.9.4-5.6.1
  • libxml2-2-debuginfo-32bit >= 2.9.4-5.6.1
  • libxml2-debugsource >= 2.9.4-5.6.1
  • libxml2-devel >= 2.9.4-5.6.1
  • libxml2-devel-32bit >= 2.9.4-5.6.1
  • libxml2-doc >= 2.9.4-5.6.1
  • libxml2-tools >= 2.9.4-5.6.1
  • libxml2-tools-debuginfo >= 2.9.4-5.6.1
  • python-libxml2 >= 2.9.4-5.6.1
  • python-libxml2-debuginfo >= 2.9.4-5.6.1
  • python-libxml2-debugsource >= 2.9.4-5.6.1
Patchnames:
openSUSE-2017-663
openSUSE-2017-711