Upstream information

CVE-2017-9022 at MITRE

Description

The gmp plugin in strongSwan before 5.5.3 does not properly validate RSA public keys before calling mpz_powm_sec, which allows remote peers to cause a denial of service (floating point exception and process crash) via a crafted certificate.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.96 7.12
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:C
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.9
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High

This issue is currently rated as having important severity.

SUSE Bugzilla entry: 1039514 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • strongswan >= 5.1.3-25.1
  • strongswan-doc >= 5.1.3-25.1
  • strongswan-ipsec >= 5.1.3-25.1
  • strongswan-libs0 >= 5.1.3-25.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-906
SUSE Linux Enterprise Server 11 SP4
  • strongswan >= 4.4.0-6.35.1
  • strongswan-doc >= 4.4.0-6.35.1
Patchnames:
slessp4-strongswan-13136
SUSE Linux Enterprise Server 12 SP2
  • strongswan >= 5.1.3-25.1
  • strongswan-doc >= 5.1.3-25.1
  • strongswan-hmac >= 5.1.3-25.1
  • strongswan-ipsec >= 5.1.3-25.1
  • strongswan-libs0 >= 5.1.3-25.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-906
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • strongswan >= 5.1.3-25.1
  • strongswan-doc >= 5.1.3-25.1
  • strongswan-hmac >= 5.1.3-25.1
  • strongswan-ipsec >= 5.1.3-25.1
  • strongswan-libs0 >= 5.1.3-25.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-906


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server 11 SP3 LTSS
  • SUSE Linux Enterprise Server 12 GA
  • SUSE Linux Enterprise Server for SAP 11 SP3
  • SUSE Linux Enterprise Server for SAP 12 GA
  • SUSE Linux Enterprise Server for SAP 12 SP1
strongswan